Development :  K-Meleon Forum
K-Meleon development related discussions. 
K-Meleon 74 b4 uses 97% of CPU
Posted by: losduarte
Date: June 09, 2014 10:58AM

Today, I downloaded an attempted to use 74 beta 4. I find that with 1-3 tabs open, version 74 beta 4 uses 97% of my CPU (as shown by Task Manager). The net effect is that navigation of the internet is impossible.

Machine: Dell Latitude d610
OS: Win XP, 32 bit
Ram: 2gb
Ram used by K-Meleon: approx 186,000
Unused Ram available when K-Meleon is active: 1,315,648

Interestingly, when I use bloated browsers like Pale Moon, consuming 338,160 RAM, Pale Moon only uses 2% of the CPU and navigates the internet just fine. This problem did not occur with K-Meleon 1.5.4.

What should I do?

Options: ReplyQuote
Re: K-Meleon 74 b4 uses 97% of CPU
Posted by: guenter
Date: June 09, 2014 10:36PM

You should use a naviator that works on Your system.

What contents and URLs are loaded in the three tabs?

Maybe reinstall. Only flash, flash games sites and sites heavy with JavaScript can drive up the CPU usage that far.

Options: ReplyQuote
Re: K-Meleon 74 b4 uses 97% of CPU
Posted by: rodocop
Date: June 10, 2014 03:50AM

Try reinstall KM as portable (there are option during the installation) - and look for results.

Or if you have it already portable - try vice versa: reinstall as full installation.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Options: ReplyQuote
Re: K-Meleon 74 b4 uses 97% of CPU
Posted by: misterp
Date: June 15, 2014 08:26AM

I assumed lots of people were seeing this and it wasn't being discussed.

I see this on all my machines, that 1 core gets taken over sometimes(usage ~50% on 2-core and ~25% on 4-core).

It doesn't seem to be reliably repeatable, at least what I am seeing.

Example machine: Win 7-64bit, 8Gb RAM, corei5-2500K, KM74b4
On Tools > Privacy: block java, block flash, block images, block advertisement
10Mbps wired connection
I never use the KM installer, so the installer is run on a virtual machine that never gets used and then the KM folder is copied to the location it uses. I use a profile.ini that then points to profiles.ini on another (virtual) disk.

I have only seen it occur when I load multiple sites via the session manager (actually via a macro I wrote to add tabs from a session as tabs in the current session which was posted to this forum a long time ago). When the core does go to near 100% memory use also increases eventually crashing K-Meleon. It seems to happen roughly 5-20% of the time when adding 5 or so tabs.

I can't get it to do it now, how surprising is that? I don't remember how to submit a crash report, but I could certainly do that if told how.

Options: ReplyQuote
Re: K-Meleon 74 b4 uses 97% of CPU
Posted by: misterp
Date: June 15, 2014 08:33AM

Just happened. No crash, memory went up to 991,048K of 8Gb and KM became greyed out with the (Not Responding) header and nothing could be done with it.

I don't really recall, there may never be a crash, just displaying of the Windows `K-Meleon is not responding message' with the Check for a solution(online), Close the program, Wait for a response options.



Edited 1 time(s). Last edit at 06/15/2014 08:36AM by misterp.

Options: ReplyQuote
Re: K-Meleon 74 b4 uses 97% of CPU
Posted by: adodupan
Date: June 17, 2014 02:59PM

Quote
misterp
I assumed lots of people were seeing this and it wasn't being discussed.

misterp, what's the point, Dorian knows about it.

Mikk had mentioned it:
Quote
Mikk
I'm not sure I would want to use KM providing an infrastructure as you are recommending (and I have a central heating equipment for winter but no air conditionig for summer in my appartement to use a Pentium 4 :D).

It's a good joke, but also true.
Here is an example. There are many such websites and of course, problem is not in websites.
Dorian should be focused on fixing it.

Regards to all

Options: ReplyQuote
Re: K-Meleon 74 b4 uses 97% of CPU
Posted by: misterp
Date: June 17, 2014 08:54PM

Quote
adodupan
...
Here is an example.
...

I have no problem with CPU on that site as I have flash and images blocked as was stated. Of course, I get a CPU problem if I run the flash.

My problem occurs with no flash running, unless something gets past flashblock. And still the CPU usage goes up.

Edit: Just generated the problem and checked in process manager that there is no flash running.



Edited 1 time(s). Last edit at 06/17/2014 09:03PM by misterp.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.