update gecko for v1.7
Posted by: jo23
Date: June 06, 2013 04:29PM

the binary i have is using gecko 1.9.2.14pre
however the last release of gecko is 1.9.2.28 of mars2012 meaning better security and stability .
i know we can modify the binary dll but its not the correct way because constant or static lib are sometimes changed . we need recompile the kameleon code and improve the history part

i can make some test (i have VC7pro ) but i don't find source: at source forge
there is code with 1.6.0 in the rc
where is the code for 1.6b2.5 1.7 1.7a2 ?

thanks



Edited 1 time(s). Last edit at 06/06/2013 04:31PM by jo23.

Re: update gecko for v1.7
Posted by: JamesD
Date: June 07, 2013 06:33PM

A really great help would be if you could produce that newer gecko engine. This link might help: https://developer.mozilla.org/en-US/docs/Developer_Guide/Build_Instructions?redirectlocale=en-US&redirectslug=Build_Documentation

I do not do C++ myself, so I can only hope this is relevant.

As for K-Meleon, maybe this will provide some answers.
http://kmeleon.sourceforge.net/wiki/BuildKMeleon

The code for KM 1.6.0 should be in SourceForge. Perhaps you can get there from something on this page. http://kmeleon.sourceforge.net/wiki/KMeleonCVS



Edited 1 time(s). Last edit at 06/07/2013 06:39PM by JamesD.

Re: update gecko for v1.7
Posted by: guenter
Date: June 08, 2013 11:54PM

Quote
JamesD

I do not do C++ myself, so I can only hope this is relevant.

As for K-Meleon, maybe this will provide some answers.
http://kmeleon.sourceforge.net/wiki/BuildKMeleon

Better use the page. http://kmeleon.sourceforge.net/wiki/BuildKMeleonDistribution

Section: http://kmeleon.sourceforge.net/wiki/BuildKMeleonDistribution#line73

You need to build the libs that are used to build K-Meleon even if You only want to recompile the history plugin. And the links guides You until where You have the libs.

You will definitely need to use the files here: http://kmeleon.sourceforge.net/wiki/?binary=internal%3A%2F%2Fb344e232045d36af17c7cf66826ecbde.zip

They IMHO contain Dorian's patches for the Mozilla code for 1.6 and later.

You have to work with the later Mozilla souce that is for K-Meleon 1.7 not the ones mentioned in the link.

p.s. AFAIK there used to be latest 1.7 GRE around by deadlock some time ago and possibly one by me.



Edited 4 time(s). Last edit at 06/09/2013 12:06AM by guenter.

K-Meleon forum is powered by Phorum.