Development :  K-Meleon Forum
K-Meleon development related discussions. 
Pages: 12Next
Current Page: 1 of 2
Fixed the K-meleon 1.6db+NS 100% now.
Posted by: dugbugoffice2
Date: August 12, 2012 09:23AM

The version of NS is 2.5 now. And you now have full options now with it.

There is an issue with frames with NS as it is with FireFox.
You can turn off the frames in about:config but it still works
when tested.
http://www.draac.com/framestest.html

All the security works, but the frames is still on.
K-meleon db 1.7 types works no frames, but the NS version of 1.6 does not.

Get K-meleon db's here:
http://home.dbdbdugbug.operaunite.com/Projects/content/KMFILES/Download-K-Meleon-db.html

K-meleon is getting behind, the engine in it is old. Mozilla ended the 3.6's
and there is no way get anything above the 3's to work.
My versions are more on security than compliance!!!!!!!!!!

Websites today are moving along & K-meleon can't always deal with these new websites.
The K-meleon-db 1.7 is more secure than the Firefox 3.6 it is based on with the same about:config settings.

But as I seen the K-meleon 1.6 NS is now the most secure.
Setting up NoScript with websites on the white list might be
hard in a way. But can be done.

It's even worse to set up K-meleon with a locked profile.
But the security is worth it! It stands with FireFox 19+ as is security.
K-meleon gets a 13 on security at http://www.browserscope.org
The K-meleon-db types with me gets attacked a lot & it does hold up
with a locked profile!

Again K-meleon is aimed at security not compliance!

Some HELP is here at:
http://home.dbdbdugbug.operaunite.com/Projects/content/KMFILES/A_KMFILES_HELP.html

I some issues with websites seems to be my settings & how websites react to them.
This happens with Firefox also I noticed. It's a file in your profile.
"webappsstore.sqlite" Some websites make it pop up. It's like a cookie kind of thing I think, so you can be tracked.
Just open it in note pad & delete all in it.
Then type in: Privacy Program
save it & set the file to hidden, Read-only archive!
Now nothing can be saved on the file.
This will help you in some websites!



Edited 7 time(s). Last edit at 03/05/2013 02:12PM by dugbugoffice2.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: kingsparrow
Date: August 12, 2012 11:34PM

so far so good for K-mel 1.6db+ns. I'll try it more out tomorrow and the others too.

seems to me you have also updatedthe 1.7db+ and the 1.6db+. thanks.............

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: 4td8s
Date: August 16, 2012 10:19PM

Quote
dugbugoffice2
The version of NS is 2.5 now. And you now have full options now with it.

There is an issue with frames with NS as it is with FireFox.
You can turn off the frames in about:config but it still works
when tested.
http://www.draac.com/framestest.html

All the security works, but the frames is still on.
K-meleon db 1.7 types works no frames, but the NS version of 1.6 does not.

where can we obtain KM 1.6db+ & 1.7db+, dugbugoffice2? (urls to these downloads please) smiling smiley

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: Kleon
Date: August 19, 2012 04:22AM

Quote
4td8s
where can we obtain KM 1.6db+ & 1.7db+, dugbugoffice2? (urls to these downloads please) smiling smiley

In case you don't know yet, try here:

http://home.dbdbdugbug.operaunite.com/Projects/content/KMFILES/Download-K-Meleon-db.html

——————————————————————————
Windows XP Pro SP3 | K-Meleon 1.6.0 Beta2
Trying out various subspecies of the lizard smiling smiley

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: kingsparrow
Date: August 28, 2012 09:14AM

seems to freeze on some sites like flickr, photo.net or in some others that require javacript enabled. Seems to load and not to load then freeze. But this could be a webpage error which runs a script unknown to k-mel. pressed the stop script button which appears, then it freeze. But with javasript dis-abled no problem on the same sites..............thanks.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: 4td8s
Date: August 29, 2012 06:50AM

Quote
kingsparrow
seems to freeze on some sites like flickr, photo.net or in some others that require javacript enabled. Seems to load and not to load then freeze. But this could be a webpage error which runs a script unknown to k-mel. pressed the stop script button which appears, then it freeze. But with javasript dis-abled no problem on the same sites..............thanks.

well kingsparrow it doesn't seem to "freeze" on the flickr.com and photo.net sites as I've just tested myself and with javascript enabled. I'm running KM 1.6db+ on Vista SP2 on an Intel Core duo laptop. try changing the UA (user agent to Firefox 3.6 or Firefox 15) and then visit those problematic web sites again on KM db+.

btw Kleon, thanks for the link to get the KM db+ downloads.



Edited 1 time(s). Last edit at 08/29/2012 06:51AM by 4td8s.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: kingsparrow
Date: August 29, 2012 09:45AM

http://www.flickr.com/groups/canonft/pool/

I have problems in this site and no problem on other flickr sites. No problem on the user agent. The way I understand it on this page site is when javascript is dis-abled it works fine and loads less images but when i enable javascript it seems to load more images and it could be a webpage error or a connection error, getting slower and freezing. Same thing with other webpage in photo.net with more images on windows xp pro sp3. I posted it here as a window would appear about the error and would ask me to stop the script or continue. When I press stop script, it's still frozen. Other than that it works fine in other webpages. Same problem on Seamonkey

I like surfing with no script and javascript dis-abled but sometimes pages are empty and would really require java s enabled.............thanks

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: ndebord
Date: August 29, 2012 10:49AM

Quote
kingsparrow
seems to freeze on some sites like flickr, photo.net or in some others that require javacript enabled. Seems to load and not to load then freeze. But this could be a webpage error which runs a script unknown to k-mel. pressed the stop script button which appears, then it freeze. But with javasript dis-abled no problem on the same sites..............thanks.

kingsparrow,

What OS are you using? I see the same freezing using javascript on some sites with this version and the earlier one too.

XP PRO SP3

N

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: kingsparrow
Date: August 30, 2012 09:12AM

same XP PRO SP3

I tried the same website with opera and it reloaded the pages blank with a message, "too many images". so it's a website error trying to run a a script. Like you I had had some freezes unlike before and I saw some sites very specific, recommending chrome, ie, and to have js enabled. It could also be that our browser of choice needs an update, as well as xp. With vista and newer os, they have better system resources like memory to consume with the newer browsers.........thanks

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: JamesD
Date: August 30, 2012 06:43PM

I tried the site with KM 1.6.0 Beta 2.4 with and without javascript enabled. Without js I got 74 images and with js enabled I got 114 images. I used PAGE PROPERTOES - IMAGES to obtain the image counts. My operating system is Win 7 (32 bit) and three gigs of ram.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: ndebord
Date: August 30, 2012 09:58PM

Quote
JamesD
I tried the site with KM 1.6.0 Beta 2.4 with and without javascript enabled. Without js I got 74 images and with js enabled I got 114 images. I used PAGE PROPERTOES - IMAGES to obtain the image counts. My operating system is Win 7 (32 bit) and three gigs of ram.

JamesD,

Where can I find this version?

TKs


XP PRO 1 Gig

N



Edited 2 time(s). Last edit at 08/30/2012 09:59PM by ndebord.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: JamesD
Date: August 31, 2012 07:02PM
Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: duffy98
Date: September 01, 2012 08:25PM

JamesD .... just saw your posting early today and downloaded this new version from your link. Haven't heard of this version before ... I'm still working on my settings so I haven't tried it out yet. Just a few quick questions ... is this version a project of yours? Just a few months ago I switched from Win 98SE to XP Pro. I see you are using Win 7 ... is this version more for the Win 7 OS or should XP also work OK? I don't understand how I never heard of it till today ... I always keep looking around for a newer version to try out. Thanks to ndebord for asking you for a link.

Without going into much detail ... what are the main changes or improvements over K-Meleon 1.6.0 Beta2 from Dec 2010?

thanks,

mike

... have another question, I'm trying to install Cookie Culler Plus with the K-Meleon Extensions Manager but it will not install. KM Extension Manager says it installed OK but there is no "button" or anything showing that it actually has installed. Should the KM Ext Manager work OK with this newer version?



Edited 2 time(s). Last edit at 09/01/2012 08:56PM by duffy98.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: JamesD
Date: September 02, 2012 01:16AM

@ duffy98

The exe file in beta 2.4 is the same as beta 2. There is a slightly newer engine and the privacy DLL has been recompiled. The spellchecker is automatically included. The HELP - TROUBLESHOOTING was completely revised.

I see no reason why the ext mgr system would not work, but I have not used it myself.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: duffy98
Date: September 02, 2012 08:41AM

JamesD ... got it all figured out. I like this version, it seems to be faster but I can't be sure. I like the fact that spell check was included. I still can't get the KM Extensions Manager to install that program but everything else is OK.

thanks

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: JujuLand
Date: September 02, 2012 05:22PM

Which version of extension manager ?
The one of KMES (by Jujuland) or for Kmext (by disrupted) ?

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: duffy98
Date: September 02, 2012 08:35PM

JujuLand ... I downloaded it from the K-Meleon Extensions Central ... K-Meleon Extensions Manager 7.4 and the version for Win XP ... Windows NT (2k, xp, vista) download NT version (7.4).

I had no trouble using K-Meleon Extensions Manager with K-Meleon 1.6.0 Beta2 (2010-12-12).

thanks

... just tried installing Cookie Culler Plus again and also Cookie Culler and Cookies Manager with K-Meleon Extensions Manager. It says installation was successful but nothing is installed. Also when you look in Extensions Manager there are no installations showing (0) ... in case a person wanted to uninstall something.



Edited 1 time(s). Last edit at 09/02/2012 09:39PM by duffy98.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: JamesD
Date: September 02, 2012 10:18PM

@ duffy98

I just loaded the extension mgr (7.4) on a new copy of KM 1.6 beta 2.4 and used it to load Cookie Culler. I see that in the listing of extensions and I see it in the tools menu. I also loaded Cache Size and I see it in the listing of extensions.

I cannot see why it would not work for you.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: duffy98
Date: September 02, 2012 10:54PM

JamesD ... very interesting. I just re-installed KM Extensions Manager in case something didn't install correctly the first time. I tried Cookie Culler Plus again and nothing is installed. Nothing showing in the Tools tab, Extensions Manager or anywhere. I turned Javascript on and off also. I guess it's only something with my setup unless a few other reports come in.

thanks


... I went ahead and just manually installed Cookie Culler Plus and all is OK with doing it that way.



Edited 1 time(s). Last edit at 09/02/2012 11:48PM by duffy98.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: duffy98
Date: September 05, 2012 09:59PM

JamesD ... have another question about something being different with your version over the KM 1.5.4 version. In the KM 1.5.4 version when you are at any web page and you click on a link there will be the hour glass running to the right side of the arrow so that a person knows that the click did take and the computer is going to that link. In your version there is no running hour glass and sometimes I find myself clicking a second or third time thinking nothing is happening. Just wondering if this is the standard in your version or is there a setting somewhere in Preferences that would make the running hour glass visible?

thanks

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: JamesD
Date: September 05, 2012 11:19PM

@ duffy98

You are correct. That is the way the 1.6.0 version works. I don't know why it is that way or how to change it. Only thing you can do is keep an eye on the status bar.

Edit: I just checked and 1.7 is the same way.



Edited 2 time(s). Last edit at 09/05/2012 11:21PM by JamesD.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: ndebord
Date: September 08, 2012 08:04AM

Quote
duffy98
JamesD ... very interesting. I just re-installed KM Extensions Manager in case something didn't install correctly the first time. I tried Cookie Culler Plus again and nothing is installed. Nothing showing in the Tools tab, Extensions Manager or anywhere. I turned Javascript on and off also. I guess it's only something with my setup unless a few other reports come in.

thanks


... I went ahead and just manually installed Cookie Culler Plus and all is OK with doing it that way.

duffy98,

In my experience, KEIH always works, whereas the manager sometimes fails. Not a clue why.

P.S. Not counting JuJu's executable extensions which work differently than the rest.

N



Edited 1 time(s). Last edit at 09/08/2012 08:05AM by ndebord.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: duffy98
Date: September 08, 2012 04:20PM

Thanks ndebord for the info ... sorry for being stupid but what does KEIH stand for? I just can't figure it out. thanks

... from your post: "In my experience, KEIH always works"



Edited 1 time(s). Last edit at 09/08/2012 04:29PM by duffy98.

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: ndebord
Date: September 09, 2012 10:54AM

Quote
duffy98
Thanks ndebord for the info ... sorry for being stupid but what does KEIH stand for? I just can't figure it out. thanks

... from your post: "In my experience, KEIH always works"

http://kmext.sourceforge.net/keih/KEIH.zip

http://kmeleon.sourceforge.net/forum/read.php?1,94714,94742#msg-94742

The original before KMET.

N

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: kingsparrow
Date: September 13, 2012 09:53AM

Quote
ndebord
Quote
kingsparrow
seems to freeze on some sites like flickr, photo.net or in some others that require javacript enabled. Seems to load and not to load then freeze. But this could be a webpage error which runs a script unknown to k-mel. pressed the stop script button which appears, then it freeze. But with javasript dis-abled no problem on the same sites..............thanks.

kingsparrow,

What OS are you using? I see the same freezing using javascript on some sites with this version and the earlier one too.

XP PRO SP3

found out that most of the problems in some websites which recommends the latest, newest browsers could all be solved by using a newer updated user agent string. Newer than the ones inside K-mels instal..............

Options: ReplyQuote
Re: Fixed the K-meleon 1.6db+NS 100% now.
Posted by: dugbugoffice2
Date: September 22, 2012 10:11PM

K-meleon is getting behind, the engine in it is old. Mozilla ended the 3.6's
and there is no way get anything above the 3's to work.
My versions are more on security than compliance.
Websites today are moving along & K-meleon can't always deal with these new websites.

Options: ReplyQuote
K-meleon 1.6db+NS "crash" on exit under Vista/Win7
Posted by: 4td8s
Date: September 27, 2012 12:47PM

since KM-1.6db+NS is using gecko 1.9.1.x much like Fred's unofficial KM-16-S20xx/KM-16-FF35xx and official KM 1.6 alpha/beta releases, KM-1.6db+NS still suffers from occasional crashes when exiting/closing the browser window with multiple tabs open.

I have not encountered these occasional "crash" issues with KM-1.7db+

Options: ReplyQuote
Re: K-meleon 1.6db+NS "crash" on exit under Vista/Win7
Posted by: kingsparrow
Date: September 27, 2012 07:16PM

seems I was using an older kmel-db,8/12/12. The newer was 8/18/12. I have no problem on kmel 1.6db+ns and 1.7db-, amazingly, surpisingly I was using kmel as the default use agent engine..........I was beginning to have sorts of problem with an earlier version when changing user agent strings, but with kmel update as a default now, it's smoother.

Thanks dugbud
http://home.dbdbdugbug.operaunite.com/Projects/content/KMFILES/Download-K-Meleon-db.html

Options: ReplyQuote
Re: K-meleon 1.6db+NS "crash" on exit under Vista/Win7
Posted by: 4td8s
Date: October 12, 2012 05:21AM

Quote
4td8s
since KM-1.6db+NS is using gecko 1.9.1.x much like Fred's unofficial KM-16-S20xx/KM-16-FF35xx and official KM 1.6 alpha/beta releases, KM-1.6db+NS still suffers from occasional crashes when exiting/closing the browser window with multiple tabs open.

I have not encountered these occasional "crash" issues with KM-1.7db+

I seem to not encounter any crashes issues on exit with JamesD's unofficial KM-1.6beta2.5 release on Vista/Win7.

perhaps dugbugoffice2 may want to update his KM1.6db+ releases to what JamesD has with KM1.6b2.5, which has newer privacy.dll KM plugin than KM1.6db+ and newer gecko dll files.



Edited 1 time(s). Last edit at 10/12/2012 05:23AM by 4td8s.

Options: ReplyQuote
Re: K-meleon 1.6db+NS "crash" on exit under Vista/Win7
Posted by: KMfan
Date: December 19, 2012 01:57PM

The K-meleon-1.6db+NS download link is working, but when i download it on my PC there are errors when extracting from 7z archive (i extract it with 7z and Winrar, same errors) Something about Unknown method in ... 549 total errors.

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


K-Meleon forum is powered by Phorum.