1.7.0 will not open from external link
Date: July 15, 2011 04:17AM

I recently horked up my poor K-Meleon so badly with a wonky extension that I decided to start over. Instead of the version I had before, I thought it would be cool to try 1.7.0. So far so good, mostly, but it won't open from any external link.

K-M is my default browser, so it opens when, for instance, I click a link in a Twitter client. But 1.7.0 just gives me this message:
---------------------------
Could not initialize XPCOM. Perhaps the GRE
is not installed or could not be found?
---------------------------

Same thing with other link sources -- *.url files, program installers that love to display their home pages, online help in other programs.

Anybody got a fix handy? I've never come up against this one before. I found a couple of threads that relate to it, but the solution is not there. smiling smiley

A.K.A. Arual the Wyrd

Re: 1.7.0 will not open from external link
Posted by: JujuLand
Date: July 15, 2011 05:34AM

I know it's not a very good solution, but the trick for now is perhaps to replace K-Meleon.exe in associations by a bat file which goes to K-Meleon folder and launch it.

@echo off
cd "c:\Program Files\K-Meleon"
K-Meleon %1

It ought to work

We have the same problem under Linux

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: 1.7.0 will not open from external link
Date: July 15, 2011 06:21AM

Thanks, I'll try that. Any ol' hack that works! grinning smiley

ETA: batchfile nees a little tweaking, but I'll work it out now that I have something to aim at.

ETA2: drat. not working. needs something and I still don't know what.

A.K.A. Arual the Wyrd



Edited 2 time(s). Last edit at 07/15/2011 06:41AM by Matera the Mad.

Re: 1.7.0 will not open from external link
Date: July 18, 2011 09:55AM

Further observations:

I can't open saved pages by double-clicking either. I can drag anything in, or use SendTo. The oddest thing is the difference between two program launchers that I use. Both have identical entries for K-M, but one works and the other doesn't. The solution for the one that doesn't work is to use a shortcut rather than the exe as target.

NOW the lightbulb is blazing over my head. I make a shortcut in the K-M folder and put one simple line in the batchfile: E:\K-meleon\k-meleon.lnk and associate .htm files with it.

Voilá! K-M opens the clicked file.

It's damned kludgy, but it works. smiling smiley

A.K.A. Arual the Wyrd



Edited 1 time(s). Last edit at 07/18/2011 09:56AM by Matera the Mad.

K-Meleon forum is powered by Phorum.