Development :  K-Meleon Forum
K-Meleon development related discussions. 
KM1.6 - win9x - Clipboard Bug
Posted by: siria
Date: November 16, 2010 03:01AM

Have examined that closer now, and there's definitely a problem with the "setclipboard" command in KM1.6 on win9x (with KernelEx).
The problem is only the format, if anything is copied with "setclipboard" it doesn't seem to exist in ANSI-format there, only in Unicode, even the most simple letters. Have read somewhere (wikipedia?? MS help?) that the clipboard should automatically hold various formats of the stuff in it or something like that...

The result is that those copies can only be inserted into UTF files, while when trying to insert it into ANSI-files the clipboard appears completely empty, even the "paste" command grayed out. For example in Notepad2.

This affects also the URL bar, "paste" is grayed.
When using Ctrl+V, the URL bar becomes completely empty.

Have tested with borrowing the macros.dll from KM154, but didn't help.
Ctrl+C, "ID_COPY_LINK_LOCATION" and "ID_EDIT_COPY" work normal, no bugs.

This could very well also have something to do with that URLBAR history bug on win9x, when opening it with that little "down arrow" next to the URL bar, and it tries to open just the first character of the chosen history URL (a workaround with alternative menu see here: http://kmeleon.sourceforge.net/forum/read.php?3,111752,111875#msg-111875 )

To avoid misunderstandings, unicode is long since installed, I can write and edit in UTF-8 without any probs in my editors!

Just don't have UTF-16 it seems, pages like http://userstyles.org/styles/18619 show a bunch of weird rectangle UTF-16 signs with each 4 tiny letters inside them, the rest of the page is normal english. In KM1.5.x those characters appear as "?????" instead.



Edited 2 time(s). Last edit at 11/16/2010 03:09AM by siria.

Options: ReplyQuote
Re: KM1.6 - win9x - Clipboard Bug
Posted by: siria
Date: November 16, 2010 03:08AM

A little macro for easier testing:

# ErrorTest9x.kmm, version 2010-11-15
# Creates menu "TEST" in Tools + Selection-Context + Link-Context

ErrorTest9x_clip1{
$_i=prompt("","cliptest1","xx");
setclipboard($_i);
alert($_i,"cliptest1");
}

ErrorTest9x_clip2{
$_i=$SelectedText;
setclipboard($_i);
alert($_i,"cliptest2");
}

ErrorTest9x_clip3{
$_i=$LinkURL;
setclipboard($_i);
alert($_i,"cliptest3");
}

_ErrorTest9x_BuildMenu{
setmenu("TEST",macro,"setclipboard: Input via prompt",ErrorTest9x_clip1,-1);
setmenu("TEST",macro,"setclipboard: Copy Selected Text",ErrorTest9x_clip2,-1);
setmenu("TEST",macro,"setclipboard: Copy Link Target",ErrorTest9x_clip3,-1);
}

#-------------------------------------------------------------------------------
$OnInit=$OnInit."_ErrorTest9x_BuildMenu;";
$macroModules=$macroModules."ErrorTest9x;";

#-------------------------------------------------------------------------------
Menu_TEST {
setmenu(Misc,popup,"TEST");
setmenu(Selection,popup,"TEST");
setmenu(LinkPopup,popup,"TEST");
}
index($OnInit,"Menu_TEST;")>-1 ? 0 : $OnInit=$OnInit."Menu_TEST;";

Options: ReplyQuote


K-Meleon forum is powered by Phorum.