Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 24, 2010 07:45AM

Does someone know what Mozilla product might have the correct componet files to update the KM 1.7.0a code?

I have copied six files for the preferences system into 1.7.0 and they seem to work OK. I will need to test more.

I see the 1.7.0 version uses 1.9.2.5pre and I was trying to find the latest product which uses a compatible Gecko engine. The plan was to copy the matching componet files into 1.7.0. I tried by getting FF but all the files there are js instead of xpt.

Perhaps some version of Seamonkey might be correct?

Re: Update Gecko for KM 1.7.0 possible?
Posted by: desga2
Date: October 24, 2010 07:25PM
Re: Update Gecko for KM 1.7.0 possible?
Posted by: guenter
Date: October 24, 2010 08:38PM

Quote
JamesD
Does someone know what Mozilla product might have the correct componet files to update the KM 1.7.0a code?

I have copied six files for the preferences system into 1.7.0 and they seem to work OK. I will need to test more.

I see the 1.7.0 version uses 1.9.2.5pre and I was trying to find the latest product which uses a compatible Gecko engine. The plan was to copy the matching componet files into 1.7.0. I tried by getting FF but all the files there are js instead of xpt.

Perhaps some version of Seamonkey might be correct?


e.g. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12pre) Gecko K-Meleon/1.7.0 will run smiling smiley That GRE is from a Firefox 3.6.12pre. And later ones will probably also run. SeaMonkey and XulRunner builds based on that GRE will also be suitable. Firefox 4 and builds based one the same GRE 2 engine are no go (K-Meleon1.7.exe does not start with current Firefox 4 components. Tested with: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101023 Firefox/4.0b8pre).

How 2: I always start the procedure with copying K-Meleon.exe over. I only invest more effort when it starts at all.

If it started successfully I shut it down and start to copy over: desga2's newest chrome, I delete ./defaults folder and replace it with K-Meleon's defaults folder, I create a profile.ini (to make its profiles old style self contained), I copy over missing folders ./skins, macros & kplugins.

Now I start it again and open ErrorConsole. Error Console will complain about errors in components. Now I will delete all *.js files that cause a complaint.

Else I delete all ./components/*.s files that Dorian did not use.

Mozilla.org usually builds all components needed to run any XUL application.

The number of ./componets/*.xpt of builds can vary because You can join the individual xpt to a big single one (starts faster). That is done by a script and xpt_link.exe after the build.

The number of ./components/*.dll can vary because they can be linked into an exe (see the big 7 mb firefox.exe of Firefox 2) or dll (see the big Xul.dll of the firefox-3.6.12pre.en-US.win32 that I mentioned as running K-Meleon 1.7 example).

The build params of .mozconfig to build & link ./components/*.dll into a big exe are

ac_add_options --disable-shared --enable-static

The build params of .mozconfig to build & link ./components/*.dll into a big Xul.dll are

ac_add_options --enable-libxul

K-Meleon project usually only builds the subset of components that is used by a web browser! The xpt and dll files of this subset are rarely joined.

The build params of .mozconfig to build individual ./components/*.dll are

ac_add_options --disable-libxul
ac_add_options --enable-shared

K-Meleon 1.6.and later has AFAIK only a maximum of 3 native files in ./components/ wallet.xpt/dll and jsbridge.xpt.



Edited 1 time(s). Last edit at 10/24/2010 09:10PM by guenter.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 24, 2010 10:04PM

Thanks desga2 and guenter.

I am going to print your info and use as a check list for my attempt.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: guenter
Date: October 24, 2010 10:31PM

Quote
JamesD

I am going to print your info and use as a check list for my attempt.

I tried to send You a mail.

Not all the info is needed / unless You have an Mozilla Build environment set up.


Download the files archive from Mozilla.org, extract & do a folder compare.

1.) delete the blue redundant FF or SM files.

2.) copy marked K-Meleon Files plus replace ./chrome and ./defaults with K-Meleon files.

That would be my kludgy approach anyway grinning smiley





Edited 1 time(s). Last edit at 10/24/2010 11:31PM by guenter.

Attachments: FileCompare.gif (88.4 KB)  
Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 25, 2010 03:40AM

I have tried the Seamonkey files and have made them work. I did not get to the job of deleting the redundant files. I don't think the Seamonkey has a later Gecko than the original KM 1.7.0.

Seamonkey files KM 1.7.0 rv:1.9.1.15pre) Gecko
Original KM 1.7.0 rv:1.9.2.5pre) Gecko

I guess I will try the other link that desga2 provided.

I did not get a crash on exit with the Seamonkey files.

Thanks for the additional info.

Which file has the information displayed on HELP - ABOUT? I must make sure that I don't replace that file with the preBeta stuff. I get a wrong KM version when I do.

Edit: I got your email. Thanks.



Edited 1 time(s). Last edit at 10/25/2010 03:48AM by JamesD.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: Fred
Date: October 25, 2010 04:46AM

Seamonkey still uses Gecko 1.9.1.x , the new release of Seamonkey 2.0.9
is now at 1.9.1.14 .
Firefox 3.6.x uses Gecko 1.9.2.x, the new release of Firefox 3.6.11
is now at 1.9.2.11 .
There is still a Firefox 3.5.14 supported, the new release has
1.9.1.14, the same as Seamonkey 2.0.9 .
Gecko 1.9.1.14 is not older than Gecko 1.9.2.11 , they are just
two different branches, namely 1.9.1 and 1.9.2 .
So 1.9.1.15pre is much newer than 1.9.2.5pre , because 1.9.2 is
now at 1.9.2.11 .

Fred

Re: Update Gecko for KM 1.7.0 possible?
Posted by: guenter
Date: October 25, 2010 04:58AM

Quote
JamesD

I guess I will try the other link that desga2 provided.

Which file has the information displayed on HELP - ABOUT? I must make sure that I don't replace that file with the preBeta stuff. I get a wrong KM version when I do.

Edit: I got your email.

1.) & 3.) It refers to the same GRE version as desga2's link has provided.

2.) URL= "about:" or via Help.

Both call: ./k-meleon/chrome/embed.jar/content/global/about.xhtml

K-Meleon & version is defined in .defaults/pref/kmeleon.js You can easily edit the values smiling smiley

pref("general.useragent.vendor", "K-Meleon");
pref("general.useragent.vendorSub", "1.7.0");

You will get the right GRE version to hold them apart anyway since kko gave about.xhtml a Java Script function that reads out the GRE version from a dll. smiling smiley



Edited 1 time(s). Last edit at 10/25/2010 05:08AM by guenter.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 25, 2010 09:23AM

I am getting very confused now. When 1.6.0 and 1.7.0 came out they used Gecko 1.9.1 and 1.9.2 respectively. If Gecko 1.9.1 is now newer than 1.9.2 should I be working to update 1.6.0 instead of 1.7.0?

Re: Update Gecko for KM 1.7.0 possible?
Posted by: Fred
Date: October 25, 2010 11:15AM

1.9.1.14 and 1.9.2.11 both have the necessary security updates
included.
Firefox 3.6.x uses 1.9.2, Seamonkey 2.0.x and the still
supported Firefox 3.5.x use 1.9.1 .
You can update KM 1.6 and KM 1.7 both either with the
latest Gecko engine 1.6.2.11 or also 1.6.1.14 (or 1.6.1.15pre
from Seamonkey Tinderbox, where the dlls are still separate,
while Seamonkey 2.0.9, which is the latest release, contains
all the dlls inside seamonkey.exe, which is less suitable to be
used in K-Meleon). Firefox has a different architecture than
Seamonkey, but its big file xul.dll can also be used for
K-Meleon.
Files coming from the upcoming Firefox 4.0 cannot be used
with the existing k-meleon.exe files up to now, but Firefox 3.6.x
should still get Gecko updates for up to one year, as we can hope.

Fred

Re: Update Gecko for KM 1.7.0 possible?
Posted by: guenter
Date: October 25, 2010 03:56PM

Whether dll are separate, linked into a big exe or a xul dll are build options.
Mozilla.org files with big Xul.dll are good enough for a private update.

Dorian patches the GRE code for official updates. Official versions top priority is not speed but compatibility to most (if not all) machines. Win98 versions (not even with kernelX) are not (fully) supported by K-Meleon.exe. If I completely understood procedure and intentions.

1.7 uses the GRE that has the slightly faster JavaScript JIT compiler. Tested.
Both 1.9.1. and 1.9.2. support recent HTML developments.

1.7 is a test IMHO how much work/time must be invested in future for the next version.
Much from what I read between the lines of Dorian's comment about 1.7.

p.s But that all is deduced from what I observe - only the devs know it for sure.



Edited 2 time(s). Last edit at 10/25/2010 08:07PM by guenter.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 25, 2010 07:54PM

The one I had downloaded was Seamonkey 2.0.10pre. Sounds to me like that one should go in the KM 1.6 path. I am currently using KM 1.6.0a4 for most of my surfing.

I think the preBeta from Desga2 is built on that one. My next try will be to update my preBeta with the Seamonkey code. Absolute speed in js is not my main requirement. Just want to the code as updated as possible.

Thanks again for all the help.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: guenter
Date: October 25, 2010 08:09PM

For surfing I much prefer K-Meleon's official patched dev versions. smiling smiley

Re: Update Gecko for KM 1.7.0 possible?
Posted by: 4td8s
Date: October 26, 2010 06:30AM

so, when will there be a new KM 1.7.0 alpha available for download?

Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 26, 2010 08:28PM

Quote
4td8s
so, when will there be a new KM 1.7.0 alpha available for download?

I don't know. I was first going to try to update desga2's preBeta with code from Seamonkey. That has not gone as well as I had hoped. I was keeping a list of my actions and I will share it with you.
01. Used 7Zip to extract seamonkey-2.0.10pre.en-US.win32.zip to a folder.
02. Copied k-meleon.exe from my KM preBeta folder to the Seamonkey folder.
03. Executed the KM exe and it opened with this file:
      chrome://navigator-region/locale/region.properties.
04. Exited KM.
05. Replaced /chrome folder with the one from KM preBeta.
06. Replaced /defaults folder with the one from KM preBeta.
07. Replaced /modules folder with the one from KM preBeta.
08. Added /skins, /macros, and /kplugins folders from KM preBeta.
09. Added profile.ini and readme.html from KM preBeta.
10. Started KM and got an error.
11. Restarted KM and selected not to resume previous session.  KM opened OK.
12. Restarted KM and changed to Klassic skin, Favorites, other minor pref changes.
13. Removed /dictionaries, /extensions, and /isp folders.
14. Restarted KM and went to some sites, started my email from the button and 
    zoomed in and out.  Tried history - error "could not load Mozilla history".
    Looked in profile and confirmed that there is not a "history.dat" file.
15. Looked in preferences and confirmed 9 days global history and history plugin.
16. Tried to test the URL bar history but when I tried to type a URL into the bar,
    I could could get only one letter typed.  Second letter caused a crash.

At this time, I am not sure I will continue this effort. I have no idea what to change to make these errors go away.

Edit: Many changes in the /components folder between KM and Seamonkey. I do not think it is possible to move forward with my limited knowledge. Not very hard to see why it is taking Dorian some time to adapt our code. Many xpt functions moving to js and I have no idea if that is on a one to one basis or not.



Edited 1 time(s). Last edit at 10/27/2010 12:34AM by JamesD.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: desga2
Date: October 27, 2010 02:17AM

@ JamesD:
The crash problem with URL bar and start is due to load Seamonkey components not compatible with K-Meleon.
Only copy /components files included in preBeta version and update it with Seamonkey /components files, the rest of files don't work with K-Meleon.

K-Meleon in Spanish

Re: Update Gecko for KM 1.7.0 possible?
Posted by: Fred
Date: October 27, 2010 03:51AM

You basically did everything correctly.
I have also found the problem that the URL could not be written into the URL bar.
Therefore I added a URL button that opens a prompt, where the address can be written.
To spare you the trouble, I have uploaded an experimental variation KM-17alpha-S209
based on Gecko 1.9.1.15pre from Seamonkey Tinderbox. Look for it here :

drop.io/eichhein

When starting for the first time you will get an error, when the profile is being created.
Restart and select new Session, and it should work correctly.
If you have Vista, it could be that the browser has to be started once (but only once)
as an administrator.

Never use the URL bar, but only the URL button.
Don't change the content of the URL bar.

Regards

Fred

PS : I will try desga's proposition to eliminate some
files in the folder components, and see if the URL bar
will work then.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: Fred
Date: October 27, 2010 04:41AM

I have eliminated the unnecessary files already,
and uploaded the improved variation again to :

drop.io/eichhein

The URL address bar is now writable, and the
browser should work already at the first start.

Fred

Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 27, 2010 07:45AM

Quote
desga2
Only copy /components files included in preBeta version and update it with Seamonkey /components files, the rest of files don't work with K-Meleon.

I don't understand. There are few common files. PreBeta has many files of type "xpt". Seamonkey has many files of type "js".
See this picture: http://dl.dropbox.com/u/1522294/preBeta_and_seamonkey.jpg

Fred,

I will try to download your code.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 27, 2010 08:23AM

I have Fred's code running and also code which guenter send me.

guenter, your code has same history problem as mine. Won't show history.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: desga2
Date: October 29, 2010 02:12AM

@ JamesD:
Yes it's, Seamonkey 2.0.x and Firefox 3.5.x have a lot of features that K-Meleon haven't because this aren't compatibles and need to be adapted or because this are unnecesary for K-Meleon.
For this new features, JavaScript language is used (for portability and comfort) instead the old xpt compiled files.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 10/29/2010 02:12AM by desga2.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: JamesD
Date: October 29, 2010 03:50AM

Yes, I have seen that. I tried a Seamonkey 2.x and the KM 1.7 exe would not start in it. I think I will leave the update stuff to others who have more knowledge of it than do I.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: guenter
Date: October 29, 2010 04:11AM

Quote
JamesD
I tried a Seamonkey 2.x and the KM 1.7 exe would not start in it. I think I will leave the update stuff to others who have more knowledge of it than do I.

The same here.

You would first compile Moz 2.and then You have to recompile (link?) K-Meleon.exe against the GRE's core files in sdk - no idea how.

Quote
JamesD
guenter, your code has same history problem as mine. Won't show history.

Else we would be devs grinning smiley



Edited 1 time(s). Last edit at 10/29/2010 04:17AM by guenter.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: Fred
Date: October 29, 2010 08:25AM

As Firefox and Seamonkey had an emergency update
today because of a zero-day exploit, and Seamonkey
is now at version 2.0.10, I have updated the
KM-17 variation again and have uploaded it again.
Look at

drop.io/eichhein

I will put the update address now also into the
General Forum for interested users.
Note: Flash in Windows works okay, but not
in Linux with wine up to now.

Fred

Re: Update Gecko for KM 1.7.0 possible?
Posted by: panzer
Date: October 30, 2010 04:30PM
Re: Update Gecko for KM 1.7.0 possible?
Posted by: desga2
Date: October 31, 2010 02:52AM


Think someone now that Facebook is good? mad smiley

K-Meleon in Spanish



Edited 2 time(s). Last edit at 10/31/2010 02:54AM by desga2.

Re: Update Gecko for KM 1.7.0 possible?
Posted by: Fred
Date: October 31, 2010 05:08AM

It's a shame that drop.io will disappear.
The big shots buy up everything that could
compete with them in some way.
They have the money to persuade anybody to sell.
The user is left high and dry.
A full replacement which does not require registration
seems to be hard to find.

Fred

Re: Update Gecko for KM 1.7.0 possible?
Posted by: jmillar
Date: November 04, 2010 05:04AM

Thanks for the S2010 update, Fred! Everything is working just fine. :-)

Replacement for drop.io
Posted by: Frank
Date: November 13, 2010 09:57PM

Dear Fred

You may try out these services (to replace drop.io) :

http:ifile.it

https:/wetransfer.com

rgds
frank

Re: Replacement for drop.io
Posted by: Fred
Date: November 13, 2010 10:44PM

Thanks for the links. I will have a look at them.
drop.io did need no registration and no email, unlike
the other sites that I know. That made it so convenient.

Fortunately, I got now the opportunity to use the
K-meleon externsions site Kmext.
I have uploaded some files already there, and I will
upload other updated variations, as soon as I will have
made them. Look inside the folder

http://kmext.sourceforge.net/fred

The older variations should still be available
at drop.io/eichhein until December 15th .

Regards

Fred

K-Meleon forum is powered by Phorum.