Re: WHERE HAVE MY FAVORITES GONE?
Posted by: desga2
Date: January 26, 2007 04:53AM

Hi Furl,

Are you administrator user in your system?
I think that K-Meleon not can save the changes in config files, your user haven't rigths to write in K-M config file or files are cheked as 'Only Read' in Properties.

Check in Edit -> Preferences -> Plugins status for IE Plugins and configuration.

Bye.

K-Meleon in Spanish

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Furl
Date: January 26, 2007 09:35AM

Thanks desga2. This computer always logs on to only the administrator account.
That is where I keep showing it the favorites. But I also try all the old
obsolete profiles on here. Yet none will show any favorites. I am very puzzled
as my KM Pro, K-Ninja, Firefox, Bon Echo, etc. do fine with the favorites.
On the Mozilla products I added the extension Plain Old Favorites. I would
like to try any suggestions

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Furl
Date: January 29, 2007 05:12AM

There is no way to fix this??

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: guenter
Date: January 29, 2007 01:41PM

The problem is a setting specific to You system and instalation choices.
Check whether favorites plugin is activated - it is not by default.

btw. K-Ninja and k-meleon pro are the same broswer as k-meleon, they merely have some different settings (and pro is compiled with a different compiler).

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Furl
Date: January 30, 2007 12:18AM

Thanks Guenter. Yes I had to activate the Favorites plugin to be able to use
Favorites. Also this must be activated to use Advanced Preferences for the
Favorites. In Advanced Preferences I show it where Favorites are located.
I do this by showing it the Favorites for the toolbar folder. Although
I know it should already know where they are.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Furl
Date: January 30, 2007 02:31AM

Thanks for the help Guenter. I have found that I can create a new profile and it
works. I can replace some components of an old profile with those of a new one
and the old will work. So do you know which files control only the favorites?

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: guenter
Date: January 30, 2007 11:56AM

IE favorite plugin - is the one controling favorites. It must be activated either in Preferences or Extended Preferences (but perhaps Preferences is better to use)

p. s. I use IE Favorites plugin to bookmark accros browser versions - things that all browsers must know, and Netscape Bookmarks or Opera Hotlist for the rest. Maybe interesting - bookmarks is a html file and can be bookmarked. So I have a very old bookmarks.html in an old 0.8.2+ created by Dorian before he was official dev and that contains all my essential info that must not be lost.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Furl
Date: January 31, 2007 02:32AM

I was hoping to not have to discard all my profiles as there are very many.
But it looks as if wiping it all out and starting all over is the only
solution. The Favorites do show up on the old profiles. It is just that
only the word Favorites and the Favorites toolbar are visible. They
cannot find any of my Favorites. The toolbar is blank. If I add a Favorite
here where there are none it will be here next time I open the browser.
But to get to ALL the old Favorites I have to create new profiles.
These old ones are NOT working at finding the Favorites list.
Everything else on these profiles works fine.
I know you have tried much to help me. I appreciate that very much.
Thank you Guenter.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: desga2
Date: January 31, 2007 03:48AM

Hi, you can selected your Favorites folder in menus Edit -> Preference -> Plugins
Select IE plugin (activated) and press button 'Config...' Path for Favorites folder is usualy: 'C:\Documents and Settings[user]\Favorites\' (for win2000 and XP).

I don't know you like do exactly, but if you have problems i think that you can export Favorites to file .html an this file you can add all your favorites to this file (copy and paste with an text editor) and then you can import file or rename file as bookmarks.html (in your K-Meleon profile folder) for used Bookmarks with K-Meleon.

How much favorites files or folder have?
Like you conserved favorites or migrated to bookmarks?

I need more info and details. Thanks.

Greetings.

K-Meleon in Spanish

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Furl
Date: February 01, 2007 04:37AM

Desga2, thanks many times. I have used KM for years and never knew what the
Configure button was for. That solves the problem. So I feel a bit stupid.
But then I never needed to Configure my favorites before. Thanks again
to you and Guenter. I'm sure lots of newbies have many basic problems such
as this. We need more persons like yourself and Guenter to guide them.
:-)

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: TeeDub
Date: February 01, 2007 09:01AM

For what it's worth, I too have had a problem with K-Meleon dropping, or losing its bookmarks folder, as well as all it's settings - like my entire profile had been eaten up! All my customized toolbar icons will occasionally return to the default positions and my bookmarks gone just like a clean install.

Fortunately, I've learned from reading these forums how to backup my profile, and as suggested earlier, saving my bookmarks.html file to a flash drive in case it happens.

I'm runing K-meleon 1.02 on Windows XP SP2. I'm not one to install/uninstall software often, so I can't imagine why this is happening..but I can tell you, it HAS happened at least 3 times since my last install of version 1.02.

The original poster DOES have a point...so the problem doesn't seem to be happening just to him. I know for a fact because it's happened to me also. The only difference is that I've learned how to back everything up so it doesn't become too big an issue for me.

Perhaps someone smarter than I can figure out why K-meleon seems to be deleting my profile/bookmarks/icons for no apparent reason?

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: guenter
Date: February 01, 2007 12:59PM

The prob seems to be that this is not happening often and is not reproducable.
I was also affected once with no damage ( i also backup ) - but other Mozillas seem to have similar problems recently. My TBird lost 3 Profiles in 1 week. Maybe time to update GRE?

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: desga2
Date: February 03, 2007 01:27AM

K-Meleon (and other Mozilla products) create a new profile when found your actually profile corrupted. This make you loose information at profile as preferences, toolbar (skin) configuration and bookmarks.

This problem can be success when not close good k-meleon program. When you exit of K-meleon, this save all profile again for changed preferences and configurations.
Also this problem can be originated by a virus in your system that modify or corrupted configuration .js files.

If you are a single user system (only you used your system) you can tried to make a copy of your bookmark.html in K-Meleon\defaults\profile folder. In this folder are files that generate a new profile. When k-meleon found corrupted profile and generate a new profile you will have all your bookmarks in the new profile.

When success this old profile is in k-meleon folder, is deleted or overwrited?
(i say that name of old profile is equal to new profile: xxxxxxxx.slt)
Is the old profile xxxxxxxx.slt in profile folder?

Greetings.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 02/03/2007 01:28AM by desga2.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: bmbase
Date: February 08, 2007 05:47AM

Just a friendly tip: backup all your bookmarks or keep them independently of browsers.

One of the most convenient tools for this is Bookmark Base. It supports all popular browsers including K-Meleon and allows you to carry bookmarks on USB drive (so called portable software).

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Gay Whittecar
Date: April 13, 2007 02:20AM

I just installed the new windows program and the prompt for "my favorites" disappeared. How do I get it back?

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: guenter
Date: April 13, 2007 02:32AM

Activate plugin in Preferences else in Advanced Preferences. Best via Advanced because there You can change some more settings. Changes active after restart.



Edited 1 time(s). Last edit at 04/13/2007 07:18AM by guenter.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: jackie simon
Date: May 22, 2007 12:31AM

this sucks i lost my favorities all the info is gone - i could scream i am so angry any suggestions justjackie01@comcast.net

Re: WHERE HAVE MY FAVORITES GONE?
Date: June 12, 2007 09:03PM

no favorites on my computer. Where are they?

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Scot Free
Date: June 17, 2007 01:44PM

Quote
Foober
Also, how does one get rid of the "Do you want to remember the values you filled in?" prompt?

I am having this same "Confirm" box pop up periodically. Is there a way to turn it off?

K-M 1.1 on XP w/SP2

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Nith
Date: August 01, 2007 08:11AM

I cannot find this problem listed anywhere. I have win xp professional. In preferences and plugins my favorites are activated but do not show up. Bookmarks and Hotlist show across top of browser but Favorites do not. Something must be missing
from my computer. Any have any guesses as to what it may be. Thanks

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: guenter
Date: August 01, 2007 08:55AM

Have You activated the km-plugin e.g. via Edit>Preferences - else I am lost too?



Edited 1 time(s). Last edit at 08/01/2007 08:56AM by guenter.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Nith
Date: August 01, 2007 09:24AM

Yes, thanks Guenter. Under Preferences and Plugins it is activated. Actually have
several computers with Win xp professional with this problem. And have some without
the problem. But I can't think of any way that they may differ. I was assuming
something like one or more dlls may be missing. But which ones? Maybe even something else?

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: kko
Date: August 01, 2007 06:14PM

Nith, I'm not sure whether you mean the Favorites menu or the Favorites toolbar. To get the menu, you only need to activate the IE Favorites Plugin. To get the toolbar, you have to enable the toolbar and make it visible:

1) Go to Edit > Advanced Preferences (or hit F2) and select IE Favorites in the category pane.
1a) Make sure the topmost check box (Enable support for Internet Explorer Favorites) is checked. (You have to restart km to make changes take effect.)
1b) Go to the Favorites Toolbar tab below and make sure Enable Favorites Toolbar is checked. (You have to restart km to make changes take effect.)
2) To make the favorites bar visible choose View > Toolbars from the main menu and check Favorites Bar or Links or whatever it might be called.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Nith
Date: August 01, 2007 11:54PM

Thanks KKO. I mean the Favorites menu. In Preferences, then under Plugins I have
several items activated including Bookmarks, Hotlist and the Favorites plugin.
But the weird thing is Favorites menu does not show up. Still weirder is the
Favorites toolbar does appear. But it does not function correctly. On the far left
where it has the button to open the Favorites menu it does not work correctly.
Opening it just brings open a very thin line. But if you move the mouse pointer
along it the various folders will open. This is truly bizarre so I am open to trying
anything. Thanks to all.

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: kko
Date: August 02, 2007 02:22AM

Quote
Nith
...I am open to trying anything.

In this case I'd try it with a clean reinstallation. Make sure that you backup your profile before uninstalling and/or tell the uninstaller to keep your profile when you're asked.

There are no known issues with missing system files under WinXP. I've really no explanation for what you described...

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Nith
Date: August 03, 2007 01:25AM

Thanks again KKO. Clean installs of the operating system and browser do not help.
But I have discovered one thing. I tried well over 100 old builds. Here is what I
have found. Of all the old builds which I have, no builds will work except for all
of the 0.8x series. CCF, builds by Fred, 0.9x or 1.0x will not work. So builds such
as 0.8.2 and Wechelbalg 0.8.2 work fine. But I do hate to use such old builds. Does
anyone have a clue as to what may be different about these particular builds? Thanks
again for any help. I am still ready to try anything!

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Nith
Date: August 06, 2007 06:49AM

Can Guenter or anyone tell me if there may be something from a 0.8.2 I might
could transfer to a current build to solve this problem?

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: guenter
Date: August 07, 2007 12:51AM

@Nith - I am not sure whether I understand - I assume the browsers do not start at all.

Some ideas where to look and what can be tried.

1.) Did You remember to let the new builds through the firewall?
XP got a firewall by MS with SP2. Maybe get an easier to handle one by ZoneAlarm, install that and then deactivate the old MS firewall.

Some firewalls sometimes break partially and stop to notify You when a new program starts for the first time. Then it looks like the program does not start up.
The firewall must be explicitely started or better newly installed before the new browser is started for the first time.

Also some firewalls stop their learning mode after a while and also prevent the new browsers to start. The learning mode most be reactivated or the rule set manualy.

2.) K-Meleons by Dorian need msvcr71.dll and msvcrt.dll. He uses a newer compiler. The files are in the distributions except with some that are zipped - maybe check for their presence in the K-Meleon folder. Take the *71.dll files from a 0.82+(Wechselbalg - btw we should ask Dorian for an official series number for that smiling smiley ) that work if You suspect that the dll are broken or not present.

3.) 0.82 and all K-Meleon versions before 1.0 had a different profiles folder location. It was in installation folder. Try whether new installs work with the old location and make sure that they have the privileges to write in their own profile folder. You can force the old location by deselecting it on install or by just creating a profile.ini inside k-meleon folder ( it can be an empty file with that name ). Using this can help with testing for faults where You cannot locate error easily (see below).

This old profile setup is also good if You install browsers for testing new items.
You simply install the browser with a unique folder name, have profile in the same folder and voila You have a throw away testing module. If anything goes badly wrong You simply delete the whole folder.


Several recent K-Meleon installs not working. By default recent K-Meleon versions
have a common Profiles directory and name their first Profile "Default". If this profile's prefs.js points e.g. at a broken skin You will not be able to start any K-Meleon browser ( A gravely damaged skin is a sure way to break K-Meleon to a point where You do not even get an error message. If You suspect this or anything similar try with a K-Meleon with a unique install folder name and with profiles in the old location / install folder. ).

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Nith
Date: August 07, 2007 02:55AM

Guenter, I am very, very sorry that I was not totally clear regarding my problem.
It caused you to do a lot of extra typing.
I will try my best to clarify. The Favorites Plugin on the newer builds will not
activate. In fact it cannot activate on any except for 0.8.2. This is what I refer to in my post of Aug 2. The Favorites plugin does activate in the old
Wechelbalg 0.8.2. That is of course a very old build. In the current builds
you can put a checkmark on the Favorites plugin, close the browser, then reopen
it and there are still no Favorites. Amazingly everything else works just fine.
Bookmarks are fine. And so is the Hotlist. So is there anything I might could transfer from an old build to a new one? Anything else that might work? Thanks

Re: WHERE HAVE MY FAVORITES GONE?
Posted by: Flekto
Date: August 13, 2007 01:23AM

I am curious. Does your problem happen to also involve the same problem I am
having? This is the thread. http://kmeleon.sourceforge.net/forum/read.php?1,73704

K-Meleon forum is powered by Phorum.