Wine and K-Meleon 1.5.4
Posted by: oui
Date: December 05, 2012 09:40PM

Hi

I am now in K-Meleon 1.5.4 using Wine 1.1.43-i486 in Archpup-1204, a new mini (78 MB) live distro from the Puppy Linux family based in this case on Arch Linux stuff having no preinstalled browser.

Exceptionnaly, K-Meleon works really very well in Linux, the pages are good and fast. ebay works, the Puppy Linux forum works, this forum works etc.
youtube.com refuses this browser.
http://france2.fr/jt/20h doesn't work probably because no flashplayer.
I did download and install it with the Adobe installer. nothing to do.

What is the solution?

Kind regards

Re: Wine and K-Meleon 1.5.4
Posted by: rodocop
Date: December 05, 2012 10:06PM

Open this thread in 'Linux users' subforum

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!



Edited 1 time(s). Last edit at 12/05/2012 10:06PM by rodocop.

Re: Wine and K-Meleon 1.5.4
Posted by: Fred
Date: December 06, 2012 03:29AM

I presume that you have put the file npswf32.dll into
the plugins folder of K-Meleon.
If not, copy it over from a subfolder of the /root/.wine
configuration folder.
I think that archpup has no file liblcms.so.1
in the folder /usr/lib or /lib.
I have found a package mentioned in the puppy forum, here

http://208.109.22.214/puppy/viewtopic.php?p=188923&sid=de5fd54d5defdb02c0c1bd3a6757753d

which includes liblcms.so.1 .
The address of the mentioned attched package missinglibs.tar.gz is :

http://208.109.22.214/puppy/viewtopic.php?mode=attach&id=9662&sid=9b8849276a849d597742887754085525

Download it to /root and unpack it to /root with the command

tar -C /root -zxf missinglibs.tar.gz

You will find the file liblcms.so.1.0.16 .

Rename it to liblcms.so.1 (which overwrites the symlink liblcms.so.1)
and copy it to the folder /usr/lib/ .

This should enable youtube and most other flash videos.
(Youtube may ask for a newer browser. Ignore it by
pressing the ignore button).

The jt on France2 seems not to work with this K-Meleon version.
Ypu can try to set a different useragent in the menu custom of
the user agent menu.

I hope that this works.
Sometimes Flash 10, which is still being updated is better.

If there should other libs be missing, take a look
at my advice from this post :

http://kmeleon.sourceforge.net/forum/read.php?11,107748

Fred

K-Meleon forum is powered by Phorum.