Question on Default Explorer Skin
Posted by: mike
Date: October 11, 2009 10:39PM

I have tried to contact the developer of that skin but the e-mails have come back.

Just over a month ago I started using the K-Meleon web browser. After I got familiar with it I started to check some other things out. I found the Default Explorer Skin download at the K-Meleon site. I wanted the look of IE since I am so used to IE6 after using it for so many years. I am very happy with the KM Explorer Skin.
However, I have a question about something that I would like to add, I would like a "Go" button for the URL bar to work. I am able to get the "Go" to show ... I took the # marks away from the "Go" button in the toolbars.cfg and the "Go" button is visible but it doesn't work ... if I type in another address, nothing happens. I would like to know what else has to be done to get the "Go" button to actually work or is it too complicated to get that button to work. Since I had it on IE6, it would be nice to have it here also, if possible.


URL Bar buttons {
GO {
macros(go_button)
GO
toolhot.bmp[16]
toolcold.bmp[16]
tooldead.bmp[16]
}

thanks,

mike

Re: Question on Default Explorer Skin
Posted by: siria
Date: October 11, 2009 10:57PM

Hi Mike, just compared and this is from the button in 1.5.3 default skin:

Go{
%ifplugin macros
macros(Go_Selected)|_Go
Go to URL. Right-click for more options.
%else
ID_NAV_GO
Go to URL
%endif

At some point there was a change in the macro system (around KM 1.1?), so it looks like the toolbar.cfg in the explorer skin is a bit outdated. So if you use a current k-meleon version and run in skin probs, just look in the other toolbar.cfg There are probably quite a few buttons of the sort...

Edit: just took a look at that default explorer skin, and boy is that one outdated! And the pics look exactly like the klassic skin, so just wondering, why don't you use that one...? Many more buttons, although klassic is ancient too.



Edited 1 time(s). Last edit at 10/11/2009 11:07PM by siria.

Re: Question on Default Explorer Skin
Posted by: mike
Date: October 11, 2009 11:40PM

Thanks siria for the fast reply ... I am using the latest K-Meleon 1.53 version. I am not too much up on doing changes. I was amazed that I was actually able to get the "Go" to show up in the browser, slowly figured that one out last week with those "#" marks. I will check out the Klassic Skin, might be the thing ... and also try to figure something out with the Default Explorer Skin in the meantime ... but I may like the Klassic Skin. In the default skin (Phoenity) that comes with KM 1.5.3, there is a working URL "Go" button and I also like that skin but I have been playing around with this Default Explorer Skin and that "Go" button seems to be the only thing that I can't get working. Again, thanks for the quick reply.

mike

Re: Question on Default Explorer Skin
Posted by: siria
Date: October 12, 2009 12:44AM

Great Mike. And just in case, no need to search around for Klassic, it's just the older default skin that still comes automatically with KM too, already installed alongside Phoenity smiling smiley

Re: Question on Default Explorer Skin
Posted by: duffy2009
Date: October 12, 2009 01:39AM

... siria , I have the "Go" button working in the Default Explorer Skin. I copied just the "Go" info from the Klassic Skin program and deleted the Default Explorer "Go" button info and replaced it with the Klassic Skin "Go" button info. The "Go" button is there and it actually works. Now, what I am not sure of ... is it OK for me to do this, I tried to contact the person that made both skins, yes the same guy did both the Klassic and the Default Explorer skins. As I said before, I sent 3 e-mails and they came back as "undelivered" or "failure". So I made this small change in the Default Explorer on my own ... I see nothing in the skin programs that changes cannot be made without permission but I might have missed it.

I am still going to check out the Klassic Skin later today.

This is what I inserted in the Default Explorer toolbars.cfg .
-----------------------------------------------------------------------

}


&Go Buttons{

Go{
%ifplugin macros
macros(Go_Selected)|_Go
Go to URL. Right-click for more options.
%else
ID_NAV_GO
Go to URL
%endif
toolhot.bmp[16]
toolcold.bmp[16]
}

---------------------------------------------------------------------

thanks again for the help ... let me know what your thoughts are about me making this small change on that Default Explorer Skin program.

mike

Re: Question on Default Explorer Skin
Posted by: siria
Date: October 12, 2009 02:08AM

grinning smiley Congrats, you made it grinning smiley
I wouldn't worry, those skins are meant for customizing, and on your own computer you can certainly play around as much as you want.

But you see, this explorer-skin (toolbar icons from 2002) just seems to be an older and outdated previous version of klassic (toolbar icons from 2004, config updated 2008), so it's somehow double work to update it *again*. The explorer-icons are included in klassic, just perhaps not all-gray anymore in the more modern version. But if you prefer the allgray look, simply copy over the toolcold.bmp from explorer-folder to klassic-folder. And then in klassic, there are many more buttons included... (not all visible by default, same trick as with this go-button, and try out View/Toolbars ;-)



Edited 2 time(s). Last edit at 10/12/2009 02:17AM by siria.

Re: Question on Default Explorer Skin
Posted by: duffy2009
Date: October 12, 2009 03:41AM

Hi siria ...

Just got done working with the Klassic Skin. I do like that skin better since it has a little color on the buttons, as you mentioned. It also has a few extra buttons set up, ready to go ... plus it has been updated and the Default Explorer Skin hasn't for some time. I did go into the toolbar.cfg and make some adjustments on things I didn't want or need. Really like the K-Meleon browser, especially now that I have it tailored more to my liking. I thank you again for all your help and bringing the Klassic Skin to my attention. Learned a lot today about "customizing" things in the K-Meleon browser.

mike



Edited 1 time(s). Last edit at 10/12/2009 03:45AM by duffy2009.

Re: Question on Default Explorer Skin
Posted by: siria
Date: October 13, 2009 06:19AM

Glad everything is perfect now :-)
I too am learning new tricks every day here, or rather two or three, LOL! grinning smiley

K-Meleon forum is powered by Phorum.