General :  K-Meleon Forum
General discussion about K-Meleon. 
KM doesnt RUN on VISTA after clicking
Posted by: Rodrigo
Date: September 08, 2009 01:32PM

I had KM for a while, into his last version and it was running ok.

Nowadays, it just suddenly STOPPED working. I click on the ICON, it asks me if I want to recover last session, and it stays there.. nothing happens. I have tried killing the process and trying again but does not work.

Also, is there a way to recover KM saved SESSIONS without loading the program (reading all the sessions data I mean)

great program anyway!

Tnx from Brazil
Z├ęCarioca

Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: JujuLand
Date: September 08, 2009 02:43PM

It seems to be a profile problem.

Just move the profile folder elsewhere to preserve it, and launch K-Meleon. It ought to create a new profile and run ok. After, it will be possible to copy some files : bookmarks.html, sfile (password), cookies, ... but not prefs.js (It will be possible to keep some prefs from the old prefs.js, but carefull, the problem is probably in prefs.

Else, I haven't any idea about your problem. Perhaps Vista ??

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: desga2
Date: September 09, 2009 12:44AM

Sessions are saved in prefs.js file in your K-Meleon profile folder.
Search the prefs lines "kmeleon.plugins.sessions2" and copy it in a new profile prefs.js file.

K-Meleon in Spanish

Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: Rodrigo
Date: September 09, 2009 07:54AM

tnx for answering bro..

but my prefs.js file doesnt have my sessions info on it.

any clue??

tnx
Z├ęcarioca

Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: desga2
Date: September 09, 2009 06:44PM

You can restore your sessions from the History.

K-Meleon in Spanish

Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: Rodrigo
Date: September 13, 2009 02:17PM

How do I see SAVED SESSIONS being OUTSIDE the program, since MINE doesnt work.

thankx

Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: guenter
Date: September 13, 2009 04:22PM

It is the OS (Vista, Windows 7) or the firewall/virus software (XP or older) that stop K-Meleon's start.

You can read out old sessions' URLs from prefs.js in used profile with an editor.

But it is probably easier to set user privileges so that OperatingSystem allows K-Meleon to start again.

If that does not work.
Vista has a mode that lets You work like an XP Admin.
Try that to recover Your sessions using that.

Greetings to Brazil, France and Spain from Germany



Edited 1 time(s). Last edit at 09/13/2009 04:56PM by guenter.

Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: siria
Date: September 14, 2009 03:32AM

Vista is really a pain, nothing ever works, grrrr
Just had the joy too to spend a couple hours fighting with it (again), just because I wanted to see how my KM-skin looks on the other screen, and of course nothing worked, as usual. Thankgod my ancient win98se notebook is still running!! tongue sticking out smiley
Anyway, each KM start on Vista took about 3 min!! First I thought it didn't do anything, then that it was me, and tried to disable all macros etc., only to find in the end that it was in fact Vista itself After disabling firewall and virus stuff, turning off everything in that "Windows Defender" thing and exiting it, KM started in 2 sec again - har har, I won tongue sticking out smiley
Yeah okay, there's probably a way to allow KM for Win-Defender, but for now I have enough again, grrr

Rodrigo, the .js in KM are simple text files, not javascript-files, as Windows assumes normally. They open in every text editor or wordpad etc, but that must be chosen explicitely. But I suppose you did that already, since you say it's not in it... Perhaps the wrong prefs-file?? There are several, a default one, and one for each profile.... hmm.... And it can be in the program folder itself, or in the appdata folders in docsets.... good luck ;-)

(The first thing I learned when using KM a few years ago, was to keep a backup of the whole program folder with the profiles in it ;-)



Edited 2 time(s). Last edit at 09/14/2009 03:46AM by siria.

Options: ReplyQuote
Re: KM doesnt RUN on VISTA after clicking
Posted by: disrupted
Date: September 14, 2009 04:33AM

i tested vista a while back on a friend's laptop and t wasn't a nice experience. even though logged in with my friend's account as administrator with supposedly full privileges; the thing makes you feel like a bad person or a hacker.. it's very annoying and time-consuming just to have to double check everything you do... it's like working with a sick person with OCD. security is great and having different zones and uac could have been executed in a much better way, there's a fine line between a robust and active security and obstructive panaroia and vista clearly crossed that line.

honestly i will glady take win95 any day over vista

Options: ReplyQuote


K-Meleon forum is powered by Phorum.