General :  K-Meleon Forum
General discussion about K-Meleon. 
Disabling ALT+a in urlbar?
Posted by: Lyx
Date: August 26, 2009 11:21PM

I'm using an US-keyboard and have added custom combos to create german umlauts: ALT+A, ALT+SHIFT+A, ALT+U, ALT+SHIFT+U, ALT+O, ALT+SHIFT+O. Problem is that KM clears the urlbar if i use alt+a or alt+shift+a. This behaviour isn't defined in the default accelerator config. A quick search through all macros also found nothing. How do i disable this? At first, i wanted to test if i can remove the combo via user accel config, but in the documentation (http://freenet-homepage.de/CoolMcKluus/software/kmeleon/project/reference/cfgfiles/accel.html) there is no method explained to unassign key-combos.

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: JamesD
Date: August 27, 2009 03:32AM

@ lyx

There is a method for making inactive accelerator keys. It involves setting the key combo to run "macros(dummy)". See this thread for some information. http://kmeleon.sourceforge.net/forum/read.php?4,94161

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: Lyx
Date: August 27, 2009 04:23AM

Okay, i figured out that the exact key-combo which is interferring, is CTRL+ALT+A, and it only seems to apply to the urlbar, not elsewhere. This is as far as i got with the macro:

_unassignkeys{
setaccel("CTRL ALT A","macro(dummy)");
setaccel("CTRL ALT SHIFT A","macro(dummy)");
}
$OnStartup=$OnStartup."_unassignkeys;";
$macroModules=$macroModules."unassignkeys;";

Doesn't have an effect. Did i do something wrong?

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: mslayer
Date: August 27, 2009 06:32AM

Quote
Lyx
Okay, i figured out that the exact key-combo which is interferring, is CTRL+ALT+A, and it only seems to apply to the urlbar, not elsewhere. This is as far as i got with the macro:

_unassignkeys{
setaccel("CTRL ALT A","macro(dummy)");
setaccel("CTRL ALT SHIFT A","macro(dummy)");
}
$OnStartup=$OnStartup."_unassignkeys;";
$macroModules=$macroModules."unassignkeys;";

Doesn't have an effect. Did i do something wrong?
Try using "macros(dummy)" instead of "macro(dummy)", I'm not an expert but I saw it in that way.

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: Lyx
Date: August 27, 2009 07:47PM

Thanks for pointing out the typo. Changed that, but they keycombo is still active. To me, it looks as if this keycombo is assigned on a level above accels and macros and overrides those - perhaps hardcoded?

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: JamesD
Date: August 27, 2009 08:06PM

@ lyx

I am not sure that I understand completely. "CTRL ALT A" is not a default accelerator in KM. "CTRL ALT SHIFT A" is not correct. Only three (3) keys are allowed. This has four.

I am running KM 1.5.3 on XP-SP3 and I see nothing happen when I use the keys "CTRL ALT A". What happens on your system when you press this combination?

Ops.. Four key are allowed. I have just never seen that many before.



Edited 1 time(s). Last edit at 08/30/2009 03:10AM by JamesD.

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: Lyx
Date: August 27, 2009 09:10PM

As i explained earlier, CTRL+ALT+A only gets triggered in the urlbar and will clear it, and it also gets triggered if i press CTRL+ALT+SHIFT+A (both combos are equivalent to RIGHT ALT + A and RIGHT ALT + SHIFT + A). This happens on a freshly downloaded KM with the only modification being PROFILE.INI in the appdir, so that profiles are stored in the appdir. No other modifications.

Simple enter something into the urlbar, then press CTRL+ALT+A.

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: Lyx
Date: August 27, 2009 09:51PM

Okay, i for testing switched my keyboard layout to normal english, and now it isn't reproducable anymore! WTF is k-meleon doing with the keyboard? In the 4 years i have been using this keyboard layout, i haven't seen a single app behaving that weird regarding key-combos.

Anyways, my setup goes like this: I created my own keyboard layout definition via microsoft keyboard layout creator (it basically simply installs your own keyboard-layout, as another input-language). The relevant changes to my layout are:

RIGHT ALT + A = ä
RIGHT ALT + SHIFT + A = Ä

If i press any of the two in k-meleons urlbar, the entire inputfield gets cleared and only the umlaut remains. However, as soon as i switch to the normal english keyboard layout (thus, disabling the two combos described above) nothing like that is reproducable anymore.

Options: ReplyQuote
Re: Disabling ALT+a in urlbar?
Posted by: desga2
Date: August 30, 2009 01:34AM

I think that you can read this documentation can help you.

Left Alt key and right Alt key (Alt Gr) are different keys;
Left Alt = ALT
Right Alt (Alt Gr) = VK_MENU

K-Meleon in Spanish

Options: ReplyQuote


K-Meleon forum is powered by Phorum.