General :  K-Meleon Forum
General discussion about K-Meleon. 
kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 20, 2008 05:53AM

I cannot run kmeleon 1.5.1 using sandboxie in windows XP.
I have had absolutely NO problems with previous kmeleon
versions (1.1.3, 1.1.5, 1.5) and sandboxie versions.
There is an ongoing thread in the sandboxie forum:

http://www.sandboxie.com/phpbb/viewtopic.php?t=4150

Before reading that thread, I thought I was going bonkers.
People are reporting hang problems in both Vista and XP
Any help appreciated.

soccerfan

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 22, 2008 02:25AM

More details:
My OS: Windows32 XP SP1(home) and XP XP2(pro)
(there are reports of problems on windows Vista also).

Software: sandboxie (latest stable version: v3.30)
Download Page: http://www.sandboxie.com/index.php?DownloadSandboxie
Direct Download (mods: please remove link if not allowed in this forum):
http://www.sandboxie.com/SandboxieInstall.exe

NOTE: Download and install does not require the paid or registered version.

Steps to replicate the bug:
1. Download and install sandboxie. (No registration required.)
2. Install kmeleon 1.5.1
3. Right click kmeleon.exe and select "sandbox" or "run sandboxed" or "send to" sandboxie (or somthing similar).[Note that sandboxie adds these items to the context menu upon installation].
4. RESULT: Kmeleon hangs. To "un-hang", a reboot is required im most cases.
[Sometimes (rarely) it may be possible to terminate the process by using taskmanager or by right-clicking sandboxie icon and selecting "terminate all programs".]

NOTE 1: Kmeleon 1.5.1 runs fine unsandboxed.
NOTE 2: Problem occurs with ONLY kmeleon 1.5.1 (Versions such as 1.5, 1.1.5 behave ok).
NOTE 3: Problem occurs with all free/paid versions of sandboxie including the stable version.

Humble Request:
I request desga2 or guenter or any other respected forum member to help confirm this
and possibly file a bug report. Many thanks.

Regards,
soccerfan

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: guenter
Date: October 22, 2008 02:52AM

We have 3 threads about this topic.

http://kmeleon.sourceforge.net/forum/read.php?1,84789
http://kmeleon.sourceforge.net/forum/read.php?3,84752
http://kmeleon.sourceforge.net/forum/read.php?3,84775

Start no new threads about this, please!


This is AFAIK the oldest thread so if You find new info or a solution You can post here.

Otherwise:

Quote
desga2
Please no more post about Sandboxie and K-Meleon 1.5.1.

You must wait to a problem solution.

smiling smiley

p.s. @ soccerfan: "useful" links can be used by "Forum Users".
I do not use a Sandbox but an old OS unsuported by MS or virus writers ;)
But 3 confirmations are enough - I hope the bug is in Sandboxi not K-Meleon grinning smiley
If applicable: Did You inform the Sandboxi settings of K-Meleon's version change?



Edited 3 time(s). Last edit at 10/22/2008 03:29AM by guenter.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 22, 2008 03:50AM

Quote
guenter
If applicable: Did You inform the Sandboxi settings of K-Meleon's version change?

Thanks guenter.
Somone has already reported it in the sandboxie forum also: http://sandboxie.com/phpbb/viewtopic.php?t=4150

I'll await patiently now.

soccerfan

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: Dorian
Date: October 22, 2008 06:16PM

kmeleon 1.5.1 try to run itself with lower privilege by default, and probably conflicting with sandboxie. But I didn't add an option for that. Maybe in the next version.

Reminder: I mostly fix what I find in the BT.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 22, 2008 06:35PM

Quote
Dorian
kmeleon 1.5.1 try to run itself with lower privilege by default, and probably conflicting with sandboxie. But I didn't add an option for that. Maybe in the next version.

Reminder: I mostly fix what I find in the BT.

Thank you Dorian. Will wait for the next version.


Btw, I tried several times creating an account to get into BT but was refused (each time there was some message in red about my server). Hence my request to others to confirm and report it.

Thanks again for reading this post.

soccerfan

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: guenter
Date: October 22, 2008 10:55PM

@soccerfan,
Try to create a real Forum account first - try with that account...
(if it does not create, delete Your cookies etc. Try with another name, mail address etc - we can probably edit to fit later smiling smiley ). If Forum insist to create an error send me a mail so that we can communicate directly.

@Dorian,
A marginal problem. Forum says again: IP = localhost.localdomain for all users - a unique identifier would be better.



Edited 1 time(s). Last edit at 10/22/2008 10:59PM by guenter.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 23, 2008 12:00AM

Quote
guenter
@soccerfan, If Forum insist to create an error send me a mail so that we can communicate directly.

guenter, I have sent you an email. Thanks.

soccerfan

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: Dorian
Date: October 23, 2008 02:39AM

The captcha is back, you should try again

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 23, 2008 02:54AM

Quote
Dorian
The captcha is back, you should try again

Many thanks Dorian. I am now registered!

@guenter: Thank you too and please disregard my email
to you (requesting registration help).

soccerfan

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: bellgamin
Date: October 23, 2008 03:32PM

I am another who cannot run the new Kmel in Sandboxie. When Kmel runs sandboxed, we cannot browse with it & we cannot shut it down. We have to do a reboot to make it stop. Also, it often grabs 100% cpu.

My company no longer lets anyone browse the internet except while using Sandboxie. Therefore, we are no longer allowed to use Kmel. We have all reverted to using Firefox or Opera. :o(


I hope there is a fix soon.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: guenter
Date: October 23, 2008 04:24PM

@bellgamin,
well, why not run an update of 1.1.x with new GRE. It would do since except that it has the advantage of real tabs it does not lack other features. Greetings guenter



Edited 1 time(s). Last edit at 10/23/2008 04:25PM by guenter.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: bellgamin
Date: October 24, 2008 03:16AM

Thanks for the suggestion Guenter but -- we cannot do that now.

Our IT is convinced that Kmel places insufficient emphasis on security. I quote part of his written memo on this matter: "In the present state of the internet, sandboxing is essential. One of the very first tests for any new browser version should be to ensure that it works well sandboxed."

It looks like it will be a while before we get him to let us use ANY version of Kmel.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: desga2
Date: October 24, 2008 03:29AM

You can use 1.5.0 with an update GRE to 1.1.8.17 (1.5.1 GRE).
Close all K-Meleon instances (included Loader if you are using it).
Only copy main K-Meleon folder (without .exe files) from 1.5.1 to 1.5.0 and copy K-Meleon\components folder from 1.5.1 to 1.5.0.
Remember delete *.dat files in K-Meleon 1.5.0 \components folder (compreg.dat, xpti.dat).

K-Meleon in Spanish

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: Bob D
Date: October 24, 2008 04:04AM

Quote
bellgamin
no longer allowed to use Kmel. We have all reverted to using Firefox or Opera. :o(
Hi Bellgamin
Why not revert back to 1.5.0.
I have not run into the SBIE compatability issue solely because I did not upgrade.
(I typically wait a couple days b4 upgrades. Let others be the guinea pigs)

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 24, 2008 04:25AM

Quote
desga2
You can use 1.5.0 with an update GRE to 1.1.8.17 (1.5.1 GRE).
Close all K-Meleon instances (included Loader if you are using it).
Only copy main K-Meleon folder (without .exe files) from 1.5.1 to 1.5.0 and copy K-Meleon\components folder from 1.5.1 to 1.5.0.
Remember delete *.dat files in K-Meleon 1.5.0 \components folder (compreg.dat, xpti.dat).

Hi desga2, will this also work for (portable) km1.1.3 to update to new GRE 1.1.8.17?

soccerfan

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: guenter
Date: October 24, 2008 04:56AM

Quote
soccerfan
Quote
desga2
You can use 1.5.0 with an update GRE to 1.1.8.17 (1.5.1 GRE).
Close all K-Meleon instances (included Loader if you are using it).
Only copy main K-Meleon folder (without .exe files) from 1.5.1 to 1.5.0 and copy K-Meleon\components folder from 1.5.1 to 1.5.0.
Remember delete *.dat files in K-Meleon 1.5.0 \components folder (compreg.dat, xpti.dat).


Hi desga2, will this also work for (portable) km1.1.3 to update to new GRE 1.1.8.17?


Yes, it'll work for 1.1.3 portable and any k-meleons with any GRE 1.8.x ( see Fred's updates).

Portables may (if You want/like it) have upixed files (dll&exe made smaller - for old, small USB) & and xpcom_core.dll created with VC 6 so that they do not create a dummy K-Meleon profile folder in %apdata% (You get that dll version from a SM with a 1.8.1.17 version or reuse the one from the portable / no security problems known = can reuse).



Edited 3 time(s). Last edit at 10/24/2008 05:05AM by guenter.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 24, 2008 06:06PM

Thanks guenter. I'm using alain's portable version with no compressed files.
I'll keep his xpcom-core.dll and (in components) kprofile.dll to update to the
new GRE. Just in case, I've also extracted xpcom-core from the latest seamonkey.

PS: Hope you are now back to near 100% healthwise.

soccerfan



Edited 1 time(s). Last edit at 10/24/2008 06:07PM by soccerfan.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: soccerfan
Date: October 31, 2008 06:13AM

Update: This problem is apparently resolved. Look here: http://sandboxie.com/phpbb/viewtopic.php?p=27952#27952

A gracious response by sandboxie's developer:
Quote

K-Meleon 1.5.1 should work fine in the sandbox.
Just to be clear, it certainly was a problem in Sandboxie.

Edit: This refers to the newly released sandboxie beta v3.31.16

soccerfan



Edited 1 time(s). Last edit at 10/31/2008 06:15AM by soccerfan.

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: Bob D
Date: November 16, 2008 10:39PM

Quote
soccerfan
Update: This problem is apparently resolved. Look here: http://sandboxie.com/phpbb/viewtopic.php?p=27952#27952

A gracious response by sandboxie's developer:
Quote

K-Meleon 1.5.1 should work fine in the sandbox.
Just to be clear, it certainly was a problem in Sandboxie.

Edit: This refers to the newly released sandboxie beta v3.31.16

Note:
SBIE release v3.32 available (16 Nov): http://sandboxie.com/
Issues w/ K-Mel 1.5.1 apparently resolved smiling smiley

Options: ReplyQuote
Re: kmeleon 1.5.1 does not run in sandboxie
Posted by: desga2
Date: November 16, 2008 11:27PM

Also K-Meleon 1.5.2 Beta can help you to solved this problem.

K-Meleon in Spanish

Options: ReplyQuote
xOwpngcGGp
Posted by: Jayna
Date: July 19, 2011 07:49PM

A million thanks for potnsig this information.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.