General :  K-Meleon Forum
General discussion about K-Meleon. 
Greasify won't turn on
Posted by: Tom Chipz
Date: September 07, 2008 07:10AM

I click on the button in the toolbar but it does nothing and trying to enable it from Tools > Greasify does nothing either.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: Tom Chipz
Date: September 07, 2008 07:37AM

I forgot to mention, pressing Apple Greasify Now does actually work.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: jk--
Date: September 11, 2008 12:43AM

You are using K-Meleon 1.5? I haven't figured out why but KM1.5's new macro code I don't think works correctly. I cannot get a menu to change a boolean pref like in 1.16

It works fine with 1.16 but if you want to use it in 1.5 you will have to set this pref manually

kmeleon.plugins.macros.greasify.enabledned  true

Applying manually should work anyway though.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: JujuLand
Date: September 11, 2008 01:10AM

If you want the kmm file works with 1.5.x and 1.1.x with specific code, you can test the value of $kLayers.

if $kLayers==0 then you're using Tabs (and you're normally under 1.5.x)
. else you're using Layers and are under 1.1.x

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Options: ReplyQuote
Re: Greasify won't turn on
Posted by: kko
Date: September 11, 2008 02:29AM

Quote
jk--
You are using K-Meleon 1.5? I haven't figured out why but KM1.5's new macro code I don't think works correctly. I cannot get a menu to change a boolean pref like in 1.16

The problem is that macro Greasify_Toggle is not executed at all. Add an alert() to test it. Can't tell you why, though.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: kko
Date: September 11, 2008 02:30AM

Quote
JujuLand
If you want the kmm file works with 1.5.x and 1.1.x with specific code, you can test the value of $kLayers.

if $kLayers==0 then you're using Tabs (and you're normally under 1.5.x)
. else you're using Layers and are under 1.1.x

A+

No, a km 1.1 with layers disabled is not a km 1.5. grinning smiley

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: Tom Chipz
Date: September 11, 2008 09:55AM

Quote
jk--
You are using K-Meleon 1.5? I haven't figured out why but KM1.5's new macro code I don't think works correctly. I cannot get a menu to change a boolean pref like in 1.16

It works fine with 1.16 but if you want to use it in 1.5 you will have to set this pref manually

kmeleon.plugins.macros.greasify.enabledned  true

Applying manually should work anyway though.

Do I do that in about:config? I tried that and I also removed the ned part and I assumed that the true part was not part of the name and various combinations, but it did nothing. Also, pressing Apply Now would be fine, but the thing is I have to press it for each page I load, which isn't exactly convenient.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: desga2
Date: September 11, 2008 06:22PM

You can detect the K-Meleon version in macros checking the pref:
general.useragent.vendorSub

Look this code in MacrLibrary for example to how use it.

K-Meleon in Spanish



Edited 2 time(s). Last edit at 09/11/2008 10:30PM by desga2.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: JujuLand
Date: September 11, 2008 10:42PM

Quote
No, a km 1.1 with layers disabled is not a km 1.5.

Sorry, but I have tested it before using it.

With 1.1.x :

When layers are enabled : k$Layers = true
When layers are disabled : k$Layers = false

With 1.5 :

kLayers = 0

But as you have talk about it, I have tested a case I never think of : where layers.dll is not present, and for some macros I use (roboform, for example), I have now a crash with 1.1x. So I must modify it to avoid these problems.

[edit=21:06:00] ---------------------------------------------------------------

I now use :

$pLayers=substr(getpref(STRING,""general.useragent.vendorsub"),0,3);
$kLayers==0?0:$pLayers="1.1";
# This last string to correct getpref result for version 1.5a1, which uses layers instead of tabs

The crash I had was due to the fact that with layers disabled, the mechanism to initialize roboform doesn't work anymore, and K-Meleon crashes when browsing in this window. It ought be possible to open a new window and close the first like I do with layers, but it's a pain, and in this case, when layers are disabled, I disable automatically roboform.

An other crash occurs when I rename layers.dll to simulate the fact that this kplugin isn't here. It's due to the presence of the kplugins sessions. When renaming it too, no more crash. It seems to be normal, because, I think sessions use layers.

[/edit] -----------------------------------------------------------------------


A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 3 time(s). Last edit at 09/12/2008 02:20AM by JujuLand.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: jk-
Date: September 16, 2008 02:40AM

Thanks JujuLand, that information is good to know, unfortunately I haven't been able to figure out exactly what the problem is with the 1.5 version so I can't write the correct code to go around the problem.


Quote
kko
The problem is that macro Greasify_Toggle is not executed at all. Add an alert() to test it. Can't tell you why, though.
Yes something is not working there, I've encountered the same problem with another module, my noscript one. If I create a simple kmm that produces the problem maybe I can post it and one of you guys could help me out.

Quote
Tom Chipz
Do I do that in about:config? I tried that and I also removed the ned part and I assumed that the true part was not part of the name and various combinations, but it did nothing. Also, pressing Apply Now would be fine, but the thing is I have to press it for each page I load, which isn't exactly convenient.

Whoops! I posted the wrong preference name in my first post. Shout be...
kmeleon.plugins.macros.greasify.enablednew


and NOT "kmeleon.plugins.macros.greasify.enabledned"

and yes, that would be in about:config, it should be a Boolean set to TRUE


Some other boolean prefs are:
Status Bar Script Notification:
kmeleon.plugins.macros.greasify.statbarnew

NoScript compatibility mode (for 1.16 only - automatic in 1.5 if I remember)
kmeleon.plugins.macros.greasify.nscompat

Enable Toolbar
kmeleon.plugins.macros.greasify.enable_toolbar

Use Modal instead of popup dialog to view script list:
kmeleon.plugins.macros.greasify.use_modal

Copy Applied Script to Clipboard
kmeleon.plugins.macros.greasify.copyclipboard

----------------------
- K-Meleon Macros and Extensions
- Greasify (Greasemonkey type macro for K-Meleon)
- Stylish for K-Meleon



Edited 3 time(s). Last edit at 09/16/2008 02:47AM by jk-.

Options: ReplyQuote
Re: Greasify won't turn on
Posted by: Tom Chipz
Date: September 25, 2008 09:55AM

Thank you very much!

Options: ReplyQuote


K-Meleon forum is powered by Phorum.