General :  K-Meleon Forum
General discussion about K-Meleon. 
Default Browser - Conflict
Posted by: crabboy
Date: August 15, 2008 05:23PM

I've done searches on this and tried everything suggested (including the instructions on the troubleshooting page) - but I cannot get Kmeleon 1.5 to act as the default browser. I also have Seamonkey and Firefox 3, also gecko-based browsers. Could a conflict exist? Any other suggestions? I had some problem with 1.1.2, but managed to get it to work.

Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: guenter
Date: August 15, 2008 06:23PM

The conflict exists when registry is damaged. You can try with tools such as registry cleaners.

Another good try: make IE default and after that make K-Meleon default. Protocols that are not handled by k-meleon after that must be set via right-click system functions to open this with default application = K-Meleon (You do this with local file of this Mimetype - can be a renamed file with different type (like .txt renamed to .shtml or .html).

Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: disrupted(unlogged)
Date: August 15, 2008 07:14PM
Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: crabboy
Date: August 16, 2008 05:37AM

I'm afraid that registry cleaners got me into this mess in the first place. I solved this problem in my previous version of Kmeleon by setting Maxthon2 as the default browser then uninstalling Maxthon. No good this time.
Under "file types" in Widows Explorer. URL:HTTP and URL:HTTPS are not listed at all. I created two new "extensions" and associated them with URL:HTTP and URL:HTTPS. The new "extensions" say that they are opened by kmeleon, but when I uncheck "use DDE", the box is checked again as soon as I close. I reinstalled Maxthon2 and can get links to open automatically there. The reason I suspect some kind of conflict is that I cannot get Seamonkey to be the default browser for links, either.

Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: crabboy
Date: August 16, 2008 05:38AM

Unfortunately, no. I have XP. Anything similar for XP?

Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: disrupted(unlogged)
Date: August 16, 2008 06:55AM

this is very odd, and the only reason i can think of for not registering properly is that the class id for URL has been altered or removed.

anyway, i uploaded the registry keys that should fix that problem and make kmeleon default handler, i assumed you installed in default location so i edited the keys accordingly to this path:
c:\program files\k-meleon\k-meleon.exe

if you have installed to another path; either edit the keys to your path or merge them and modify the path from folder options>file types

i suggest you delete all the url values that you have manually created before merging the registry keys in fear they might cause any conflict

the keys are self-explanatory to what they register:

save the keys to your computer(right click, save link target as..) and merge them.

for html,htm,,shtm,shtml,xht,xhtml and rdf file types; you can easily register them with k-meleon or in folder options without any problems.
goodluck.


Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: crabboy
Date: August 16, 2008 02:45PM

Thanx. I will try that and get back with results.

Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: crabboy
Date: August 17, 2008 07:41AM

Tried disrupted's suggestions. No effect. Went back to file types to find HTTP and HTTPS listed (they weren't before). Removed all references to Maxthon. Links now open in K-Meleon. At first every link opened a new window, but I found the setting in Preferences that fixed that.
I really like 1.5, but it seems to have a steeper learning curve than previous versions.



Edited 1 time(s). Last edit at 08/17/2008 07:46AM by crabboy.

Options: ReplyQuote
Re: Default Browser - Conflict
Posted by: ttccdr
Date: July 16, 2009 08:14PM

Open a Windows Explorer window then Tools - Folder Options - Scroll down to find URL hypertext transfer protocol and select it. Then click Advanced and select the open line then paste in the command line "C:\Program Files\K-Meleon\k-meleon.exe" "%" (change this as necessary to suit where you've got K-Meleon installed). Click ok and ok and back right out. Do the same again for the hypertext transfer protocol with privacy line. You should then find all's well. Good luck.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.