How to disable "remember" prompt?
Posted by: lphilpot
Date: March 28, 2008 08:59AM

I've searched the forums and looked through the FAQs, configs, etc. but haven't seen an answer to this -

How do I disable the dialog that asks "Do you want to remember the values you filled in? Yes, No, Never for this site"?

I don't see any likely plugins enabled that would cause this and have seen nothing about it in the documentation (unless I just overlooked it). It's not consistent, and sometimes even if I select "Never for this site" is asks again, so I'd like to just completely disable it. But how? about:config? If so, what preference?

Thanks.

Re: How to disable "remember" prompt?
Posted by: kko
Date: March 28, 2008 01:53PM

It's pretty simple. When you log in to a site for the first time, km will ask you whether you want to save the login information:

1) Yes: Remember the data and automatically fill in the next visit.
2) No: Don't remember the data. Ask again the next visit.
3) Never for this site: Don't remember the data and don't ask again the next visit.

When you are asked again the next visit although you had chosen 1) or 3), it's due to the site and no failure of the browser. Sites can try to prevent you from automating the login.

If you don't want the browser to remember any login data, open Edit > Advanced Preferences > Privacy & Security > General and uncheck "Remember login data".

Re: How to disable "remember" prompt?
Posted by: caktus
Date: March 28, 2008 05:26PM

I too have been wanting to stop this notice from popping up as I do not want any login data saved to the local computer. However, "Remember login data" is already unchecked.

Charlie

~~If it ain't broke, why screw it up?~~


Re: How to disable "remember" prompt?
Posted by: lphilpot
Date: March 28, 2008 06:35PM

It's not checked - In fact, it's greyed out and disabled (in the unchecked state). I have just disabled the Privacy plugin, so I'll see if that makes any difference.

Thanks.

Re: How to disable "remember" prompt?
Posted by: kko
Date: March 28, 2008 07:43PM

Quote
lphilpot
It's not checked - In fact, it's greyed out and disabled (in the unchecked state).

Yes, sorry, in km 1.1.x this check box is disabled. It's under Edit > Preferences > General > Remember passwords.


Quote
lphilpot
I have just disabled the Privacy plugin, so I'll see if that makes any difference.

Nope, that can't make any difference.

Have you tried to clear the passwords (requires the Privacy plugin)?

Re: How to disable "remember" prompt?
Posted by: lphilpot
Date: March 29, 2008 02:33AM

Quote
kko
Have you tried to clear the passwords (requires the Privacy plugin)?

Done that. :-) Also, the Remember Passwords option was not enabled to start with.

Thanks.

K-Meleon forum is powered by Phorum.