General :  K-Meleon Forum
General discussion about K-Meleon. 
Problemas con letras que llevan tilde (acento)
Posted by: Luys
Date: January 25, 2008 03:36PM

Hola a todos.
Estoy observando que (en páginas en español; no sé si en otros idiomas usarán también el acento al escribir) las letras que llevan tilde aparecen en las páginas del K-Meleon distorsionadas. Por ejemplo: mientras estoy escribiendo esto, en la izquierda, donde aparecen las diferentes secciones del foro, en la palabra "imágenes" la "á" aparece escrita con una A (en mayúscula) con pestaña encima y una "i" a continuación; en "documentación", parecido: la "ó" aparece escrita con una A (en mayúscula) con pestaña encima y un pequeño 3 al lado (como si estuviera "elevado al cubo"); en "involúcrate", a la "ú" le ocurre algo similar (en este caso, aparecen la A con pestaña encima y un signo º a continuación).
¿Cuál puede ser la causa? Y, sobretodo, ¿cómo solucionarlo?
Gracias por adelantado.

P.S. Utilizo el K-Meleon en español, v. 1.1.3 (gecko 1.8.1.10).

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: desga_2
Date: January 25, 2008 05:39PM

Hola Luys, el problema es la diferencia de codificación de caracteres de la página web.
Esto lo puedes cambiar en el menú: Ver -> Codificación

Las más usadas en español son Occidental ISO-8859-1 o Windows-1252 (codificación regional) y UTF-8 (codificación internacional). Lo normal es ponerlo en Automático, de esta forma el navegador selecciona la codificación adecuada, siempre que la página web la especifique.

La página web de K-Meleon esta codificada en UTF-8.

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: Anonymous User
Date: January 25, 2008 09:22PM

Pues a mi me ocurre que veo el menú lateral perfectamente pero vuestros textos en el foro los veo mal. Que curioso.

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: desga2
Date: January 26, 2008 05:32AM

¡Que bueno volver a verte por estos foros enaitz! surprised smiley

Lo que pasa es lo siguiente:

La página web de K-Meleon esta en UTF-8 (codificación estandar internacional), pero lo que es la aplicación del foro que esta incrustada/embebida en la página utiliza la codificación que tenga definida el usuario que escriba el post.
Así por ejemplo los post anteriores enaitz los ve mal porque tiene definida la codificación UTF-8 que es la de la página (por eso ve bien los menús) y nosotros los escribimos con Occidental (ISO-8859-1 o Windows-1252).

Este post esta escrito con codificación UTF-8 por lo que enaitz debería leerlo bien.

Lo dicho que lo único que hay que hacer es modificar la codificación de Unicode UTF-8 a Occidental (ISO-8859-1 o Windows-1252) o viceversa.
Menú: Ver -> Codificación

Saludos.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 01/26/2008 05:33AM by desga2.

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: Anonymous User
Date: January 26, 2008 06:47AM

Bueno, no es que me haya ido ni nada, simplemente es que antes era un estudiante bohemio con mucho tiempo libre y ahora soy uno de esos currantes en turnos de mañana y tarde.

A lo que vamos, tienes toda la razón, tu post es el único que puedo ver con los caracteres Unicode perfectamente escritos. La pregunta es evidente ¿Cómo hago para que todo lo que yo escriba lo pueda ver todo el mundo correctamente y para que yo pueda decodificar todo lo que escriban los demás esté en el formato que esté? Es que en el menú de codificación hay la ostia de opciones disponibles y no se cual debería de dejar marcada. ¿O es que la única opción es elegir entre ver bien el texto de los mensajes o ver bien la barra lateral? ¿No hay forma de verlo todo bien? Si no la hay ¿Cual es la opción menos mala?

Y la siguiente pregunta tambien es evidente: Si la opción que viene por defecto no es la óptima ¿Por qué no viene la mejor opción establecida por defecto y cómo hago para dejarla marcada para siempre en mi prefs.js personalizado?



Edited 1 time(s). Last edit at 01/26/2008 06:49AM by enaitzjga.

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: Luys
Date: January 26, 2008 07:05AM

Gracias por vuestras respuestas.
Me sumo a las preguntas hechas por el compañero Enaitzjga en el anterior comentario: ¿cuál es la mejor opción o, al menos, la que puede dar en conjunto el mejor resultado? Porque, como bien dice, dentro del Menú Ver/Codificación, hay un montonazo de opciones que, para los profanos en estas cosas, suenan a chino...
Recibid un cordial saludo.
L.

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: desga2
Date: January 27, 2008 02:27AM

Os lo voy a dejar claro a la primera: smiling smiley

Ver -> Codificación -> Autodetectar -> Universal
y
Ver -> Codificación -> Unicode UTF-8

Ya que de esta forma permites al navegador detectar la codificación de la página y cambiarla y Unicode UTF-8 es la tendencia de todas las páginas web ya que es una codificación Internacional (de esta forma se aseguran que su web se vea bien (todos los caracteres) en cualquier idioma).

Creo que esta es la configuración por defecto.

De todas formas yo no soy un erudito en la materia por lo que si quieres saber más lo mejor es que le preguntes a google o a la wikipedia que siempre tienen algo interesante que decir al respecto.

P.D.; Las que más se usan (al menos en lo referente a nuestro idioma) son las que indico en mi post anterior: Unicode UTF-8 y Occidental (ISO-8859-1 o Windows-1252 que viene a ser lo mismo, soló que ISO es un estandar europeo y Windows es de Microsoft). Estas codificaciones sólo las necesitas cambiar si navegas por páginas con codificación cirílica como el ruso, el árabe, el chino, el japonés, es decir de caracteres diferentes al inglés.

K-Meleon in Spanish



Edited 2 time(s). Last edit at 01/27/2008 06:40PM by desga2.

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: Anonymous User
Date: January 27, 2008 03:45AM

Así lo tengo yo (por defecto) y puedo ver bien el menú y nuestros mensajes, Desga2, pero sin embargo el de Luys no lo veo correctamente.

¿Quizá Luys no lo tiene bien configurado?

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: Luys
Date: January 27, 2008 04:55AM

Quote
enaitzjga
Así lo tengo yo (por defecto) y puedo ver bien el menú y nuestros mensajes, Desga2, pero sin embargo el de Luys no lo veo correctamente.

¿Quizá Luys no lo tiene bien configurado?

Hola, yo lo tenía configurado más o menos como decía Desga2, la configuración por defecto del K-Meleon, por lo que en vez del Unicode UTF-8 estaba puesto el Occidental ISO-8859-1. Ahora, al cambiarlo al Unoicode UTF-8 veo un montón de pequeños rombos negros con un interrogante dentro, en el lugar donde deberían estar las letras acentuadas, las "ñ", el interrogante de inicio -curiosamente, el interrogante del final de la pregunta se ve bien-...
En fin, para volverse loco. Quizás me resulte más "cómoda" la Occidental ISO-8859-1.
Saludos, y gracias por vuestras respuestas.
L.

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: araceli
Date: March 16, 2008 10:50AM

por que llevan tilde dìa, fàsil ,dolorisìsima ,fàsilmente ,pajàro ,papà

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: araceli
Date: March 16, 2008 10:52AM

por que no llevan tilde linde ,fusil, hebilla , rectamente, su ,voz

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: desga2
Date: March 16, 2008 07:49PM

@ araceli:

Puedes resolver tus dudas sobre ortografía española en la siguiente página:

Reglas de ortografía del español.

K-Meleon in Spanish

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: ana
Date: September 24, 2008 06:09AM

como ejemplo arbol - lapices- matematica - fisica - azucar-

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: pepe
Date: January 10, 2010 03:54AM

¿Alguien sabe porque es el problema cuando te pasa en todos los programas y textos del ordenador?==entiendase que tambien pasa con cualquier explorador...

Options: ReplyQuote
Re: Problemas con letras que llevan tilde (acento)
Posted by: desga2
Date: January 11, 2010 01:22AM

Comprueba que tienes bien configurado el idioma en la "Configuración Regional" en el Panel de Control de Windows.

K-Meleon in Spanish

Options: ReplyQuote


K-Meleon forum is powered by Phorum.