General :  K-Meleon Forum
General discussion about K-Meleon. 
K-Meleon prefetch issue
Posted by: Unnamed
Date: November 12, 2007 08:58PM

It isn't widely known, but there is a feature in Firefox called network prefetching.

As it is enabled by default in Firefox, K-Meleon has inherited that setting.

You can read more about it on these pages:
http://okbanlon.com/notes/prefetch.html
http://lwn.net/Articles/139725/
http://mgopinath.blogspot.com/2007/08/firefox-tip-stop-firefox-from-pre.html
http://kb.mozillazine.org/Network.prefetch-next

This feature makes K-Meleon load websites listed on a user's Google search without their permission. This is a waste of bandwidth, unexpected behaviour and a privacy / security issue. Some people still have to pay per megabyte.

You can disable it by toggling network.prefetch-next to false in about:config .

I believe network.prefetch-next should by default be set to "false" in the next release of K-Meleon as there is no good reason for it to be enabled and good reasons for it to be disabled.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: guenter
Date: November 12, 2007 09:46PM

This setting is not active by default ( I have no knowledge whether the setting work at all)

Check with:

K-Meleon extension lifeHTTpheadders?


These are my (non-)preloading results:
Quote
Google search page: listening into my requests with LiveHttpHeaders


http://www.google.de/search?q=Sterntaler%20lake%20applets

GET /search?q=Sterntaler%20lake%20applets HTTP/1.1
Host: www.google.de
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: de,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-15,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Cookie: PREF=ID=d26368a7b92133b6:TM=1194562368:LM=1194562368:S=b_3_AldwqrPR987M

HTTP/1.x 200 OK
Cache-Control: private
Content-Type: text/html; charset=UTF-8
Server: gws
Transfer-Encoding: chunked
Content-Encoding: gzip
Date: Mon, 12 Nov 2007 14:28:22 GMT
----------------------------------------------------------


When I entered the site I searched K-Meleon also did NOT PRELOAD.

If know the site quite well - it is mine smiling smiley

If You observed any preloading on other pages/sites - it is due to JavaScripts that the page owners inserted into the pages. I am aware of this technique but I do not use it.

I recommend that You use exensions such as NoScript, Adblock or the Privacy Bar (block e.g. JavaScript by default) to prevent certain types of code and content that cause that excess bandwidth use - which You do not want because of the involved costs.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: caktus
Date: November 13, 2007 01:16AM

Quote
gunter
Posted by: guenter (IP Logged)
Date: November 12, 2007 10:46AM
This setting is not active by default etc.

gunter, I don't understand the tech stuff in your post. But I just cleaned out all of my Prefetch files on November 10th and already 61 objects riside within. The only browsers I have been using are K-MeleonCCF ME 0.08 Beta 1 and 1.1.2. And I myself have extienced no such problems at all.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: JamesD
Date: November 13, 2007 02:11AM

@ caktus

Where are prefetch files stored? I want to check and see if I have any.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: kko
Date: November 13, 2007 02:29AM

Quote
guenter
This setting is not active by default ( I have no knowledge whether the setting work at all)

It is active by default. Look into about:config.


Quote
guenter
These are my (non-)preloading results:

The pages you've tested don't use prefetching, but other pages do (also Google pages).


Quote
guenter
If You observed any preloading on other pages/sites - it is due to JavaScripts that the page owners inserted into the pages.

Nope. This kind of prefetching has nothing to do with JavaScript. See the Link prefetching FAQ.


Quote
Unnamed
I believe network.prefetch-next should by default be set to "false" in the next release of K-Meleon as there is no good reason for it to be enabled and good reasons for it to be disabled.

I second this and I will provide a checkbox in the 1.5 pref panel to easily enable/disable this option.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: sensai
Date: November 13, 2007 02:43AM

I already mentioned this issue 2 years ago

http://kmeleon.sourceforge.net/forum/read.php?1,24559,24559#msg-24559

and it is true that "true" is still the default setting on a fresh k-meleon installation, just checked it.

personally I don't care, since I stopped this behavior since the day I mentioned it (user.js rules) but still think it should be disabled by default.

cheers,

sensai

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: caktus
Date: November 13, 2007 03:07AM

Quote
JamesD
Where are prefetch files stored?

C:\WINDOWS\Prefetch, or Start > Run > Prefetch > OK.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: JamesD
Date: November 13, 2007 10:18AM

OK, I checked and I have 114 items in prefetch. Do they all come from K-Meleon? Is there a way to tell? Notepad, findfast, spybotsd don't seem like something that KM would have done.

Yes the network.prefetch-next is set to true on my system.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: ndebord
Date: November 13, 2007 10:58AM

Guenter,

Strange result when I tried to check this setting by typing in about:config

XML Parsing Error: undefined entity
Location: about:config
Line Number 84, Column 34: <label id="warningTitle">&scaryWarningTitle.label;</label>
---------------------------------^

N

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: Frank
Date: November 13, 2007 11:03AM

This thread is for prefetching in K-Meloon which has nothing to do with prefetch settings in Windows - the two are quite different yes ?

Frank

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: guenter
Date: November 13, 2007 01:45PM

@kko - do You think live httpheaders is at error?

p. s. Ein User hat behauptet, dass K-Meleon wegen einer Einstellung zu viel Traffik generiert. K-Meleon sandte nicht einmal Anforderungen! Deshalb ist mir unbekannt, ob es ├╝berhaupt funzt!



Edited 1 time(s). Last edit at 11/13/2007 01:47PM by guenter.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: kko
Date: November 13, 2007 11:08PM

Quote
caktus
Quote
JamesD
Where are prefetch files stored?

C:\WINDOWS\Prefetch, or Start > Run > Prefetch > OK.

Nonsense. Consider to inform yourself about What is link prefetching?


Quote
Frank
This thread is for prefetching in K-Meloon which has nothing to do with prefetch settings in Windows - the two are quite different yes ?

Yes, of course. The one has nothing to do with the other.


Quote
guenter
@kko - do You think live httpheaders is at error?

p. s. Ein User hat behauptet, dass K-Meleon wegen einer Einstellung zu viel Traffik generiert. K-Meleon sandte nicht einmal Anforderungen! Deshalb ist mir unbekannt, ob es ├╝berhaupt funzt!

Can a photograph of a nightly sky be a proof that there is no sun? Does it matter what camera is used? smiling smiley

Try this test page. You have to enable cookies. This also proves that prefetched pages can set cookies on your system. That's problematic because a page that you visit can specify arbitrary other pages/resources to be prefetched - also from other domains. The benefit for the user is questionable since there's no guaranty that you will ever vist the prefetched pages. IMHO there's a high potential for abuse.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: caktus
Date: November 14, 2007 02:31AM

Quote
kko
Nonsense. Consider to inform yourself about What is link prefetching?

Don't understand the "nonsence" remark in relation to my post. A Prefetch folder is at C:\WINDOWS\Prefetch, and Start > Run > Prefetch > OK too will pull up the Prefetch folder. There were 61 files in my Prefetch folder. About half as many relating to local programs, documents, etc. And I did dump the contents, except for the Layout.ini of course thought it too will rebuild eventually.

While every few weeks Windows automatically cleans out PF files that haven't been utilized in a few weeks, I find that having about 35 or less files in the PF seems to result in faster program and document load. Though it can also result in slower load time for a day or so while the Prefetch files rebuild.

By the informative refernce link you provided perhaps you were infering that KM has it's own PF separate from Windows, to which I was not awhere.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: JamesD
Date: November 14, 2007 03:34AM

@ kko

Thanks for the link to the browser prefetching FAQ. Now this thread makes more sense to me.

Looks like as a user, I have two ways to control this. I can turn it off or on with the userpref or I can set my cache smaller or larger since that is where the items are stored. Since I have a DSL connection and I am not charged by amount of bandwidth, I guess I should just leave it set to defaults.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: guenter
Date: November 14, 2007 12:00PM

@kko - I did not know that this html Tag exists / SELHTML does not seem to know it sad smiley

But OK is was wrong - it can be activated by the web page without script.
Lets switch it off by default since it can be controlled from web sites.

Can You include a toggle into 1.5 pref panel?



Edited 1 time(s). Last edit at 11/14/2007 12:16PM by guenter.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: JamesD
Date: November 15, 2007 03:06AM

This could be a temporary fix until the new prefs are complete, Just copy the following code into user macro folder and name the file Prefetch.kmm

# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)
#
# ---------- Prefetch.kmm
# ---------- K-Meleon Macro Language change prefetch boolean value ---------------
#
# Dependencies : main.kmm
# Resources : -
# Preferences : -
# Version : 0.1 2007-11-14
# --------------------------------------------------------------------------------

_Prefetch_RunCode{

$_Prefetch = "network.prefetch-next" ;
$_Pf_Value = getpref(BOOL,$_Prefetch) ;
$_Pf_Value == true ? &_Prefetch_True : &_Prefetch_False ;
$_Pf_Choice = confirm("Prefetch is " . $_Pf_Text,"CHANGE ?",YESNO,QUESTION);
$_Pf_Choice == "YES" ? togglepref( BOOL, $_prefetch) : 0;
}

_Prefetch_True {
$_Pf_Text = "True";
}
_Prefetch_False {
$_Pf_Text = "False";
}

_Prefetch_ModMenu{
setmenu("&Tools",macro,"Prefetch",_Prefetch_RunCode,Misc);
}

$OnInit=$OnInit."_Prefetch_ModMenu;";
$macroModules=$macroModules."Prefetch;";

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: thejxe
Date: November 16, 2007 06:41PM

Prefecth could be a very serious problem.

http://lwn.net/Articles/139725/

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: thejxe
Date: November 17, 2007 12:35AM

From http://en.wikipedia.org/wiki/Link_prefetching

Criticisms

* Users who pay for the amount of bandwidth they use find themselves paying for traffic for pages they might not even visit.
* Webmasters who pay for the amount of outgoing traffic on their sites, are forced to pay for traffic generated by people who may never actually visit their sites.
* Advertisers pay for viewed ads on sites that are never visited.
* Browser usage statistics are skewed heavily towards browsers that implement prefetching.
* Search engine referer statistics are skewed heavily towards search engines that implement prefetching.
* Web site statistics become unreliable due to registering page hits that were never seen by the user.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: ndebord
Date: November 17, 2007 12:39AM

Guenter,

I wonder about that prefetch setting. After reading this post, I found it and promptly zipped it up and removed the original.


c:\WINDOWS\Prefetch\K-MELEON.EXE-0C202A53.zip\K-MELEON.EXE-0C202A53.pf

P.S. K-Meleon recreated a new prefetch file after exiting and restarting the browser. What setting actually stops this action (if any)?

TKs

N



Edited 1 time(s). Last edit at 11/17/2007 11:09PM by ndebord.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: sam
Date: November 17, 2007 03:02AM

I went into about:config, found 'network.prefetch-next' and toggled it to 'false'. Hope that works.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: ndebord
Date: November 18, 2007 06:34AM

Sam,

Did the same thing. Changing the setting to false did nothing. I went to the folder, deleted the file, rebooted KM and the prefetch file was recreated. There must be some other settings or it is hardwired. Don't know.

N

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: guenter
Date: November 18, 2007 07:36AM

Just check whether file size increases fast after You toggle the pref in aboutcolonconfig.

Options: ReplyQuote
Browser prefetch != OS prefetch
Posted by: rmn
Date: November 18, 2007 12:04PM

The stuff in %WINDIR%\Prefetch is not related to the topic of this thread; it's an operating system feature.

Options: ReplyQuote
Re: K-Meleon prefetch issue
Posted by: ndebord
Date: November 19, 2007 12:13AM

rmn,

Much thanks for the info and the link to wikipedia. Now I understand it.

N

Options: ReplyQuote


K-Meleon forum is powered by Phorum.