Modifying Mimetypes
Posted by: Peabody
Date: February 09, 2007 07:14AM

I'm struggling with getting mimetypes configured the way I want in K-M 1.02 (in NT4 SP6a).

I want to configure K-M to open DOC and RTF files in Wordview rather than Word. If I toggle the option to "Open it with" and enter the path of Wordview, the online file opens in Wordview. But if I additionally check the "Always ask me" option, then K-M opens in Word rather than Wordview.

I do not always want to automatically open DOC files. Sometimes I want to save for later and sometimes I want to view immediately.

Second, when K-M incorrectly opens a DOC file in Word rather than Wordview, K-M immediately steals the focus and I have to manually select Word from the Windows task bar.

Third, K-M always opens Wordview in a non-maximized window. I want Wordview to open in a maximized view.

How do I fix these problems?

Thanks.

Re: Modifying Mimetypes
Posted by: Peabody
Date: February 09, 2007 12:33PM

Some additional info:

The problem is not related solely to DOC files. After posting I noticed that K-M refused to use an alternate program for DOC, RTF, XLS, and PPT files. I prefer to use the viewer programs for these mime types because then macros cannot execute. I have configured K-M to use the Word, Excel, and PowerPoint Viewers rather than the native programs.

As I mentioned, if I enable Always Ask then K-M refuses to use the alternate programs. If I disable Always Ask then K-M uses the alternate programs.

I tested thoroughly in Firefox and FF always asks and if I select the Open option, FF uses the alternate programs rather than the default program.

I copied the FF mimetypes.rdf and that made no difference. K-M will not use an alternate program if I select Always Ask.

As a final test I tried other mime types and configured for an alternate program. I then noticed that K-M is consistent, regardless of the file type. If I configure K-M for an alternate program other than the default, AND enable Always Ask, K-M refuses to honor the alternate program selection. Disable the Always Ask and K-M then uses the alternate program. Or, if I use the default program and enable Always Ask, then K-M will indeed ask.

I have tested this thoroughly and this seems like a bug. K-M simply refuses to use an alternate program AND Always Ask.

I'd be grateful if anybody can confirm this and help.

Thanks.

Re: Modifying Mimetypes
Posted by: guenter
Date: February 11, 2007 01:56AM

I confirm. The same at my system with 1.02 de-AT version.
No idea how to work around the problem.
I no one has an idea for a couple of days - it must be reported as a bug.

Re: Modifying Mimetypes
Posted by: Peabody
Date: February 11, 2007 02:27AM

Thanks for confirming! Seeing as the Always Ask is a toggle option, hopefully correcting the problem in the upcoming 1.1 release is simple and straightforward.

Re: Modifying Mimetypes
Posted by: guenter
Date: February 12, 2007 11:44AM

I do not think that it is easy as toggling a pref. But maynbe we are lucky.

Re: Modifying Mimetypes
Posted by: JujuLand
Date: February 16, 2007 05:50PM

I have tried this problem, and I confirm that mtypes works correctly, but it's K-Meleon which doesn't verify the mimetypes.rdf parameters before opening. Open seems to only open the default program

I think it's a bug for Dorian.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: Modifying Mimetypes
Posted by: guenter
Date: February 16, 2007 09:04PM

thx for input alain / rmn has also looked.
It is a bug or improvement request - the behaviour must be anciant.
Nobody found it during the last years - so it is nothing urgent smiling smiley

Re: Modifying Mimetypes
Posted by: rmn
Date: February 16, 2007 10:06PM

I've filed it as bug 900.

K-Meleon forum is powered by Phorum.