General :  K-Meleon Forum
General discussion about K-Meleon. 
Pages: Previous1234Next
Current Page: 2 of 4
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Peabody
Date: November 21, 2006 11:09AM

Quote

Add: #674 Hide layers toolbar when only one layer open

Is this going to become a user option or become hard-coded? I very much want a tab to appear on the Layers toolbar even when I have no pages open. This just the way my brain is wired, that is all. Now that I am growing comfortable with K-M and am considering setting K-M as my default browser, any such coerced new "feature" would simply cause me to start looking for another browser family. Please---let users decide and if that will be the design then thank you and ignore my rant. smiling smiley

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: felipe
Date: November 21, 2006 04:09PM

Quote
desga2
If you read this vcredist.exe version 6 SP5 not is compatible with Win2000! Win2000 must be update only with his Service Packs (in this vcredist.exe files are includes).

That's not right, you can download the file from here and then install it.
I've done. Why don't you? If you read the entire link, it goes to this:
http://www.microsoft.com/downloads/details.aspx?familyid=a8494edb-2e89-4676-a16a-5c5477cb9713&displaylang=en
smiling smiley

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: marcopolo
Date: November 21, 2006 06:31PM

I tried to install in w2003 server but it doesn't run.
sad smiley

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: kko
Date: November 21, 2006 07:29PM

Quote
ra
Oh, and Edit - Preferences claimed that "Klassic" was my skin, although it was/is Phoenity_ra from my profile, set directly in prefs.js while the browser was closed.

That's only an issue when using old profiles. It's resolved once you change the skin.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: desga2
Date: November 21, 2006 09:11PM

Must I created a new bug post with not run problems in Win2000 and Win2003 (specially in es-ES versions)? Must i waited? Is Dorian working in it? Must i tried something more? Will be Kmeleon 1.1 Gecko 1.8.1 (final release) compatible with Win2000 systems?

Must i stopped ask? smiling smiley

Greetings.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: felipe
Date: November 21, 2006 09:44PM

After hours of experiments I only have reached to have my eggs broken and a terrible headache. I've decided to came back to KM version 1.02 while I'm waiting for a patch or a happy solution. If a patch or a beta wich will supports W2000 is not released I'll came back definitely to IE7. This new release of KM is a completely fiasco. I reinstalled windows 2000 from zero and I tested it with SP1, SP2, SP3, SP4 and this last release of KM doesn't work in none case. I decided to install this KM release in some computers and it runs proudly well in W9x/Me/XPSP1 but not in XP64, nor in windows 2003 server (as marcopolo said before). Some friends of mine found problems with some computers with XPSP2, but finally it runs, and also there were found that it doesn't work properly with Windows Vista RC1, although this last point is being tested now by one friend of mine. I've made all, I've reinstalled all from zero, including every addons from microsoft, FrameNetwork, DAC, MSXML&SDK, including a revision of any DLL using the software Dial_a_fix_full from http://djlizard.net/ but no success. This release is useful as a snake bitting the eyes.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: kko
Date: November 21, 2006 09:57PM

@desga2: Please no bug report, this is an alpha version! 1.1 is compatible with Win2k (I have no problems here). Have you tried to redownload the package? Maybe your download is corrupt. Have you tried do disable all interfering applications (personal firewall, virus scanner, ...)?

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: felipe
Date: November 21, 2006 10:35PM

Quote
kko
@desga2: Please no bug report, this is an alpha version! 1.1 is compatible with Win2k (I have no problems here). Have you tried to redownload the package? Maybe your download is corrupt. Have you tried do disable all interfering applications (personal firewall, virus scanner, ...)?

I have the same problems than Desga2 and Felipe.
sad smiley

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: felipe
Date: November 21, 2006 10:37PM

Quote
felipe
Quote
kko
@desga2: Please no bug report, this is an alpha version! 1.1 is compatible with Win2k (I have no problems here). Have you tried to redownload the package? Maybe your download is corrupt. Have you tried do disable all interfering applications (personal firewall, virus scanner, ...)?

I have the same problems than Desga2 and Felipe.
sad smiley

I have the sampe problems than Desga2 and Marcopolo.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: maty
Date: November 21, 2006 11:22PM

Perhaps the problem is the js3250.dll of K-M 1.1. This .dll work wrongly with K-M Nauscopico 1.02.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Dorian
Date: November 22, 2006 01:39AM

Did you try with absolutely nothing (no menus, no accels .. . delete default/settings) ?

I only have access to W98SE, WXPSP2 and VistaRC2. If they're not affected, I can't do much.

Quote
Peabody
Is this going to become a user option or become hard-coded?

An option, obviously.



Edited 1 time(s). Last edit at 11/22/2006 01:39AM by Dorian.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Hao Jiang
Date: November 22, 2006 01:53AM

Here is the mouse gesture plugin supporting drag and drop for this version:

http://kmeleon.et8.net/gestures.rar

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: desga2
Date: November 22, 2006 01:57AM

OK, I try in my job (Win2000 SP4 es-ES) to download again Kmeleon 1.1a2 Gecko 1.8.1 and now to executing k-meleon.exe error message showed (yes!). Error message says that msvcp71.dll and msvcr71.dll are needed. I download K-Meleon 1.02 WITH INSTALLER. I install it and copy this 2 files in Kmeleon 1.1a2 Gecko 1.8.1 folder. AND RUN IT!

The question are, why in my home system not run? I will tried this at night.
I tried to copy this files before (2 days ago, read later post) and not ran.

Edited:
I detected that new Kmeleon 1.1a2 Gecko 1.8.1 not create Profiles folder, is this OK for final version or only in this alpha version?



Edited 1 time(s). Last edit at 11/22/2006 02:07AM by desga2.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Hao Jiang
Date: November 22, 2006 02:15AM

Quote
desga2
I detected that new Kmeleon 1.1a2 Gecko 1.8.1 not create Profiles folder, is this OK for final version or only in this alpha version?


This version as default will create KM's profile folder in your %app% directory, if you still want traditional profile folder in your km's directory, create a profile.ini and write:

[profile]
path=profiles
IsRelative=1

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: desga2
Date: November 22, 2006 02:59AM

OK, thanks Hao, I found it.

Note; I don't Admin user in this system.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: ra
Date: November 22, 2006 03:42AM

Quote
kko
Quote
ra
Oh, and Edit - Preferences claimed that "Klassic" was my skin, although it was/is Phoenity_ra from my profile, set directly in prefs.js while the browser was closed.

That's only an issue when using old profiles.

No, this was a completely new profile.

Is the selected skin saved at two places, so modifying prefs.js isn't enough anymore?

Quote

It's resolved once you change the skin.

True. :-)

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: kko
Date: November 22, 2006 04:51AM

@ra: Just in case you've edited prefs/user.js to set the skin: The skin name is now stored without the trailing backslash (this backslash is causing what you've observed).

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: ra
Date: November 22, 2006 05:25AM

Quote

Chg: Favicon support using moz API

Looks good. But I noticed a small bug re. transparency: has an transparent background in Opera and FireFox, but in K-M the background is black when it is displayed as siteicon.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: desga2
Date: November 22, 2006 08:21AM

Quote
desga2
I tried copy next files not included in Kmeleon 1.1a2 Gecko 1.8.1;
profile.ini
msvcr71.dll
msvcp71.dll

Not results was being obtained.
(I don't know because not ran when i did it)

Now I repeat this actions in my home system Win2000 SP4 (es-ES);
1) Deleted all Kmeleon 1.1a2 Gecko 1.8.1 folder and file .7z downloaded.
2) Download again the file K-Meleon1.1a2_1.8.1.7z. (begining post on thread)
3) Extract all files from K-Meleon1.1a2_1.8.1.7z to a new folder.
4) Copy next files from your K-M 1.02 on new K-Meleon1.1a2_1.8.1 folder:
profile.ini => (content of this file in Hao post in this thread)
msvcr71.dll => (dll files only available on WITH INSTALLER version of K-M 1.02)
msvcp71.dll => (NOT in .7z files... why? I don't know)
5) RUN!RUN!RUN! (only once is needed) smiling smiley

Problem and misterius solved. Please, Dorian can you included this files in .7z files? I think that you must included it in .7z files (including 1.02 version).
Thanks all people for yours help and interest in our problem.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Hao Jiang
Date: November 22, 2006 08:38AM

For people who got problem running this build. Try the CCF version which includes possible missing files.

Hao

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: none_inside
Date: November 22, 2006 05:25PM

Quote
desga2
Quote
desga2
I tried copy next files not included in Kmeleon 1.1a2 Gecko 1.8.1;
profile.ini
msvcr71.dll
msvcp71.dll

Not results was being obtained.
(I don't know because not ran when i did it)

Now I repeat this actions in my home system Win2000 SP4 (es-ES);
1) Deleted all Kmeleon 1.1a2 Gecko 1.8.1 folder and file .7z downloaded.
2) Download again the file K-Meleon1.1a2_1.8.1.7z. (begining post on thread)
3) Extract all files from K-Meleon1.1a2_1.8.1.7z to a new folder.
4) Copy next files from your K-M 1.02 on new K-Meleon1.1a2_1.8.1 folder:
profile.ini => (content of this file in Hao post in this thread)
msvcr71.dll => (dll files only available on WITH INSTALLER version of K-M 1.02)
msvcp71.dll => (NOT in .7z files... why? I don't know)
5) RUN!RUN!RUN! (only once is needed) smiling smiley

Problem and misterius solved. Please, Dorian can you included this files in .7z files? I think that you must included it in .7z files (including 1.02 version).
Thanks all people for yours help and interest in our problem.

No succes until I've copied these files to windows directory too (?).
Now it works. Thank you Desga2.
Thank you

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: marcopolo
Date: November 22, 2006 05:32PM

I solved the problem installing Microsoft® C Runtime Library, v. 7.10.3077.0

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: felipe
Date: November 22, 2006 05:36PM

Quote
none_inside
No succes until I've copied these files to windows directory too (?). Now it works. /quote]

It the files are in the directory of windows, you don't need to add them to KM directory. I copied the two file to windows directory and it runs good now.


Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: marcopolo
Date: November 22, 2006 05:38PM

There is not a problem from KM release, but Flock, Firefox, OpenOffice and some portable applications have added these two files.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Dorian
Date: November 22, 2006 11:57PM

Quote
desga2
Problem and misterius solved. Please, Dorian can you included this files in .7z files? I think that you must included it in .7z files (including 1.02 version).
Thanks all people for yours help and interest in our problem.

I've tried my seamonkey build and had the same problem when the dlls were missing. Why there isn't the usual "can't found dll" error?...

AFAIK redistributing those dlls like that is not legal (but that's really a minor problem though tongue sticking out smiley). Next time, the installer will be used like I usually did for beta releases.



Edited 1 time(s). Last edit at 11/22/2006 11:58PM by Dorian.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Terry
Date: November 23, 2006 07:27AM

@Dorian - thank you for your concern. This was an alpha build to use at our own risk. Actually, for an alpha, it works more like a finished product. In any respect, I found no problem with the way it was issued as an alpha build. Personally, I preferred it this way. Thanks for all your hard work.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: Dorian
Date: November 23, 2006 06:18PM

Quote
ra
Looks good. But I noticed a small bug re. transparency: has an transparent background in Opera and FireFox, but in K-M the background is black when it is displayed as siteicon.

I'm aware that some icons can't be show correctly because they use a 2bpp transparency bitmap, which is not supported by window. Which mean I have to convert it to a 4bpp image. But I've never found any icons like that until now.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: ra
Date: November 25, 2006 12:47AM

The send insecure warning dialog and others show now up in the task bar. With many K-M windows open I would prefer them to have a different icon (like a red lizard) or no icon at all to make it easier to find them (I just had one pop up, but continued to work elsewhere, had lots of green icons on the task bar, but didn't notice the one from the dialog at first...).

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: ra
Date: November 25, 2006 11:00AM

Quote
Dorian
Fix: #878 Ctrl-Backspace deletes wrong part of URL

The following might be related:

If an URL ends with "/something123/" double-clicking on "something123" selects "something123/" <- including the slash (incorrect).

But when the end of the URL is "/something123/a" double-clicking on "something123" selects "something123" <- without the slash (correct).

In both cases "something123" should be selected, with the slash being the delimiter.

Options: ReplyQuote
Re: Kmeleon 1.1a2 Gecko 1.8.1
Posted by: ra
Date: November 26, 2006 08:18AM

Next one, a question this time: Is there an easy way to *disable* this new shrink image feature on a left click, that's there when one views a large image? Or bind it to a double-left-click?

Options: ReplyQuote
Pages: Previous1234Next
Current Page: 2 of 4


K-Meleon forum is powered by Phorum.