exec program doesn't work
Posted by: Lars
Date: October 22, 2004 05:36AM

Hi,

I want to start an external app, made the config files on another machine and transferred them. Thouhg nothing happens when I click the toolbar button. In toolbar.cfg I have:

Tastatur {
macros(exec_Keys)
Tastatur öffnen
toolhot.bmp[9]
toolcold.bmp[9]
tooldead.bmp[9]
}

and in macros.cfg:

exec_Keys {
menu=&Tastatur
exec("\"C:\\Programme\\Click-N-Type\\Click-N-Type.exe\"");
}


worked fine on the machine I tested on, but not on the target. What could be wrong, and where could I start to debug?

Lars

Re: exec program doesn't work
Posted by: Fast Sjonny
Date: October 22, 2004 05:40AM

I think it should be:

exec_Keys {
menu=&Tastatur
exec("C:\\Programme\\Click-N-Type\\Click-N-Type.exe\");
}


But I can be wrong ofcourse.....

Jan.

Re: exec program doesn't work
Posted by: Lars
Date: October 22, 2004 05:58AM

makes no difference... the \" are to escape the following " I think

Lars

Re: exec program doesn't work
Posted by: jsnj
Date: October 22, 2004 10:22AM

Seems correct. Just double-check the path carefully. Sometimes the mistakes are the silliest. Other than that, I don't know because it looks correct.

Re: exec program doesn't work
Posted by: Lars
Date: October 22, 2004 05:24PM

jep, everythings installed default on two machines, on one machine it works (W2k) on the other not (Win98SE). Seems that the OS is the only difference, but what could be the reason?

Lars

Re: exec program doesn't work
Posted by: alain.NOSPAM.aupeix@wanadoo.fr
Date: October 22, 2004 06:15PM

And why don't:

exec("C:\\Programme\\Click-N-Type\\Click-N-Type.exe");

Re: exec program doesn't work
Posted by: Lars
Date: October 22, 2004 06:49PM

I tried
exec("C:\\Programme\\Click-N-Type\\Click-N-Type.exe");
also of course, no difference. As I wrote above, the \ just escapes the following ".

Re: exec program doesn't work
Posted by: Michel
Date: October 22, 2004 07:42PM

Since win9x is ms-dos, you might try ms-dos names:
exec("\"C:\\Progra~1\\ClickN~1\\ClickN~1.exe\"");

Michel

Re: exec program doesn't work
Posted by: Lars
Date: October 22, 2004 07:51PM

ah, that's a great idea, could very well be the reason. I'll try at home and post results.

Lars

Re: exec program doesn't work
Posted by: rumpel
Date: October 22, 2004 07:58PM

maybe the path of macros.cfg is wrong
It works fine for me.W98se

rumpel

Re: exec program doesn't work
Posted by: Lars
Date: October 26, 2004 03:30AM

hm, strange... I tried the Dos-Name path, also doesn't work. @rumpel, could you perhaps change your config for this?

Lars

Re: exec program doesn't work
Posted by: rumpel
Date: October 26, 2004 04:39AM

macros.cfg and toolbars.cfg changed:

http://www.ezshare.de/files-de/38390/Click_N.exe.html

für 0.82
beide Dateien am Ende geändert
Tastatur Button neben dem Los Button

macros.cfg gehört in
..K-Meleon/Profiles/default/xxx.slt
nicht in ..../defaults/profile

macro plugin geladen

rumpel

Re: exec program doesn't work
Posted by: Lars
Date: October 26, 2004 05:49AM

ok, ich glaube ich habe die Ursache gefunden: Ich habe kein macro plugin. Die .dll ist zwar vorhanden, aber unter preferences wird das plugin nicht aufgelistet. Mache ich was falsch?

Lars

Re: exec program doesn't work
Posted by: Lars
Date: October 26, 2004 05:52AM

ich habe schnell mal auf nem XP notebook installiert: Hier habe ich mehr plugins (für jede .dll auch ein plugin). Auf dem 98 Rechner sinds einige weniger.

Lars

Re: exec program doesn't work
Posted by: rumpel
Date: October 26, 2004 02:02PM

Die datei macros.dll gehört in das Verzeichnis kplugins.
Eigentlich hilft nochmal drueberinstallieren mit allem was
man installieren kann.Oder die dll einfach von einem anderen Rechner kopieren.

rumpel

Re: exec program doesn't work
Posted by: rumpel
Date: October 26, 2004 02:40PM

da hab ich irgenwie eine falsche Version der macros.cfg
erwischt,hier die andere:

http://www.ezshare.de/files-de/38546/Click_N_2.exe.html

rumpel

Re: exec program doesn't work
Posted by: Lars
Date: October 26, 2004 03:37PM

Ich habe sowieso frisch installiert, da ich frische .cfg's wollte ;) trotzdem habe ich nur die Hälfte der Plugins... (die .dll's liegen aber korrekt im kplugins ordner) Gibts nen debug Modus, bei dem protokolliert wird welche .dll's geladen werden?

Allerdings bin ich am überlegen auf den Rechner NT zu installieren, da das für Kiosk Mode sicherer ist, und vermutlich sogar etwas schneller als 98. Dann dürfte sich das Problem (hoffentlich) eh' erledigt haben.

Gruss, Lars

Re: exec program doesn't work
Posted by: rumpel
Date: October 26, 2004 06:49PM

Das mit dem debug Mode weiss ich nicht.
Vielleicht fehlen dir auch irgendwelche Systemdateien.

Gruss
rumpel

Re: exec program doesn't work
Posted by: Lars
Date: October 26, 2004 07:14PM

hm, schon möglich. Ist aber nix verbogen oder so, Standard W98SE Installation halt. Da müsste man halt jetzt die Abhängigkeiten kennen ;) Bezeichnend ist, dass nicht nur eine .dll nicht geht, sondern mehrere...

Gruss, Lars

Re: exec program doesn't work
Posted by: rumpel
Date: October 27, 2004 12:26AM

Ich hab als updates
directX 8... oder 9..
den IE 5.5 und
ndis24.....exe
aber sonst eigentlich nichts besonderes.
Da musst du jetzt mal probieren.
Anfangen würde ich mit directX.

Gruss
rumpel

Re: exec program doesn't work
Posted by: guenter
Date: October 27, 2004 12:57AM

Nt? denk bitte daran, dass für schon für 0.8.2 dll upgedated werden mußten.
also falls du da dann unstimmigkeiten mit Sichtbarkeit von elementen hast, dann.

http://kmeleon.sourceforge.net/wiki/index.php?id=FAQ#install1
stichwort troubleshooting
& endlich mal nen thread dem ich mühelos folgen konnte - gruss nach Minden &...
aus Hannover

Re: exec program doesn't work
Posted by: rumpel
Date: October 27, 2004 03:13AM

Hallo guenter

Sind die Knochen wieder zusammen?
Ich hoffe dir gehts schon wieder besser.
Wie wäre es mit einer deutschen übersetzung für 0.9b2

http://www.ezshare.de/files-de/39250/KM_lang_0.9b2_de.exe.html

Gruss und gute Besserung nach Hannover
rumpel

Re: exec program doesn't work
Posted by: guenter
Date: October 27, 2004 06:34PM

ja, danke der nachfrage. montag werde ich wieder arbeiten, denke ich.
danke auch für die übersetzung, da wird sich wer sehr freuen.
hab sie gleich per mail weiter geleitet.

benutze grad w-b menus mit 0.9 - so kann ic am leichtesten mit/an xul sachen arbeiten.

leider wird Jordans mtypes, wegen eines ungeklärten fehlers nie mit 0.9 (so wir er jetzt ist) gehen. auch nicht mit der version, die jetzt heimlich bei "quellenschmiede" auf dem server hier abgelegt (aber noch nicht angekündigt) ist.

die version ist sehr viel stabiler - aber wieder etwas langsam.
gruss

Re: exec program doesn't work
Posted by: rumpel
Date: October 27, 2004 06:59PM

Die übersetzung ist aber noch nicht ganz vollständig.Der IE Link
funktioniert noch nicht und die Suchmascinen sind auch noch
nicht richtig angepasst.Wenn der IE benutzt werden soll bzw. der Link dorthin muss in macros.cfg \program files\ in \Programme\
geändert werden.Da hab ich aufgehört und bis jetzt noch nicht
weitergemacht.Ich wart jetzt erstmal auf die nächste Version

Gruss
rumpel

Re: exec program doesn't work
Posted by: guenter
Date: October 27, 2004 09:26PM

ist völlig ok - wo ich es hin geschickt habe, wird schon lange kein MSIE mehr benutzt
nur noch mozillas - & sie könnte selbst support leisten - muß es bei ihren freundinnen wohl auch manchmal - ich soll dir jedenfalls jetzt schon dank ausrichten.

dass auf diesem server im verzeichnis test ein etwas stabilerer ist - hast du mitbekommen?

Re: exec program doesn't work
Posted by: rumpel
Date: October 28, 2004 12:05AM

Ich hab die Version 0.9b2 und warte bis eine offizielle neue
Version da ist.Zum richtigen testen fehlt mir auch die Zeit.

Re: exec program doesn't work
Posted by: guenter
Date: October 28, 2004 03:18AM

hier auch - wechselbalg hat uns allen viel zeit gekostet. Jan will/kann das nächste halbjahr nix mehr machen. wir mußten ja auch noch zum teil noch lernen.
zumindest ich.

und dann ist noch - über unsere devs sind wir wenig erbaut.

weing zeit - wir versuchen so gut zu helfen - wie es geht. das muß reichen.
m. E. - besser wäre k-m mit 1.8.a2 chrome gewesen - bzw von dort weiter machen.
habe heute nochmals die 1.8 ter GREs durchprobiert.
1. 8.a5 nightly GREs zum teil IMHO beeindruckend viel schneller als eins-siebener GREs - alle eigentlich: soweit ich sie durchprobiert habe.

die devs haben viel zeit bei den eins siebener verquadert. - & hoffe sie machen wenigstens nen zusätzlichen stischen - sonst wäre es u. U. geschwindigkeitsmäßig peinlich.

ich komme mit p500 und wechselbalg auf test-seiten
http://www.24fun.com/downloadcenter/benchjs/benchjs.html
bis 24.06 seconds, Oct 27, at 08:11:44 runter
- wo der offizielle bei rotwerd: 38.21 seconds, Oct 27, at 07:38:05 liegt

dort wird nicht alles gemessen - auch beim 0.9 ist viel licht - aber es ist peinlich

Re: exec program doesn't work
Posted by: guenter
Date: October 28, 2004 03:19AM

hier auch - wechselbalg hat uns allen viel zeit gekostet. Jan will/kann das nächste halbjahr nix mehr machen. wir mußten ja auch noch zum teil noch lernen.
zumindest ich.

und dann ist noch - über unsere devs sind wir wenig erbaut.

weing zeit - wir versuchen so gut zu helfen - wie es geht. das muß reichen.
m. E. - besser wäre k-m mit 1.8.a2 chrome gewesen - bzw von dort weiter machen.
habe heute nochmals die 1.8 ter GREs durchprobiert.
1. 8.a5 nightly GREs zum teil IMHO beeindruckend viel schneller als eins-siebener GREs - alle eigentlich: soweit ich sie durchprobiert habe.

die devs haben viel zeit bei den eins siebener verquadert. - & hoffe sie machen wenigstens nen zusätzlichen stischen - sonst wäre es u. U. geschwindigkeitsmäßig peinlich.

ich komme mit p500 und wechselbalg auf test-seiten
http://www.24fun.com/downloadcenter/benchjs/benchjs.html
bis 24.06 seconds, Oct 27, at 08:11:44 runter
- wo der offizielle bei rotwerd: 38.21 seconds, Oct 27, at 07:38:05 liegt

dort wird nicht alles gemessen - auch beim 0.9 ist viel licht - aber es ist peinlich
gruss aus Hannover

Re: exec program doesn't work
Posted by: guenter
Date: October 28, 2004 03:20AM

oh ne das hatte ich schon mal - den 0.9 schaffe ich bald ab.

Re: exec program doesn't work
Posted by: rumpel
Date: October 28, 2004 02:33PM

Lernen müssen wir wohl immer wieder.
Das mit den devs na ja , mal abwarten.Eigentlich ist es immer einfacher (und sicherer?) nicht gleich die neueste Software zu benutzten.
Da erspart man sich viel Arbeit mit updates.Wenn die ältere Software aber schlecht war,hat man viel vergeblich gemacht.

Bei dem Benchmarktest komm ich so auf ca.16 sec.
Allerdings hab ich Layers,Mouse Gestures und External....
abgestellt. Die meisten Funktionen brauch ich eh nicht.
Da ist kein grosser Unterschied zu 0.82
Auch nicht beim laden von Seiten.
Zur Zeit benutze ich immer noch 0.82,mit einem Teil der macros
aus Wechselbalg.
Wenn ich mal die Zeit hab,werde ich die macros bearbeiten,
also alles löschen was ich nicht benutze.Dann funktioniert auch
meistens alles was noch da ist besser.
Wir sollten hier aber Schluss machen und warten was Lars macht.

Gruss
rumpel

K-Meleon forum is powered by Phorum.