General :  K-Meleon Forum
General discussion about K-Meleon. 
Post Data Message
Posted by: John
Date: August 11, 2014 12:10AM

How can I prevent the "post data" message when using the back button ?

Options: ReplyQuote
Re: Post Data Message
Posted by: SweetJane
Date: August 11, 2014 01:45AM

There's an easy way to prevent this in FireFox with an option in about:config.
I don't know about K-Melon. I just uninstalled K-Melon after playing around with it for awhile. If K-Melon developers don't want to provide an easy solution then find a better browser. If I want to disable a security feature, that's my responsibilty. A browser should provide an option to disable this anoying message.

Most of the time when this occurs there is no security issue, it's just an anoyance.

Do Yourself A Favor And Find A Better Browser.

Options: ReplyQuote
Re: Post Data Message
Posted by: Zero3K
Date: August 12, 2014 04:00AM

I tried adding these values (as integers) which have had no effect:

browser.sessionstore.postdata = -1
browser.sessionstore.privacy_level = 1

Hopefully Dorian is able to get them to work properly.



Edited 1 time(s). Last edit at 08/12/2014 04:01AM by Zero3K.

Options: ReplyQuote
Re: Post Data Message
Posted by: Zero3K
Date: September 04, 2014 02:52PM

Dorian: Any thoughts on gettig those options to work?

Options: ReplyQuote
Re: Post Data Message
Posted by: guenter
Date: September 04, 2014 08:45PM

Quote
SweetJane
There's an easy way to prevent this in FireFox with an option in about:config.
I don't know about K-Melon. I just uninstalled K-Melon after playing around with it for awhile. If K-Melon developers don't want to provide an easy solution then find a better browser. If I want to disable a security feature, that's my responsibilty. A browser should provide an option to disable this anoying message.

Most of the time when this occurs there is no security issue, it's just an anoyance.

Do Yourself A Favor And Find A Better Browser.

Hei Sweety, it is the same about:config pref option as in Firefox and just as easy. I know enough K-Meleon. I use it as default for more years than the Firefox browser project exists and was not just playing around. The K-Meleon developers do a GUI as replacement for the inresponsive XUL GUI of the main branch Mozillas. They do not pretend to cater for anything else.

Do Yourself a favor and find a better answer - like posting the about:config pref of Firefox - or stop posting here until You know more and do not just have to play the Mozilla browser guru around here.



Edited 1 time(s). Last edit at 09/04/2014 09:45PM by guenter.

Options: ReplyQuote
Re: Post Data Message
Posted by: guenter
Date: September 04, 2014 09:15PM

Quote
Zero3K
Dorian: Any thoughts on gettig those options to work?

AFAIK. Post data are send by foward and reload button.
IMHO not from back button.

I might be wrong / I am not 100 % certain. See my p.s.

The pref options You tried do not exist in FF. Neither in KM.

Wrong: But they exist as defaults (only). They do not exist in any prefs.js.

Anyway. Both posters gave their mail address instead of logging in or posting without that. "Sweety" has manipulated his post data / IP = localhost. :D

IMHO both trolling.

To verify?

You could send them a mail with SeaMonkey with sending mail status notification on. Than You judge by the response of their mail servers whether they are so innocent and naive as they pretend. ¬_¬

p.s. That about post data is what I also found with Live HTTP Headers Extension for K-Meleon 1.5.4 & with that version.

But maybe I got the wrong readings or the extension does not work anymore?

Maybe try with one of the many header sniffers for FF whether one works with 74.

If yes?

You can find out for 74 yourself.:)



Edited 3 time(s). Last edit at 09/05/2014 04:21AM by guenter.

Options: ReplyQuote
Re: Post Data Message
Posted by: Dorian
Date: September 05, 2014 12:46AM

AFAIK there is no option to disable this in FF.
Those prefs are about sessions and have nothing to do with the document expired message.

Options: ReplyQuote
Re: Post Data Message
Posted by: guenter
Date: September 05, 2014 03:02AM

Quote
Dorian
AFAIK there is no option to disable this in FF.
Those prefs are about sessions and have nothing to do with the document expired message.

Dorian, IMHO the two strangers were trolls anyway. Their posts make no real sence to me. One either edited his HTTP header's IP data... Else he is posting from the Forum's server...

Greetings

p.s. Zero.

I already mentioned that the other interpretation makes no sence with back button.

More verbose version of above. :)

Not reachable by default via about:config of Firefox.

Falls back to a useful default. Looked it up now.
Quote
Mozillazine
0 Do not store POST data in saved sessions (default)

Pref can be created and then changed. Is for session recovery.

Values and purpose: session restore.

Positive integer or -1 means store POST data. Which will be send again.

Therefore the other mentioned pref must be also created before use and must be set to prevent re-sending POST data like buy orders or mail from secure sites.
To prevent the keeping/resending of POST data on secure sites the value =
Quote
Mozillazine
1 Store extra session data for unencrypted (non-HTTPS) sites only
is used for pref browser.sessionstore.privacy_level.

Hope my English is understandable enough.



Edited 2 time(s). Last edit at 09/05/2014 04:12AM by guenter.

Options: ReplyQuote
Re: Post Data Message
Posted by: Zero3K
Date: September 13, 2014 11:23PM

How about having it not resend the Post Data when pressing the backspace key?

Options: ReplyQuote
Re: Post Data Message
Posted by: guenter
Date: September 14, 2014 01:57AM

Quote
Zero3K
How about having it not resend the Post Data when pressing the backspace key?

What or who makes You believe Post Data are sent when You do backspace?

Maybe install http://livehttpheaders.mozdev.org/ and check Yourself
what if anything is sent when you do backspace!


p.s. You'd call it with chrome://livehttpheaders/content/LiveHTTPHeaders.xul

Else use this macro created for K-Meleon AFAIR 1.x. Tools were in help then.

# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)

# ---------- LiveHTTPHeaders (Live HTTP Headers) -------------------------------------------------------------------
#
# Dependencies	: main.kmm (OpenURL) 
# Resources	: -
# Preferences	: -
#
# ------------------------------------------------------------------------------------------------------------------

livehttpheaders{
$OpenURL="chrome://livehttpheaders/content/LiveHTTPHeaders.xul"; &OpenURL_InNewWindow;
}

# ----- PRIVATE

_livehttpheaders_BuildMenu{
# edit menu
setmenu(KMAbout,macro,"Live HTTP Headers",livehttpheaders);
}
$OnInit=$OnInit."_livehttpheaders_BuildMenu;";

# ------------------------------------------------------------------------------------------------------------------
$macroModules=$macroModules."livehttpheaders;";

BTW. I already wrote that backspace did not sent a darn thing on my PC.

I installed a new version of livehttpheaders and have the same readings.



Edited 1 time(s). Last edit at 09/14/2014 02:00AM by guenter.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.