Google Cache
Posted by: Larkspur
Date: November 27, 2013 04:33AM

Google is up to their usual stupid tricks again.

Yesterday I performed several Google searches. The link to Google's cache was clearly visible. Today it's gone. There's a green down arrow that I assume points to other search options (including Cache) but nothing happens when I click on it.

It's been that way with Firefox for some time and I have the same problem with that down arrow not responding when clicked on. But in K-Meleon until today the cache link was still visible.

Anyone here notice this change? And does the down arrow function for the rest of you folks?

It really steams me when Google pulls this kind of stunt. G-r-r-r-h!

Larkspur



Edited 1 time(s). Last edit at 11/28/2013 12:00AM by Larkspur.

Re: Google Cache
Posted by: fred
Date: November 27, 2013 03:47PM

With javascript disabled i have the old in cache links ( k-meleon 1.7 )

The arrow works in Opera 12.16 and the new k-meleon 74

Perhaps a javascript function not supported by the old javascript engine?

Re: Google Cache
Posted by: Larkspur
Date: November 27, 2013 11:57PM

Wow! I just disabled javascript and the cache link is back! Thanks!

I depend on the cache and "text only version" for pages that take too long to load. Significantly, Google group pages are the most difficult to load, hence the necessity for that text only link.

Out of curiosity, how does disabling javascript make that link reappear? And when do I really need javascript?

Larkspur


Postscript: Just obtained one answer to above question: Turning off javascript disables formatting options when I post.



Edited 1 time(s). Last edit at 11/28/2013 01:38AM by Larkspur.

Re: Google Cache
Posted by: Larkspur
Date: November 28, 2013 01:36AM

Another Google change I've noticed since posting:

When I search through Google images and click on one, instead of taking me straight to the image where you can click on "see original size" or "go to originating web page", it now goes straight to the original web page. Which means of course that it takes much longer to load as it loads the entire page, not just the one image you're interested in.

Just checked this with Firefox and Opera, and same thing happens.

What gives?

Re: Google Cache
Posted by: rodocop
Date: November 30, 2013 04:40AM

try to change useragents and check difference in how Google shows things! ;-)

This is Google's way to serve different browsers - no bug, just feature! tongue sticking out smiley


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 11/30/2013 12:18PM by rodocop.

Re: Google Cache
Posted by: fred
Date: November 30, 2013 05:24PM

Could not found a ways around it, seems to be the new way how things work...
Seems like searching images with Bing.com looks better...

Re: Google Cache
Posted by: rodocop
Date: December 03, 2013 05:18PM

K-Meleon Twin 1.6 (UserAgent - FF15):




Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 12/03/2013 05:19PM by rodocop.

Re: Google Cache
Posted by: Larkspur
Date: January 28, 2014 11:42AM

Hi Guys,

I recently removed all traces of previous versions of Sun Java that might be gumming up the works and did a fresh install of the latest version (Version 7 Update 51). I did so in the hopes of getting those little green down arrows that point to Google's cached pages to actually work. Those cached pages were easily available to me until just before I posted this thread, when the "cached" link was replaced with the little green down arrows.

In order to access those cached pages (which I need to do all the time) I have to first disable JavaScript in K-Meleon's Preferences, close the browser, and open it again from scratch. And then rinse and repeat to enable JavaScript again for the many, many pages that require it. An annoying, tedious procedure.

So I was hoping that updating Sun Java to its latest version would allow me to click on those pesky green down arrows and bring up the menu for the cached page, as should happen in Firefox, but also doesn't, for me at least, since I am running an older version of Firefox.

Problem is, the update did not solve the problem. When I click on the down arrows, absolutely nothing happens. Is there another solution that I have not tried yet?

Thanks in advance,

Larkspur

Re: Google Cache
Posted by: siria
Date: January 28, 2014 03:02PM

Huh? Your description isn't very clear so I'm surely reading you wrong, but you can't be really meaning to restart the whole browser after each JS toggle, right??
And enabling the Privacy Toolbar makes switching most easy, if button space is not a critical prob. Of course all buttons can be hidden except those you want to really keep (probably Toggle JS, Toggle Java, Clear Cache, switch UA, Toggle images)

Luckily the websites I'm interested in need JS only rarely for essential functionality, at worst 3% of them, so the JS block speeds up loading extremely.

But it's true that google seems to have changed something again in their code, in order to force people to switch JS "on", allowing them to easier spy us out if someone wants to get a cached page - hate it too, although for other reasons sad smiley And as you say that's not enough, not even using JS will now show those links!

But if you prefer to use javascript anyway - have you tried with the new KM74/KM1.8.0-beta versions?

Edit: Ah, now I see what you meant with "text links"! Didn't notice them before (since by default surfing JS-less ;-)) Those only appear in the cached header now. Not much use from there of course. Although simply blocking images helps a lot too.
Hm, it seems one just has to add "&strip=1" at the end of a normal cache link to get the text version... This could be done by a macro or by adding it as own search engine.

Ha - try this:
Switch to a fake higher FF user agent, switch JS OFF, and then click here:
https://www.google.com/search?q=larkspur&strip=1
Then click on the normal cache link and the text-only version appears - or is it just me now??

PS: that's not "off-topic", but "general". Anyone can move? ;-)



Edited 8 time(s). Last edit at 01/29/2014 03:34AM by siria.

Re: Google Cache
Posted by: siria
Date: January 29, 2014 01:32AM

Okay, without needing to fake the User Agent, but javascript needs to be blocked:

KM 16 shows the old plain cache links again (by adding gbv=1)
http://www.google.com/search?gbv=1&q=%s

KM 16 opens those plain cache links as text-only-version first (by adding gbv=1 and strip=1)
http://www.google.com/search?gbv=1&strip=1&q=%s

(%s is the search term, whatever)
Those links can be added as bookmarks or hotlist and can get a Nickname, e.g. "gc" or "gt"
That means I can now type into the URL bar "gt whatever", hit the Return-key, and the google-results for "whatever" appear smiling smiley

They can also be added to the search engines list, but not sure if the normal way works again, guess it was a bit buggy in the last beta versions.

Of course javascript can easily switched on and off again any time by hitting F7, or better by enabling the privacy toolbaar with the JS button (View>Toolbars>PrivacyBar)

--------

I kinda like that smiling smiley smiling smiley
Have made it now my default search engine, and it also works on the search button. Exactly what I always wanted to speed things up, do a search and the result list offers already text-only links!
So, Thanks for asking grinning smiley



Edited 5 time(s). Last edit at 01/29/2014 04:04AM by siria.

Re: Google Cache
Posted by: siria
Date: January 29, 2014 04:06AM

PS: you mentioned google groups taking so long to load, that's why you need the text cache.
What I'm doing myself, being on win98se, is this:
1) keep Javascript blocked
2) set the UserAgent to a fake IE7 string
3) and use the new search option from above.
Result is a perfectly basic and ultrafast scriptless version of google groups smiling smiley

My fake IE7 useragent string is
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1
Can be changed temporarily in F2>Privacy&Security>Paranoia / custom.
But way too complicated and vanishes after next switch.
Easier: a permanent string can be added in about:config
Far better: After adding the permanent string use the useragent menu on right-clicking the UA button in the privacy bar, that way switches are just 1 click away smiling smiley



Edited 1 time(s). Last edit at 01/29/2014 04:10AM by siria.

Re: Google Cache
Posted by: siria
Date: January 29, 2014 04:38AM

Quote
Larkspur
When I search through Google images and click on one, instead of taking me straight to the image where you can click on "see original size" or "go to originating web page", it now goes straight to the original web page. Which means of course that it takes much longer to load as it loads the entire page, not just the one image you're interested in.

No idea how to prevent that, but in general disabling javascript goes a long way to speed things up. Of course it's still far more than just loading 1 pic, but still far less than also loading all scripts.

Since you're on dial-up I'd recommand to block embedded objects too (flash etc), but out-of-the-box there's no toggle for it, which makes it slightly complicated for normal users. I have it, but needs an extra macro and modifying toolbars and having a toolbar image etc., slightly complicated. Oh well, am hoping since years that some day it may be included by default.
The prob with "objects" in gecko is, as soon as javascript is blocked (for speed reasons or otherwise) then embedded objects like flash are automatically *allowed* again! sad smiley
(The gecko pref exists long since: permissions.default.object / INT / 1=enabled / 2=blocked / 3=originating site only)



Edited 1 time(s). Last edit at 01/29/2014 04:46AM by siria.

Re: Google Cache
Posted by: Larkspur
Date: January 29, 2014 09:58AM

Hi Siria,

Okay, you learn something new every day!

I'd never used the Privacy Bar. With it enabled I can now toggle JavaScript on and off without having to close out the browser and reopen it.

-- "Of course all buttons can be hidden except those you want to really keep (probably Toggle JS, Toggle Java, Clear Cache, switch UA, Toggle images)"

Question: I went into Preferences and unchecked the Privacy box in K-Meleon Plugins. That removes "Cache," "Passwords," and "Clear All" from the Privacy Bar. But I'd like to remove/hide "Cookies" "User Agent" and "Java" as well. How do I keep only the ones I want?

-- "But if you prefer to use javascript anyway - have you tried with the new KM74/KM1.8.0-beta versions?

I haven't tried anything above K-Meleon 1.6.0 Beta 2.6 because I'm assuming 1.6.0 Beta is the most stable version currently available.

I found that I could not run K-Meleon 1.6.0 Beta 2.6 and 1.6.0 Beta 2 concurrently. Is that true for
KM1.8.0-beta as well? If I could make all the extensions work from the same central directory I wouldn't mind having multiple versions of K-M on my drive. But it gets messy when each version stores it's extenstions/plugins and what-all in separate directories. I've forced them to use the same folder for cache and bookmarks, but otherwise everything else ends up in each version's separate directories.

I've never tried switching User Agent. Internet Explorer is irrecoverably broken on my machine and will need a clean install of Windows before it ever works again, and because I'm on dialup, I've been forced to stick with an older version of Firefox (4.0). So I doubt messing with User Agent will help me any.

But I still can't figure out why those green down arrows don't work for me. According to my research, when you hover over them, the links to Google's cached pages are supposed to become visible...

They don't work for me in Firefox either, but I'm assuming that's because of the outdated version I'm using.

But thanks for putting me on to the Privacy Bar. That helps my problem a lot.

Larkspur

P.S.: The above post was composed in answer to Siria's first reply. Just arrived to find the newer replies. Will come back to respond to them later...



Edited 1 time(s). Last edit at 01/29/2014 10:00AM by Larkspur.

Re: Google Cache
Posted by: guenter
Date: February 02, 2014 02:23PM

Quote
Larkspur
Hi Siria,

Okay, you learn something new every day!

I'd never used the Privacy Bar. With it enabled I can now toggle JavaScript on and off without having to close out the browser and reopen it.

-- "Of course all buttons can be hidden except those you want to really keep (probably Toggle JS, Toggle Java, Clear Cache, switch UA, Toggle images)"

Question: I went into Preferences and unchecked the Privacy box in K-Meleon Plugins. That removes "Cache," "Passwords," and "Clear All" from the Privacy Bar. But I'd like to remove/hide "Cookies" "User Agent" and "Java" as well. How do I keep only the ones I want?

-- "But if you prefer to use javascript anyway - have you tried with the new KM74/KM1.8.0-beta versions?

I haven't tried anything above K-Meleon 1.6.0 Beta 2.6 because I'm assuming 1.6.0 Beta is the most stable version currently available.

I found that I could not run K-Meleon 1.6.0 Beta 2.6 and 1.6.0 Beta 2 concurrently. Is that true for
KM1.8.0-beta as well? If I could make all the extensions work from the same central directory I wouldn't mind having multiple versions of K-M on my drive. But it gets messy when each version stores it's extenstions/plugins and what-all in separate directories. I've forced them to use the same folder for cache and bookmarks, but otherwise everything else ends up in each version's separate directories.

I've never tried switching User Agent. Internet Explorer is irrecoverably broken on my machine and will need a clean install of Windows before it ever works again, and because I'm on dialup, I've been forced to stick with an older version of Firefox (4.0). So I doubt messing with User Agent will help me any.

But I still can't figure out why those green down arrows don't work for me. According to my research, when you hover over them, the links to Google's cached pages are supposed to become visible...

They don't work for me in Firefox either, but I'm assuming that's because of the outdated version I'm using.

But thanks for putting me on to the Privacy Bar. That helps my problem a lot.

Larkspur

P.S.: The above post was composed in answer to Siria's first reply. Just arrived to find the newer replies. Will come back to respond to them later...

!.) You can toggle Java Script without the bar when You use the hotkey F7.
F8 toogles popup.

2) The bar can be edited via Edit / Configuration / Toolbars (toolbars.cfg).

Cave! Do so only after You did a backup of the file. If You make a mistake when You edit the file it can prevent the browser from starting again.

The file toolbars.cfg is located in the folder of the used skin.

Comments out the button toggle Cookies

# Cookies{
# macros(pref_ToggleCookies)
# Block Cookies
# privhot.bmp[2]
# privcold.bmp[2]
# }

Comments out the button Java /Applets

# Java{
# macros(pref_ToggleJava)
# Block Java Applets
# privhot.bmp[4]
# privcold.bmp[4]
# }

Comments out the button User Agent

# User Agent{
# ID_APP_ABOUT|&User Agent
# Check Browser Identity. Right-click to choose different User Agent.
# privhot.bmp[16]
# privcold.bmp[16]
# }


Actually I made different changes. I only wanted to prevent that visitors like my grandson can perform damage to my settings. While he can use needed items he cannot delete things that I want to keep.

Quote
My privacy bar


# Animation{
# macros(pref_ToggleAnimation)
# Block Image Animation
# privhot.bmp[0]
# privcold.bmp[0]
# }

# Colors{
# macros(pref_ToggleColors)
# Block Page Colors
# privhot.bmp[1]
# privcold.bmp[1]
# }

Cookies{
macros(pref_ToggleCookies)
Block Cookies
privhot.bmp[2]
privcold.bmp[2]
}

# Images{
# macros(pref_ToggleImages)
# Block Images. Press F9 to toggle.
# privhot.bmp[3]
# privcold.bmp[3]
# }

# Java{
# macros(pref_ToggleJava)
# Block Java Applets
# privhot.bmp[4]
# privcold.bmp[4]
# }

JavaScript{
macros(pref_ToggleJavaScript)
Block JavaScript. Press F7 to toggle.
privhot.bmp[5]
privcold.bmp[5]
}

Popups{
macros(pref_TogglePopups)
Block Popups. Press F8 to toggle.
privhot.bmp[6]
privcold.bmp[6]
}

# Referer{
# macros(pref_ToggleReferer)
# Block HTTP Referer
# privhot.bmp[7]
# privcold.bmp[7]
# }

%endif

%ifplugin privacy

Clear Cache{
privacy(ClearCache)
Clear Cache
privhot.bmp[8]
privcold.bmp[8]
}

# Clear Cookies{
# privacy(ClearCookies)
# Clear Cookies
# privhot.bmp[9]
# privcold.bmp[9]
# }

# Clear History{
# privacy(ClearHistory)
# Clear History
# privhot.bmp[10]
# privcold.bmp[10]
# }

# Clear Passwords{
# privacy(ClearSignon)
# Clear Passwords
# privhot.bmp[11]
# privcold.bmp[11]
# }

# Clear URLBar{
# privacy(ClearMRU)
# Clear URL Bar History
# privhot.bmp[12]
# privcold.bmp[12]
# }

%endif

# %ifplugin macros & privacy
# Clear All{
# macros(kPrivacy_ClearAll)
# Clear All
# privhot.bmp[13]
# privcold.bmp[13]
# }
# %endif

%ifplugin macros

Kill Flash{
macros(JS_killFlash)
Kill Flash Objects
privhot.bmp[14]
privcold.bmp[14]
}

# Kill Applets{
# macros(JS_killApplets)
# Kill Java Applets
# privhot.bmp[15]
# privcold.bmp[15]
# }

User Agent{
ID_APP_ABOUT|&User Agent
Check Browser Identity. Right-click to choose different User Agent.
privhot.bmp[16]
privcold.bmp[16]
}

3.) You sure can use different versions of K-Meleon at the same time.
But for this each K-Meleon must run with a different profile.

Add the command line parameter -new to the desktop link via windows properties.

E:\.k-meleon1.6beta2.en-US\k-meleon.exe -new

This starts the most recent 1.6 beta of Dorian on my PC even when other versions are running already. I use all K-Meleons with a portable setup. Each has its own profile in its install folder. You need to grant user writing rights to the K-Meleon profiles folder.

siria makes the different versions ask which profile to use on startup and has global profiles in Windows USER APP folder. AFAIK all recent versions since 1.5.x can use each others Profiles.

A list of the commands can be found locally under

resource:///defaults//commands.html

or via Edit / Configuration / Commands


4.) You need to change user agent to Firefox 3+ or equivalent SeaMonkey for some pages. Else You get an error. These pages have a stupid browser switch that does not recognized K-Meleon as user of Gecko Rendering Engine and Java Script.



Edited 2 time(s). Last edit at 02/02/2014 10:13PM by guenter.

Re: Google Cache
Posted by: siria
Date: February 10, 2014 03:38AM

Hi guenter, that thread is lost here, please move it to "General"?

K-Meleon forum is powered by Phorum.