Re: Anyone still using kmeleon?
Posted by: rodocop
Date: November 10, 2013 08:24AM

It seems that I have the same kit of libs, but I never got such a message.

Spellcheck is just half-working here on Win7 - it underlines wrong words, but doesn't suggest anything.

James, what spellcheck kplugin version you've checked?


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 11/10/2013 08:25AM by rodocop.

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 10, 2013 09:08AM

@ rodocop

Seems like we both have the same version dated 1/13/2011 and having 84,480 bytes.

Re: Anyone still using kmeleon?
Posted by: rodocop
Date: November 10, 2013 08:36PM

Yes, but I've tested also old version (about 33k in size) with the same result


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: Anyone still using kmeleon?
Posted by: JujuLand
Date: November 10, 2013 10:46PM

Well, I've been able to run Km174 under Linux.

I'll post the complete things to do here on Linux Forum.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: Anyone still using kmeleon?
Posted by: rodocop
Date: November 10, 2013 11:41PM

Good job, comrade!


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: Anyone still using kmeleon?
Posted by: Dominika
Date: November 11, 2013 07:06AM

Tabbar at bottom doesn't work. All tabbar location options do not work. Thanks if you fix.

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 11, 2013 07:30AM

Update to History4me
Quote

I have a quick and dirty fix for history. It is not fancy and you need to do your own maintenance for how much to history to keep. All this does right now is give you a record. For now the "View history" is under the Tools menu.

I have changed the method of communicating between History4me.kmm and History4me.exe. It no longer uses the clipboard. You are now free to copy and paste without an overwrite by History4me.

https://dl.dropboxusercontent.com/u/1522294/History4me.7z

Re: Anyone still using kmeleon?
Posted by: JujuLand
Date: November 12, 2013 04:11AM

Fred,

Can you confirm the path of the files in your system ?
And which is your distro ?

Thanks
A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: Anyone still using kmeleon?
Posted by: Fred
Date: November 12, 2013 08:34AM

I still use uninstalled distros working in RAM from USB stick.
One of them is Xubuntu 12.04 .
To save RAM I usually do not use the wine .deb of the system,
but wine 1.1.10 for Slackware, which does not have any dependencies, because
Wine 1.4 used from the system debs has a size of more than 120 Mb .
Wine 1.1.10 has no fakedll folder, and the libs are in /usr/lib/wine.
So I replaced only dwmapi.dll.so and advapi32.dll.so with the
files from Wine 1.6.
I have also a Wine1.6 standalone on USB stick which I can use with a
start script, which defines $PATH and $LD_LIBRARY_PATH to the
files on the USB stick. But this is demanding a libc6 version 2.11 or
higher, which not all my distros have, and which is not always installable
in an easy way.
To answer your question I have installed for once Wine 1.4 on Xubuntu
using synaptic.
I replaced the two libs in /usr/lib/i386-linux-gnu/wine and KM-74 worked
OK as far as I can see.
Changing the fakedlls did not seem to be necessary.
I prefer Xubuntu because Ubuntu is bigger and I also do not like the
Unity desktop, but I think that there is no difference concerning Wine 1.4 .
By the way: Firefox for Windows seems to need the full Wine 1.6 version.

Regards

Fred

Re: Anyone still using kmeleon?
Posted by: Fred
Date: November 12, 2013 08:40AM

Correction :
Wine 1.4 is sufficient for Firefox for Windows (but not Wine 1.1.10 as far as I know).

Fred

Re: Anyone still using kmeleon?
Posted by: JujuLand
Date: November 13, 2013 01:46AM

Well I see that U-X-K-Lunbuntu use the same folder (seems normal ...)

So I will just make a script for it. If needed will modify for there config.
But, I will maks two archives, as I see that so files are different between i386 and x32_64

For your stick install, I think of MultiSystem which can help you.
It allows to boot on a few systems present on the stick.
It's really interesting, and a feature I don't use but which can interest you, is that it allows to have a kind of disk where you can save some datas and perhaps save installs (I haven't tried this last feature).

Thanks
A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 2 time(s). Last edit at 11/13/2013 02:01AM by JujuLand.

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 14, 2013 12:46AM

I have upgraded the History4me system. Just a little testing done, but it seems to perform well. It provides links that you may use to return to a page in history.

The link is here:
https://dl.dropboxusercontent.com/u/1522294/History4me.7z

You will have to discard your old History4me.txt file in your profile. This one contains more information.

Re: Anyone still using kmeleon?
Posted by: JujuLand
Date: November 14, 2013 08:39PM

Instructions to run K-Meleon under Linux are here

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: Anyone still using kmeleon?
Posted by: naruman
Date: November 15, 2013 02:17AM

K-meleon New Update:

Contain:

1-History manager.
2-Clear cache ' DISK + MEMORY ' [ while k-elemon running] .
3-Some of Good Old macros.

Macros:

1-Flash blocker.
2-IFrames list.
3-Google Redirect Killer.
4-user agent 2.
5-Reload All Images.
6-SpeedUp .
7-on/offline button .

instructions:

1-Unpack k-melen 74 + Dorian Updat .
2-Rename k-meleon\kplugins\macros2.dll To macros.dll .
3-Delete 'chrome' folder.
4-Unpacking my update over k-meleon files.
5-Run k-meleon & set ' view/toolbars/privacy bar ' activate.


Bug:

Like all chrome running under km74 , right click does not work & open new chrome layer from chrome file cause to kill k-melleon !!

So i make the History manager on new tab ,not in new window & use the selection right click to copy the sites URL Then you can paste it in the address bar.

Notes:

History manager need some new modules in omni.ja .

& I will add Clear ' cookies + history ' to clear cache soon .



Edit :

Add This macros To Solve problem open History URL.

After add the file , the 'Open History URL' option appear in right click menu.



Edited 1 time(s). Last edit at 11/15/2013 03:14AM by naruman.

Re: Anyone still using kmeleon?
Posted by: mouse
Date: November 15, 2013 05:30AM

In answer to the topic question

My wife was using KM constantly until a year ago under XP and I still use the 1.6 Beta for mainstream browsing from time to time when get fed up with IE/FF/etc bloatware. I also use it for software testing as well.

Only problem was that some web pages would not load. So I have great hopes for this new version... excellent news.

And thanks very much!

Mouse (Mike)

Re: Anyone still using kmeleon?
Posted by: kingsparrow
Date: November 15, 2013 09:16AM

Oh Naruman, this is sweet................thanks

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 16, 2013 09:21PM

Thanks Naruman,

Now I don't have to do any more work on my temporary history. Less work for me is better.

I did have to make some changes. In toolbar.cfg for Klassic I changed the history to match the default skin.

Do you know what I could change in Policies Manager to make it work? I just get a blank screen now.

Re: Anyone still using kmeleon?
Posted by: naruman
Date: November 16, 2013 11:15PM

Quote
JamesD
Thanks Naruman,

Now I don't have to do any more work on my temporary history. Less work for me is better.

I did have to make some changes. In toolbar.cfg for Klassic I changed the history to match the default skin.

Do you know what I could change in Policies Manager to make it work? I just get a blank screen now.


To run ' Policies Manager ' , just put ' policymanager.jar + policymanager.manifest ' in chrome folder & add this line to ' chrome.manifest ' (the one in chrome folder) :

manifest policymanager.manifest

This will make you able to run it's xul, but The extension will not work correct .

As there is bug in running sub xul from another one , so if yo click on 'create new policy ' or 'edit policy ' it will close k-meleon .

Either the bug is fixed or the sub xul run in iframe but we will had to rebuild all the xul.

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 17, 2013 01:42AM

Another big thank you, naruman.

Policy Manager appears.

At least now, I won't have to poke around in my prefs.js to see if I included a site or not. I just imported my sites, etc. from a working install, so I am good to go now.

Re: Anyone still using kmeleon?
Posted by: rodocop
Date: November 17, 2013 06:57AM

naruman & JamesD,

I found second Dorian's kmeleon.exe to have some bugs in work with xul extensions so the question is:

1) if use first KM exe and place jars into omni.ja (and edit chrome.manifest there) - will the xul work right or not?

2) and if go further and unpack jar and place it's content folder by folder in corresponding places inside omni.ja (some more editing needed for chrome.manifest) - the same question.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 11/17/2013 06:58AM by rodocop.

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 17, 2013 09:17AM

I see that we have a new error console in this latest code. I made an error in a macro to test and it found it.


@ rodocop

Perhaps naruman can answer about the chrome, jars, and ja files. I am completely lost since everything went in the ja file.

@ naruman

Edit: TCache.kmm does nothing. I think I tried that myself. There is no kmprefs(cache) or it is not called that way. It has a error in line 16. I fixed the error and tried it again. It does not show in the menu because there is no kmprefs(cache).



Edited 3 time(s). Last edit at 11/17/2013 09:51AM by JamesD.

Re: Anyone still using kmeleon?
Posted by: naruman
Date: November 17, 2013 10:09PM

Quote
rodocop
naruman & JamesD,

I found second Dorian's kmeleon.exe to have some bugs in work with xul extensions so the question is:

1) if use first KM exe and place jars into omni.ja (and edit chrome.manifest there) - will the xul work right or not?

2) and if go further and unpack jar and place it's content folder by folder in corresponding places inside omni.ja (some more editing needed for chrome.manifest) - the same question.

k-meleon.exe The old and new both have the bug .

Running jar from inside 'omni.ja' .... the bug still exist.

Running unpacked xul from inside the 'omni' .... we still have the bug.

I think 'the bug ' have no relation of the xul place , maybe it related of controlling 'Xulrunner' little much , i not sure.

I found one or two method of calling the xul , do not kill km , but that means all xul will need to rebuild .

Quote
JamesD

Edit: TCache.kmm does nothing. I think I tried that myself. There is no kmprefs(cache) or it is not called that way. It has a error in line 16. I fixed the error and tried it again. It does not show in the menu because there is no kmprefs(cache).

Where is this macro 'TCache.kmm' i can't find it?

Did you mean 'ClearCache.kmm' , it's called from 'Privacy Bar' in skins\toolbars.cfg.

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 17, 2013 10:26PM

Quote
naruman
Where is this macro 'TCache.kmm' i can't find it?

No, you won't find it. I have egg all over my face. I went back and looked at the date created and this was my attempt to bring up the cache section of KMprefs. I modeled it after hotlink.kmm but cache does not work that way. I guess I forgot to delete the old code.

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 17, 2013 10:40PM

Is there supposed to be a file called jsbridge.xpt in the chrome? I don't have one, but the error console said something tried to read one. Is it in a jar or ja and doesn't have a manifest?



Re: Anyone still using kmeleon?
Posted by: naruman
Date: November 17, 2013 11:24PM

Quote
JamesD
Is there supposed to be a file called jsbridge.xpt in the chrome? I don't have one, but the error console said something tried to read one. Is it in a jar or ja and doesn't have a manifest?

jsbridge.xpt is an old components file , is supposed to be related of Microsoft Foundation Class 'mfc' dialogs and xul , help in view passwords

It's in 'kmeleon.manifest' & it was in Dorian new update , i guess it's little to old for Gecko to read .


Edit:

After put it in omni.ja\components folder & add it to 'components.manifest' + remove it from 'kmeleon.manifest' , the error disappear , but nothing has changed .



Edited 1 time(s). Last edit at 11/17/2013 11:55PM by naruman.

Re: Anyone still using kmeleon?
Posted by: naruman
Date: November 19, 2013 12:43AM

I had found things i hope it would help in solving some bugs:

-the alert 'in chorme js & js inject' doesn't work and also the prompt dialog .

The two bugs related of the interfaces nsIDOMWindow & nsIDOMWindowUtils.






The Second bug 'prompt' was fine in the original km.exe 'before the first update' , something has changed in the source code causing the bug.

And about open sub xul .I don't think there's any bugs in open new xul from another , but something else , can't find it yet , as it kill k-meleon while testing the codes .

Re: Anyone still using kmeleon?
Posted by: rodocop
Date: November 19, 2013 01:58AM

as I can guess, subXUL problem may be caused by the 'relative path problem' inside XUL-code.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: Anyone still using kmeleon?
Posted by: Dorian
Date: November 19, 2013 03:20AM

New build. It should be complete, just add the XRE.

- I've found a workaround for the open xul crash (seems like a xul bug in the embedding context)
- Chrome and default folder were moved inside browser.
- Quickly added FF places interface.
- Various fixes and privacy plugin

Re: Anyone still using kmeleon?
Posted by: JamesD
Date: November 19, 2013 04:20AM

I am a dummy. What is the XRE? It says I need mozjs.dll. Is that in the xre?

Edit: Should this just be extracted to the prior version?

Edit 2: Apparently you extract over the prior version. Some privacy data is working now, but I cannot attach the tab/window buttons to the tab bar anymore. Edit configuration still does not have the special right click menu yet. I have lost the policy manager window again.



Edited 2 time(s). Last edit at 11/19/2013 05:12AM by JamesD.

Re: Anyone still using kmeleon?
Posted by: rodocop
Date: November 19, 2013 08:33PM

James,
XRE is XUL Runtime Environment e.g. xulrunner-related files...


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


K-Meleon forum is powered by Phorum.