1.7 Zoom not working, sort ofconfused smiley
Posted by: caktus
Date: November 02, 2013 11:09AM

1.7 Zoom not working, sort ofconfused smiley

When I open a new window, Zoom works from the View menu but does not work from Ctrl+mouse wheel unless I first Zoom from the View menu.

When I open a new tab, Zoom from Crtl+mouse wheel doesn't work unless I first Zoom from the View menu or click on a previous tab then back.

Might anyone have an idea how to fix this?

Thank you.

Charlie

~~If it ain't broke, why screw it up?~~


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: rodocop
Date: November 02, 2013 02:15PM

Have you installed a 'bugfix' to 1.7 from realgy?

I have no idea about would it fix your problem or not but it's invaluable fix for 1.7 inborn bug.

Try this and tell us about.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: JujuLand
Date: November 02, 2013 03:24PM

Try to have a look, and perhaps print or export, the prefs values between when launching, and after having used zoom menu.

I wouldn't be surprised if a pref has changed or has been set.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 1 time(s). Last edit at 11/02/2013 03:29PM by JujuLand.

Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: caktus
Date: November 03, 2013 02:52AM

@ rodocop

I installed the bug fix macro. As you suggested, it didn't fix the zoom problem.

@ JujuLand

I'm not sure I understand which "prefs" to check. I checked the before and after prefs in about:config and didn't notice any changes.

BTW, more zoom problems. Occasionally, a page will not zoom using Ctrl+mouse wheel even after using zoom in the View menu or after having clicked back and fourth between tabs. Also, now sometimes zoom in the view menu doesn't work and some times a page will zoom using Ctrl+mouse wheel after leaving the page or tab open for a few minutes.

I am beginning to think maybe the installation is corrupted and I may need to download a fresh copy of 1.7.

Late breaking news: I downloaded and installed a fresh copy of 1.7 and with the default installation I experienced the same problems.

I guess I will download and try Twin again if I can find the D/L link again.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 1 time(s). Last edit at 11/03/2013 03:22AM by caktus.

Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: rodocop
Date: November 03, 2013 03:17AM

what is your assembly of 1.7 build?

Look for size and date of zoom.kmm - my KM Twin has this file created at 30.08.2010 and sized as 5977b.

And it works properly.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: caktus
Date: November 03, 2013 03:52AM

Quote
rodocop
what is your assembly of 1.7 build?

Look for size and date of zoom.kmm - my KM Twin has this file created at 30.08.2010 and sized as 5977b.

And it works properly.



For the 1.7 I just downloaded and installed, the zoom.kmm Properties Details indicates Date Created 11/2/2013
but Date Modified 7/23/2008 (that's weird)
and Size 5.97KB.

Zoom works with Ctrl+mouse wheel except for tabs.

Another problem I m experiencing with the new install of 1.7 is regardless how I set Tab bar mouse control, Browsing and Tabbed Browsing settings, I can only open two tabs. and all sucesssive tabs open in the second tab and when I click to close the second tab those previouse tabs come into focus but the last (second) tab will not closed unless I click on the "X" and OK to close all tabs. I hope what I am saying here makes since.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 2 time(s). Last edit at 11/03/2013 04:33AM by caktus.

Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: JamesD
Date: November 03, 2013 07:40AM

I have put a version A2 of KM 1.7 here. https://dl.dropboxusercontent.com/u/1522294/K-Meleon1.7a2.7z

I don't know if it is any better than the one you are trying, but I don't think I have the problems that you noted except for a slow response for Crtl + mouse wheel. This version has two KM.exe files. I am using the larger one and the zoom.kmm date is correct.

This may be exactly what you can get from Sourceforge. I just cannot remember from where and when I obtained it.

I hope this is of some use.

Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: caktus
Date: November 03, 2013 08:36AM

Thank you, James. I'll install this one and see how it works out.

Charlie

~~If it ain't broke, why screw it up?~~


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: caktus
Date: November 04, 2013 12:57PM

@ JamesD RE: K-Meleon 1.7.0

When I pin a km.exe to the task bar or create a shortcut using the Default.exe the KM.exe's do not work and renders an error "Could not initialize XPCOM." However, KM.exe shortcuts created from "Send to > Desktop (create shortcut)" and then pinned to Taskbar do work.

Even though I ran Default.exe, the older Internet shortcuts including Favorites shortcuts render the error: "Could not initialize XPCOM. I have tried to manually reset the file associations but that didn't work either. Do you have any idea what might be causing this error or how to fix it?

When I open a new window, zoom with Ctrl+Mouse wheel works as it should. However, links that I open in a new tab will not zoom with Ctrl+Mouse wheel, but it does work after clicking on a previous tab then back. The zoom buttons work as they should.

Aside from the error, I can deal with the zoom problems as this version otherwise seems to be stable. The version also seems to load pages a little faster and more properly, though it still has a little trouble loading some images but I understand that is expected so far.

Perhaps the problems are related to Windows 8, more and more I am learning to hate this OS.mad smiley More and more I feel like throwing Windows 8 out the window and replacing it with XP Pro even though it will soon loose support.mad smiley

Charlie

~~If it ain't broke, why screw it up?~~


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: rodocop
Date: November 04, 2013 06:23PM

Charlie,

look this message and the next one in that thread...


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: caktus
Date: November 04, 2013 11:26PM

Quote
rodocop
Charlie,

look this message and the next one in that thread...

If your simply conferring that the problems with 1.7a are innate to it's make-up, I can dig it. Hopefully, a developer will come along and complete the work for us KM'ers. But if you're just poking some fun at my spastic grammar I can only say touché.grinning smiley Most days of late, I have to lead a rather medicated life and I tend to get lost in things.

BTW, I'll probably manage to continue using 1.7a since it has become super fast after having used it for a while.

Charlie

~~If it ain't broke, why screw it up?~~


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: rodocop
Date: November 05, 2013 12:21AM

No jokes-pokes ;-) This is a 'by-design' problem.

But my 1.7 works fine from the Seven's Taskbar (it's KM Twin's 1.7 made from db+ build)


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: 1.7 Zoom not working, sort ofconfused smiley
Posted by: caktus
Date: November 05, 2013 06:06AM

Quote
rodocop
No jokes-pokes ;-) This is a 'by-design' problem.

But my 1.7 works fine from the Seven's Taskbar (it's KM Twin's 1.7 made from db+ build)

I've used both and so far and I seem to be experiencing the same on both builds. I really don't see any difference. Well, so far.

I'm beginning to think it may be a compatibility problem with Windows 8 or perhaps particular settings I've assigned to something. Perhaps it has something to do with Classic Shell and my trying to make Windows 8 as UN-Windows 8 as I can manage. What ever it is, it's not enough to make me stop using KM.

Late breaking news:cool smiley Dumped everything KM and went back to 1.6beta2.6 and customized it and at least everything is back they it was before I started massing with the 1.7's. After I rest my mind for a spell I'll start messing with 1.7 again, probably the db+ build.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 2 time(s). Last edit at 11/05/2013 10:09AM by caktus.

K-Meleon forum is powered by Phorum.