1.6 CPU requirements?
Posted by: JohnHell
Date: August 20, 2013 01:14AM

Hi,

I'm now on a Pentium 233 MMX (long story short, my P4 PSU exploded and the replacement at home, doesn't have enough power for the upgrades till the last time was used) and I can't run 1.6b2.6 (well, any 1.6.x) because crashes before open.

The thing is that after applying all the needed dlls and dependencies, nothing helps and Depencency Walker stops with Xppref32.dll because of an illegal operation, exiting K-meleon.

And that made me think if the 1.6.x executable is expecting some instructions in the CPU.

Now I'm running 1.5.4 (quite naked (without any profile configured)), so at least til 1.5.4 it was possible to run in a so old CPU.

So:
Windows 2000 Sp4
Pentium 233Mhz MMX
256RAM
VC++ redistributibles applied and all known dependencies


Any ideas, or is really what I was thinking (CPU instructions missing)?

I hate this situation, and I think I wont have a PSU until 3 weeks :-S

Re: 1.6 CPU requirements?
Posted by: JamesD
Date: August 20, 2013 04:06AM

I am not an expert in this area, but I found the following the FAQ.

Quote
http://kmeleon.sourceforge.net/docs/faq.php#requirements
Users of Windows 2000 may experience problems due to the absence of msvcp60.dll. Install the Windows 2000 Support Tools from your setup CD or consult the Windows Update website.


Re: 1.6 CPU requirements?
Posted by: JohnHell
Date: August 20, 2013 04:45AM

That's all checked. (First thing I do as I'm a Win2k user, in all of my own pcs).

That is why it is so strange. K-meleon is not requesting any special file, just when loads that file, makes an illegal operation :S

If there is someone out there with the same CPU (Pentium 1) and can confirm it, could be great.

BTW, I had installed in this "emergency" PC K-meleon 0.8.2 xDDD Ah... loads of memories comming.

Re: 1.6 CPU requirements?
Posted by: rodocop
Date: August 20, 2013 06:52AM

Have you this already installed?

It's obligatory for 1.6.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 2 time(s). Last edit at 08/20/2013 06:53AM by rodocop.

Re: 1.6 CPU requirements?
Posted by: JohnHell
Date: August 20, 2013 10:43PM

Yes, as I said, rodocop, all redistributables (VC++ 2005 and 2008) and dependencies (if needed, as msvcp60.dll) are installed ;)

If anyone has experience with Dependency Walker...:
https://hotfile.com/dl/240668300/a8c64ce/k-meleon.dwi.html

Looks like I made a mistake, or something, now the error is on xpcom_core.dll with illegal instruction (I think I read other line).

Re: 1.6 CPU requirements?
Posted by: JohnHell
Date: August 22, 2013 10:35PM

Finally I'm using Opera 11.64¹ that, amazingly performs better than Gecko engine built with 1.5.4 (1.8). More than better, lighter for my P 233 MMX. Also has better HTML5 and CSS3 support than Gecko 1.8 so somes pages don't look messed up.

That feels as a traitor, but I need to use what my system lets me ;) while I'm on this emergency PC.


¹ 11.64 it's an "old" version but I can't run higher versions because they relay on hardware acceleration and I'm on a S3 virge DX/GX only. I miss my broken TNT2 that I had in this system configuration sad smiley

Re: 1.6 CPU requirements?
Posted by: ohmygod
Date: September 22, 2013 11:04PM

Quote
JohnHell
Finally I'm using Opera 11.64¹ that, amazingly performs better than Gecko engine built with 1.5.4 (1.8). More than better, lighter for my P 233 MMX. Also has better HTML5 and CSS3 support than Gecko 1.8 so somes pages don't look messed up.That feels as a traitor, but I need to use what my system lets me ;) while I'm on this emergency PC.¹ 11.64 it's an "old" version but I can't run higher versions because they relay on hardware acceleration and I'm on a S3 virge DX/GX only. I miss my broken TNT2 that I had in this system configuration sad smiley

Amazing, someone talking about Opera and the post is still alive. Cheers.

Re: 1.6 CPU requirements?
Posted by: JohnHell
Date: September 25, 2013 06:55AM

This forum is quite open to topics, even about other browsers.

Of course we prefer K-meleon, but close a thread because of talking of another browser... I can't recall such situation.

Aside this and going on topic again, I'm still in this PC configuration and now I'm switching from Opera to K-meleon 1.5.4 because, sadly, Opera with some websites (I don't know what they have) tend to BSOD (graphic driver, I guess, I don't know) the system :/

Oh, JamesD, I think you built 1.6b2.6 (at least you changed icons) can I ask/request you to build it with MMX support or check if it is enabled in the compiler? If you didn't built it, and only changed some icons with utilities as Resource Hacker, forget this, but I remembered that and other fixes you did and maybe you compiled the exe ;)

It's just a request to try to run it on this system if the instruction set is not correctly in the exe.

Thanks if you can do ;)

Re: 1.6 CPU requirements?
Posted by: JamesD
Date: September 25, 2013 07:47PM

@ JohnHell

I did not compile the executable in 2.6 beta. I just put together pieces, the latest I could find, and built a package. I think the file is from Dorian. I am not familiar with the term MMX.

What icon might be changed? I added some bmp files for buttons, but they are all in ...skins\default. I am using 2.6 on Win 7 and XP and everything seems to work for me.

Re: 1.6 CPU requirements?
Posted by: JohnHell
Date: September 25, 2013 10:56PM

Ok.

The most visible changed icon was the one for the security, the lock icon in the bottom right corner.

I thought you changed it by re-compiling the exe ;) If not, my mistake.

This is the change I noticed (among others) from beta2.4 to beta2.6 and are icons inside the exe that is why I thought of a re-compile:


As I said, if you didn't do anything, my mistake smiling smiley I asked just to try ;)

No problem smiling smiley

P.S.: MMX are instructions set added to x86 architecture for better performance. For example, MMX was added in Pentium 1, in Pentium II/III was added SSE, in Pentium 4 SSE2 and so on, if I'm not wrong (more info at the Wikipedia ;) ).

Re: 1.6 CPU requirements?
Posted by: JamesD
Date: September 26, 2013 08:33AM

Beta 2.4 had some stuff compiled separately. I think the privacy.dll was one such piece. I don't know where the icon for the lock is found. It is in some executable for sure.

I don't think this answers your question, but might supply some insight.
http://kmeleon.sourceforge.net/forum/read.php?3,110663,110756#msg-110756

The executable and DLLs used in Beta 2.6 were compiled by Dorian in mid 2012. I am afraid that I have no idea about what switches were or were not set for that compile. When I requested of Dorian that a new compile be done from the latest code, I did not specify any specific support.

Re: 1.6 CPU requirements?
Posted by: JohnHell unlogged
Date: September 26, 2013 09:32AM

All icons I'm talking (and I'm not) are inside the exe, not in external dlls.

That is what made me suspect of a re-compile or whatever.

It's strange because icons don't appear/change magically tongue sticking out smiley

But don't worry, as I said, it was just to give a try. Maybe there were faulty instructions in compiling or maybe Dorian made mandatory SSE o higher instructions because K-meleon/gecko needed them.

Until 1 or 2 weeks I won't be in my main P4 pc and browsing in a limited way (used to 1.6b2.6 as I was...) it's driving me crazy xD

Thanks anyway James smiling smiley

Re: 1.6 CPU requirements?
Posted by: duffy98
Date: September 26, 2013 03:47PM

JamesD ... I was going to mention about using the security lock icons from K-Meleon 1.5.4 since I prefer an "open lock" that looks unlocked. I got help from disrupted back in 2010 trying to figure out how to move the security icons from one KM version to another. I didn't mention anything about it since I can now make the change myself with the help I got from disrupted. It's no big deal and I may be the only one that likes the older icons from KM 1.5.4. I actually think the only icon that is different is the "opened - unlocked" icon. Here are the instructions I got from disrupted. The newer unlocked icon just doesn't look open enough for me at a quick glance when I'm checking "security". I think I got the "older" icons from KM 1.5.4 ... once I extracted them I just save them in a folder for future use with the instructions from disrupted. The icons are numbered: icon 7, icon 8, icon 9 with icon 8 being the "opened lock" icon. I did this back in 2010 so I am not sure about those icon numbers but that is what I have saved in the folder ... disrupted mentions "expand the folder called "Icon Group". Communication icons numbers are 183 (secure), 184 (nonsecure) and 185 (broken)". It took me a little time to figure it all out and actually get the icons into a folder since I had never worked with resource hacker before.

KM Icon Change (disrupted)

Posted by: disrupted
Date: September 24, 2010

It's not complicated, the icons are compiled inside the kmeleon.exe itself and first you'll need to extract them from KM 1.5.x exe.

Open 1.5 kmeleon.exe in Resource Hacker, expand the folder called "Icon Group". Communication icons numbers are 183 (secure), 184 (nonsecure) and 185 (broken).

Select the icon you want to extract and right click and select "Save Icon Group"

You can also find all 3 icons in the kmeleon cvs inside the 'res' folder:

http://sourceforge.net/projects/kmeleon/files/k-meleon-src/1.5.0/K-MeleonBE1.5.7z/download

After saving the 3 icons, open 1.6 kmeleon.exe in Resource Hacker and expand the Icon Group, same icons have the same id numbers ... select the icon you want to replace and right click and select "Replace Resource", browse to the replacement icon you have extracted from KM 1.5.4 and open it ... click Replace in the editor dialog and when you have finished replacing all needed icons ... click on File > Save.
...

You don't have to change any icons for me unless you like them better ... it only takes me a minute or two to fix the icons to my liking.



Edited 6 time(s). Last edit at 09/26/2013 04:06PM by duffy98.

K-Meleon forum is powered by Phorum.