K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 18, 2013 08:20AM

I have K-Meleon1.6.0_Beta2dot5_en-US exactly as I want it except it keeps crashing. It will work fine for a while and all of a sudden it will start crashing. I keep submitting the automatic crash report that always pops up but I guess there's still no one home. After closing K-Meleon1.6.0_Beta2dot5_en-US then I reopen it and it asks me if I want to reload the previous session. If I select "Yes" it will immediately continue crashing. If I select "No" KM works fine, except that I have lost the session I was working with. When I manually reopen the same pages some times KM crashes and some times it doesn't. Also, restarting the machine will clear up the problem for awhile. Sometimes I can go a week with out KM crashing. Sometimes it will happen at least several times a day. I clean out the cookie, temp and memory/disk cache files often but the problem continues to persist. When I'm about to loose my patience I go back to using IE 10 but lets face it, IE will ALMOST never replace my favorite browser. I'll bet if MS had any intention of replacing KM they would have done it years ago.

I am using a 64 bit machine with 6 GB of mem and the 64 bit version of Windows 8 with Classic Shell installed.

Thank you,

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: JamesD
Date: June 18, 2013 07:30PM

@ Charlie

I think the problem is with sessions. I am not a programmer, so I can't fix that. Do you use sessions? If so, could you replace your use of sessions with Groups?

It is possible to test if sessions is your problem. To test, first close KM and then look in the KM root\kplugins folder. Move the sessions.dll file to some place not in KM. Restart KM. Run for a while and see if you get any problems.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 18, 2013 09:49PM

Thank you, JamesD. I will give that a try.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: rodocop
Date: June 18, 2013 10:34PM

Sometimes my KM catches alike problems.
As a rule, this being connected with the content of particular page (and tab). So I simply close KM, then open prefs.js with text editor and remove line with the info about this tab

user_pref("kmeleon.plugins.sessions2.Previous Session.window0.count", 20);
Here you have to decrease number by 1, when editing - this tells KM to open 'n-1' tabs.
user_pref("kmeleon.plugins.sessions2.Previous Session.window0.tab11", "6	5	http://www.someaddress...";);
line to delete - that one, which lists the potentially problematic page (generally, this is last opened tab before problem begins)

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!



Edited 2 time(s). Last edit at 06/18/2013 10:35PM by rodocop.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 21, 2013 04:33AM

Quote
JamesD
@ Charlie

I think the problem is with sessions. I am not a programmer, so I can't fix that. Do you use sessions? If so, could you replace your use of sessions with Groups?

It is possible to test if sessions is your problem. To test, first close KM and then look in the KM root\kplugins folder. Move the sessions.dll file to some place not in KM. Restart KM. Run for a while and see if you get any problems.

James, I don't quite understand how to use Groups. I've looked up Groups several places on the Internet, it sounds like it is about the same as Sessions. But I don't know how to add it to KM.

I tried removing sessions.dll but it made KM intolerably slow, it would take 30-40 seconds to load pages, even when RE-loading pages.

I tried disabling Sessions in Preferences\KM Plugins But that did not stop the crashing problem.

All day today, KM has been crashing immediately upon opening a window. In KM.exe\Properties, I set KM to use Compatibility Mode for Windows XP SP3 but that too did not fix the crashing problem. I then set it to use Windows XP SP2 Compatibility Mode. Strangely, the Compatibility Troubleshooter indicated that it is still set to Windows XP SP3 mode but I have been using KM for about and hour, opening multiple windows and tabs and so far km has not crashed.surprised smileysmiling smileyconfused smiley

@ rodocop, I think I have just figured out how to do what you suggested so I haven't tried it yet but hopefully the compatibility thing above will keep working out, keeping my fingers crossed.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 1 time(s). Last edit at 06/21/2013 05:02AM by caktus.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: JamesD
Date: June 21, 2013 06:07AM

@ caktus

I cannot understand why not having sessions would make your system slow. I see no change in speed on my system.

Groups is similar to sessions except that it does not save the history for the group and only does one window at a time. Groups allows you to save as a group name, all the tabs currently open in the current window. When loading a group all those tabs are re-opened in addition to the current tabs.

Look on this page: http://kmext.sourceforge.net/ext4.htm and select "Bookmarking & Archiving" and scroll down to Groups2-0.67.

If disabling sessions did not stop the crashing problem then there is not any reason to do without sessions.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 22, 2013 01:46AM

Again, I just now removed the sessions.dll. Then I went to https://www.wellsfargo.com/. https://www.wellsfargo.com/ took 50 seconds to load. Actually, nothing loaded until 50 seconds, then the entire page loaded at once and the page loaded html only. Reloading the page took 30 seconds although the page was already loaded, the only difference was the image encompassing the Login area had rendered. I reloaded and Force reloaded the page several times with the same result.

http://capitaldaily.com/ also opened as html only. It opened and reloaded in about 8 seconds, it usually opens in 2 seconds. After loading this page, km crashed.

I tried loading numbersusa.com, the complete page loaded in 8 seconds, it usually loads in 2 seconds. When the page was completely loaded the old familiar crash occurred. I again loaded this page several times with the same results.

http://sourceforge.net/ loads and reloads in 8-24 seconds and the only images that would load are the "Download" buttons. When I copy the URL's of the place holders of the missing images, I can paste them into the URL bar, press Enter and the images load properly.

http://kmeleon.sourceforge.net seems to be the only site/pages that fully load in 2 seconds every time.

My Homepage, http://webmail.intergate.com/imp/login.php?Horde=de04e4d9c33af99303ea7c80459e2606 always opens immediately upon opening a KM window.

Another problem that occurs after removing the sessions.dll file is regardless what item I click on in the URL bar dropdown list, the only page that loads is the page that is currently loaded.

The same problems occur when I move the sessions.dll back to the kplugins folder and disable Sessions in Preferences, except loading time varies from 3-34 seconds.

For some reason, when Sessions is disabled or sessions.dll is removed, KM goes hog-wild spastic. Perhaps my particular machine is the culprit, for some reason.

I just checked the Compatibility Mode for k-meleon.exe and still it is set to Windows XP SP2 while the Compatibility Mode Troubleshooter indicated Compatibility Mode XP SP3. In this Compatibility mode, still, so far so good.

If I start having problems again I will try using Groups.

EDIT: Well, km just crashed again while trying to load some page about should-the-fbi-be-allowed-to-wiretap-your facebook-account.html, or something like that. Facebook is blocked in my Hosts file. I wonder if that may have something to do with this.

I was able to completely reload the session (3 windows with multiple tabs) in less than a second. However, some of the links that were highlighted indicating that I had previously visited them were no longer highlighted so I wonder if history may also have something to do with this.

I am also wondering if the crashing problem may have something to do with Windows 8 or the fact that is the 64 bit edition.

In any case, since reloading this time was barely and inconvenience this even that, I'll keep this km the way it is just to keep seeing how it goes.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 2 time(s). Last edit at 06/22/2013 02:42AM by caktus.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 23, 2013 12:21AM

With and without both Sessions or Groups KM keeps crashing. KM is now crashing so often that I cannot use it at all. I'm going to try starting K-Meleon1.6.0_Beta2dot5_en-US again from scratch.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: rodocop
Date: June 23, 2013 01:47AM

You definitely have big problems with KM installation. There cannot be many prefs.js or somethink like this.

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 23, 2013 05:27AM

I have been working with a fresh download and installation of K-Meleon1.6.0_Beta2dot5_en-US with default settings. Just as with previous installations of KM 1.6.0 Beta 2.5 and the official 1.6B, regardless of settings, some .HTM/L associations to KM, some shortcuts refuse to accept the KM icon.

So far, KM has not crashed. I will customize slowly to see if I can identify what is causing KM to crash. I have a feeling that KM 1.6.0_Beta2dot5_en-US and other KM's simply refuse to be compatible with Windows 8.mad smiley

I am trying to make myself compatible with Windows 8, somehow. But I have a feeling I will eventually downgrade, preferably to another 64 bit compatible OS. I like this 64 bit machine and being able to have lots of RAM.smiling smiley

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: rodocop
Date: June 23, 2013 05:48AM

The answer is not win8 but 64bit IMHO.

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 23, 2013 07:27AM

Quote
rodocop
The answer is not win8 but 64bit IMHO.

I understand that 32 bit/x86 programs are supposed to work on Windows 8 64 bit but more and more I'm learning different in most cases. This new install of KM has already crashed a couple of times but I'm still playing with it. I would find it a shame to have to drop KM.sad smiley

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: JamesD
Date: June 23, 2013 08:31AM

Windows 8 is very finicky about K-Meleon. You might try this:
Control Panel\All Control Panel Items\Default Programs

Microsoft never makes it easy for a set default program. They always tweak something with every release.

You are "supposed" to be able to set the default and also file associations from the link above.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 24, 2013 04:16AM

Quote
JamesD
Windows 8 is very finicky about K-Meleon. You might try this:
Control Panel\All Control Panel Items\Default Programs

Microsoft never makes it easy for a set default program. They always tweak something with every release.

You are "supposed" to be able to set the default and also file associations from the link above.

Tried that last night but it didn't change the Internet shortcut icons and still I got an occasional crash. But as usual, KM did have default status.

This morning, I removed KM and reinstalled it in the Programs (x86) folder, which was a bit tricky, I had to first move the setup file to the Programs (x86) with admin rights. As before, changing Default status in the way you mentioned made KM the default browser but did not change the shortcut icons, just using the KM's SetDefault tool probably would have accomplished this.

I changed default status again (as above), but little differently. This time instead of selecting the KM icon from the first selection window that opened, I selected "more options" then "Look for another app on this computer" and navigated to the Programs (x86)\ K-Meleon1.6.0_Beta2dot5_en-US folder and clicked on the KM's SetDefault tool. This finally changed the shortcut icons. Probably selecting the k-meleon.exe would also have set the correct icons.

Been using this install about an hour and so far, no crashes. Keeping my fingers X'd.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: rodocop
Date: June 24, 2013 06:45AM

caktus,
why not to:

1) install any portable build (I suppose Twin as it is already tweaked to self-contain setdefault routine - thanks to adodupan!)

2) press 'Set as Default Browser' in Preferences

3) use Browser TraySwitch to save this state under Windows (you can save settings for as many browsers as you want - and select the needed default one on the fly)

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 24, 2013 11:25AM

Quote
rodocop
caktus,
why not to:

1) install any portable build (I suppose Twin as it is already tweaked to self-contain setdefault routine - thanks to adodupan!)

2) press 'Set as Default Browser' in Preferences

3) use Browser TraySwitch to save this state under Windows (you can save settings for as many browsers as you want - and select the needed default one on the fly)

Do you mean I could have several versions of KM installed and just choose which version I want to use without getting Profiles mixed up? Sounds cool, I keep this in mind.

The reason I'm using 1.6.0_Beta2dot5 is because I was having too much trouble with the official 1.6.0 for some reason. I think I was having too much trouble with 1.7 and the Chrome Frame, also. Right now, I think I'll stick with just 1.6.0_Beta2dot5 as I believe I may finally be making progress getting it work on this Windows 8 64-bit.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: rodocop
Date: June 25, 2013 03:20AM

Charlie,
you always can use several instances of KM installed (portable) in parallel.

Just use parameter '-new' in shortcut of every KM.

And if speaking about several DEFAULT KM's - I don't ever mind what this could be needed for, but yes, you can.

I use Browser TraySwitch to have different browsers as defaults when I need this.

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: June 25, 2013 05:39AM

Quote
rodocop
Charlie,
you always can use several instances of KM installed (portable) in parallel.

Just use parameter '-new' in shortcut of every KM.

And if speaking about several DEFAULT KM's - I don't ever mind what this could be needed for, but yes, you can.

I use Browser TraySwitch to have different browsers as defaults when I need this.

Thank you, robocop. I think I'll play around with that a bit.

BTW, KM 1.5.4 seems to be working out pretty good. So far the only crashes of concern only happen when I click on Spell Checker, I'm trying to find a different spell checker I can use with 1.5.4. The only other (2) crashes seem to be related to illegally using the back button on a secure site, sometimes it works, sometimes it doesn't. I'm guessing Windows 8 64-bit, the 64-bit machine or both just don't like KM 1.6 and all I can say to that is tongue sticking out smiley!grinning smiley

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: rodocop
Date: June 25, 2013 05:44AM

All I can say is that KM Twin works without glitches on the Win7 64bit.

And also beta 2.5 by JamesD.

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!



Edited 1 time(s). Last edit at 06/25/2013 05:45AM by rodocop.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: July 31, 2013 01:10AM

Been using 1.6.0_Beta2dot6 for few days now with no problems but a few curiosities. Under the browsers Help menu there are 2 links to K-Meleon Home, 2 links to K-Meleon Forums, 2 links to K-Meleon Plugins and 2 links to About K-Meleon. Does anyone have any idea how I may have caused this and I can fix it?

I will give KM Twin another try. Perhaps it too will play nice with Windows 8.

Thank you.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: JamesD
Date: July 31, 2013 03:56AM

@ caktus

I don't know why. There are no duplicates in KM help menu on my system. The code that makes the items you noted begins with the following part of menu.cfg file.

KMAbout, KMDocs, KMForums, and KMHome are all menus. They are all contained in the menu "&Help" which is then part of the menu "Main".

Each menu can be run with or without using the plugin named macros. This is supposed to be an either/or situation.

# ----- Help

KMAbout{
%ifplugin macros
About &Plugins=macros(hm_Aplugins)
About &K-Meleon=macros(hm_Akm)
%else
About &Plugins=ID_LINK_ABOUT_PLUGINS
About &K-Meleon=ID_APP_ABOUT
%endif
}
KMDocs{
%ifplugin macros
&User's Guide=macros(hm_UserGuide)
&FAQ=macros(hm_FAQ)
%else
&User's Guide=ID_LINK_KMELEON_MANUAL
&FAQ=ID_LINK_KMELEON_FAQ
%endif
}
KMForums{
%ifplugin macros
K-Meleon &Forums=macros(hm_KMforum)
%else
K-Meleon &Forums=ID_LINK_KMELEON_FORUM
%endif
}
KMHome{
%ifplugin macros
K-Meleon &Home=macros(hm_KMhome)
%else
K-Meleon &Home=ID_LINK_KMELEON_HOME
%endif
}

&Help{
!KMHome
!KMForums
!KMDocs
!KMAbout
}

# ----- Main

Main{
:&File
:&Edit
:&View
%ifplugin bookmarks
:&Bookmarks
%endif
%ifplugin favorites
:F&avorites
%endif
%ifplugin hotlist
:H&otlist
%endif
%ifplugin sessions
:&Sessions
%endif
:&Tools
:&Help
bmpmenu(top)
}



Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: August 03, 2013 03:17AM

Quote
JamesD
@ caktus

I don't know why....

It seems to match what is in my menus.cfg. At this point I guess I may as well just leave it be since the duplicates don't seem to be causing any problems.

Thanks.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: JamesD
Date: August 03, 2013 07:30AM

Charlie

We can try and find out where the duplicated are originating. I suggest that you make a small change in menus.cfg file and see what happens when you run KM with the changed file.

&Help{
!KMHome
#!KMForums
!KMDocs
!KMAbout
}

If you change the !KMForums line to start with a # symbol, it becomes a comment. Do that, restart KM and see if one or both of the forums duplicate entries are removed.



Edited 1 time(s). Last edit at 08/03/2013 07:30AM by JamesD.

Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: caktus
Date: August 06, 2013 04:37AM

Quote
JamesD
Charlie
Quote

We can try....
&Help{
!KMHome
#!KMForums
!KMDocs
!KMAbout
}
....

James, the above method removed both of the Home links from the Help menu.

However, when I changed

KMHome{
%ifplugin macros
K-Meleon &Home=macros(hm_KMhome)
%else
K-Meleon &Home=ID_LINK_KMELEON_HOME
%endif
}

to

KMHome{
%ifplugin macros
#K-Meleon &Home=macros(hm_KMhome)
%else
K-Meleon &Home=ID_LINK_KMELEON_HOME
%endif
}

the extra KM Home link was removed from the Help menu leaving one working KM Home link.smiling smiley Will removing the extra links in this manner cause any problems?

BTW, I forgot to mention, one Home link had the (KM) icon and the extra Home link did not have the icon. The Home link that was removed was the link w/o the icon.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon1.6.0_Beta2dot5_en-US keeps crashing
Posted by: JamesD
Date: August 06, 2013 06:17AM

Charlie,

If it fixes your problem, then it should not cause another problem. It just means only one of two possible methods will be used. The if/else should have made only one method active. I do not know why it did perform correctly on your system.

I am not sure how many other places the if/else code occurs in KM.

K-Meleon forum is powered by Phorum.