General :  K-Meleon Forum
General discussion about K-Meleon. 
Single click not working
Posted by: caktus
Date: May 29, 2013 08:32PM

In the Folder Options I have set items to open with single click instead of double click but sometimes K-Meleon1.6.0_Beta2dot5_en-US requires a double click to open, this problem does not occur with other programs. In this Windows 8 I am using "open as" does not have a "Browse" option. This usually occurs After restarting or booting the computer or when K-Meleon1.6.0_Beta2dot5_en-US has not been open for a while. I don't recall when this started happening (few months I guess), I have just been putting up with it. I have re-set the Folder Options several times, Right click/Open With/Choose Default Program.../KM.exe many times and checked to see if any new mouse drivers are available even thought it is just an HID/PNP device. I have reset KM as the default browser many times and the Loader.exe is running. Even System Restore does not fix the problem.

Another problem I am having is all Internet shortcut icons have .txt icons. I have tried emptying temp files and iconcache and the Preferences/caches. This Windows 8 does not seem to have the Folder Options with the type of view tab where I can choose what icons open what types of file that I was accustom to in Windows XP. System Restore is no help.

I am using Windows 8 on a 64bit machine with Classic Shell Version 3.6.7 – general release


Thank you.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: Single click not working
Posted by: JamesD
Date: May 30, 2013 02:32AM

@ Charlie

I don't have Win 8 or the classic shell, so I cannot duplicate your situation. I noticed that you are using the loader.exe program, and I wondered why do you need it? Win 8 is very modern ops sys and I would not expect to need loader. How much RAM do you have?

You also mentioned folder options. On what are you clicking to start KM? Are you clicking on the k-meleon.exe file or a shortcut?

The setdefault.exe file in beta 2.5 is old and I cannot say if it up do doing the job in Win 8. I suggest doing a search for setdefault on the forum to see if there is a more modern version.

Edit: http://kmeleon.sourceforge.net/forum/read.php?4,121695,121719#msg-121719
You might try the newest setdefault from this site.



Edited 2 time(s). Last edit at 05/30/2013 08:16AM by JamesD.

Options: ReplyQuote
Re: Single click not working
Posted by: caktus
Date: June 01, 2013 12:17AM

Thank you, JamesD, for responding. The machine has 6GB of RAM. I like that this 64bit OS can recognize a lot of RAM. I even like that I have been able to install some bits and pieces of OOOOLD programs like Word/Works/Home Pub. 2000 but still I think I may end up going back to an earlier version of Windows.

I have removed the Loader.exe and so far KM opens on one click. After restarting or booting the machine KM takes about one second to open (I guess because it is not in memory) and on subsequent attempts it opens immediately.

To open KM I and clicking on Internet shortcuts, KM.exe and sometimes Favorites shortcuts.

I just recently noticed that Favorites shortcuts are opening in a new Tab rather than a New Window even though Favorites are set to open in a New Window as is set in Preferences\K-Meleon Plugins\IE Favorites\General Tab. Do you have any idea how I might fix that?

Thank you for the link to the latest SetDefault.exe, that fixed the KM shortcut icons immediately after resetting the default program like should have happened in the first place.smiling smiley

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: Single click not working
Posted by: JamesD
Date: June 01, 2013 06:29AM

I have to guess at this, but when you open a shortcut perhaps the diversion is for "typed URLs". I would check and see in what place typed URLs are set to open.

Options: ReplyQuote
Re: Single click not working
Posted by: caktus
Date: June 03, 2013 03:26AM

Quote
JamesD
I have to guess at this, but when you open a shortcut perhaps the diversion is for "typed URLs". I would check and see in what place typed URLs are set to open.

I have Typed URL's set to open in an New Window which has been working fine, and since removing the Loader.exe KM windows are now constantly opening with one click.smiling smiley

Now, only a few older programs are still requiring double-click but I that's just caused by the generation gap between Windows 8 and earlier apps, I guess that's just what I get for trying to live on both the front and back of "cutting-edge technology."grinning smiley

Another problem I am having with K-Meleon1.6.0_Beta2dot5_en-US is Favorites always opening in a new Tab while Favorite's are set to open in a New Window. I have tried toggling the setting but Favorites will only open in a New Tab. Can you help me fix this so Favorites only open in a New Window.

Thank you.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: Single click not working
Posted by: deadlock
Date: June 03, 2013 08:56AM

@caktus
>but Favorites will only open in a New Tab

You can open about:config and try to filter these values:
- kmeleon.plugins.favorites.openurl
- forceTab (3 or 4 entries overwriting the above)

You can use kmeleon.notab if you can't find the wrong setting.
I've also tested using white Windows version but a different KM.

Options: ReplyQuote
Re: Single click not working
Posted by: caktus
Date: June 04, 2013 12:56AM

Quote
deadlock
@caktus
>but Favorites will only open in a New Tab

You can open about:config and try to filter these values:
- kmeleon.plugins.favorites.openurl
- forceTab (3 or 4 entries overwriting the above)

You can kmeleon.notab if you can't find the wrong setting.
I've also tested using white Windows version but a different KM.

Thank you, deadlock. I found kmeleon.plugins.favorites.openurl in about:config, the Status is "user set" the Type is "String" and it's Value is set to "ID_OPEN_LINK_IN_NEW_WINDOW"

I don't understand what you mean by "- forceTab (3 or 4 entries overwriting the above)" I don't quite understand how to use kmeleon.notab, nothing I see in it seems to relate to the problem.confused smiley

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: Single click not working
Posted by: deadlock
Date: June 04, 2013 01:47AM

@caktus
If you didn't find any forceTab entries in about:config
then it is not related to your problem and we'll have to
search in your profile's prefs.js to find the reason.
Does it happen in a new profile?

Just for for fun:
Try to add this setting to defaults\pref\kmeleon.js
pref("kmeleon.notab", true);

Options: ReplyQuote
Re: Single click not working
Posted by: caktus
Date: June 04, 2013 03:20AM

My bad! In about:config I just now typed in the filter bar "forcetab" and among some other items it called up "kmeleon.plugins.macros.docinfo.forceTab.links;true" I toggeled It's Value to "false" and now Favorites are opening in a "New Window" like I want. I wonder how I managed to goof that up!

The first time I typed in Fav and one of the items called up was kmeleon.plugins.favorites.openurl;ID_OPEN_LINK_IN_NEW_WINDOW and thought everything in about:config was fine.

incidentally; RE:

Quote
deadlock
@caktus
If you didn't find any forceTab entries in about:config
then it is not related to your problem and we'll have to
search in your profile's prefs.js to find the reason.
Does it happen in a new profile?

Created the new Profile and set Favorites to open in a New Window and it works as it should. Other than enabling the Favorites macro and setting Favorites to Open In A New Window, I have made no other changes to the New Profile.


Quote
deadlock
Just for for fun:
Try to add this setting to defaults\pref\kmeleon.js
pref("kmeleon.notab", true);

I tried this but no apparent change

EDIT:
For curiosity, I just went back to about:config and pulled up pref("kmeleon.notab" and it is now set to "faulse" I wonder if this will be a problem.

Thank you, Guy's, for helping me fix this.smiling smiley

Charlie

~~If it ain't broke, why screw it up?~~




Edited 1 time(s). Last edit at 06/04/2013 03:23AM by caktus.

Options: ReplyQuote
Re: Single click not working
Posted by: JamesD
Date: June 06, 2013 02:33AM

The correct way to change where ie favorites open is to use EDIT - PREFERENCES - K-MELEON PLUGINS - IE FAVORITES and make a selection from the choices presented.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.