Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: November 15, 2012 05:14PM

That items in majority are inherited from db+ builds.

I don't use any of them except my own Twin-Setup and Twin-Tune. As I can see KM cannot be more responsive and slick than using Twin-Tune. But some values can be tuned according to you PC's specs and connection speed.

But I've found optimal (for me) values and use them on every my PC without changing. My experience lets me recommend these settings as universal for any PC not older than 7-8 years and any broadband connection (DSL, ISDN, Ethernet, 3G etc.)

Perhaps, one can make KM even faster but I don't care :-) I have enough speed.

P.S. Small comparison for all who consider KM as 'oldware'-oriented browser.
Testing rendering speed of Softpedia catalog pages on Win 7-64bit and modern AMD CPU (comparable with Core i3 Pentium) shows at least 2x faster page display than by pure fresh Google Chrome.

Lightning speed - and this is that case when the difference really does matter!



Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 2 time(s). Last edit at 11/15/2012 05:16PM by rodocop.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: November 15, 2012 09:03PM

Hi, Kandra!
I'm using Foxit reader for PFDs too and I've given a try to your link - all went without any problem.

So all I can is repeat: find the reason in your PC config.

About gmail and UserAgent.
Modern smart sites not only check user agent but compare it with real rendering engine. So you cannot spoof them browsing with KM and setting Chromeor Opera as UA-string. You need Gecko-based UserAgent.

My default User Agent
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28
is enough for Gmail compatibility.

I can say more: sometimes web pages do not allow you to use UA from newest FireFoxes (4.0 and newer) as the real underlying Gecko is old. And the choice of compatible UA-string is reduced to the Twin default one.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 6 time(s). Last edit at 11/15/2012 09:21PM by rodocop.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: kandra
Date: November 16, 2012 12:06AM

HiRodo,when i use Firefox15 as my user agent only,gmail modern features are working with 3.6.28 it is not working ,so i am using Firefox15 as UA.My system windows7.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: November 16, 2012 01:45AM

OK, use it!

My note refers to general use, not to Gmail in particular.

Also, there is useful Auto Agentswitch extension which applies Firefox useragent every time you visit listed domains. You can edit the list adding more domains.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: george27
Date: November 16, 2012 10:33PM

Where are the download links? The two are not working.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: November 16, 2012 11:12PM

Link #1 fixed
Link #2 still working (http://kmeleon.bugs3.com/K-Meleon Twin+.7z)


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 4 time(s). Last edit at 11/16/2012 11:55PM by rodocop.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: duffy98
Date: November 17, 2012 02:59AM

Perhaps this little test site will be of some help to a few people. I have changed my User Agent to Firefox 15 and I get all green checkmarks ... with Firefox 3.6.28 it says browser is old, outdated ... doesn't pass but it reads Firefox 15 as OK.

You must have Javascript off and if you use Proxomitron, "Bypass" must be checked so the test will actually work. Sometimes I also get one or two popup windows from ZoneAlarm before I hit the test button and I don't let anything connect to the internet. It doesn't seem to be necessary to do so. You should see the test results.

Browser - Flash - Shockwave Test Page:

http://www.explorelearning.com/index.cfm?method=cCorp.dspTest

... something interesting ... with KM v1.6.0.2 and with Firefox 3.5, the browser get an OK green check mark but in KM Twin with Firefox v3.6.28 (later version ?) I get a fail, browser old message. I'm using the 1.6.0 version I got from JamesD a few months ago.

In KM v1.5.4 the older User Agent Firefox 3.5 also is accepted as OK with the test, just not FF v3.6.28. I am not a Firefox user so I have limited knowledge of the different versions ... could the UA string for FF v3.6.28 be incorrect in some way and need to be changed, just a thought.

...



Edited 5 time(s). Last edit at 11/17/2012 09:14PM by duffy98.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: November 19, 2012 10:49PM


Thank you, JamesD.

Systems been down for a few days. I am starting with a new default install of twin+. I will install the macros you and others have posted and report back.

Charlie

~~If it ain't broke, why screw it up?~~


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: November 29, 2012 12:04AM

At times twin+ works great even though I have dialup with a 56k modem which connects at about 26k these days, loading web pages at least twice as fast as 1.5.4. However, when I attempt to load more than about 8 tabs, twin+ crashes.

Also, when I attempt to access web pages after starting/restarting the computer, twin+ is in Work-Offline mode even though there is no check-mark beside File > Work-Offline and I have to toggle the Work-Offline mode twice before I can load web pages. This problem also occurs [sometimes] when reopening twin+ for a new session.

Could someone please help me fix these problems.

Thank you.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 1 time(s). Last edit at 11/29/2012 02:00AM by caktus.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: JamesD
Date: November 29, 2012 02:54AM

Well, I don't know what to say. I have just had Twin+ open with eleven and fourteen tabs twice each. I did not have a failure. I also don't think I was ever in offline mode. I am not sure of that because I did not always empty cache. How does one tell if he is actually offline?

The only problem was the site icons. Sometimes they were there and other times only a placeholder appeared. That is why I don't turn those on in my default KM.

Caktus, are you letting a tab load before loading another? Could that lead to a resource problem - i.e. memory? I was using groups and loading in pairs some of the time, but I have all the memory that 32 bit Windows can address.

Sorry that I cannot produce same error. I have no certain answer for you.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: November 29, 2012 03:21AM

Quote
JamesD
Caktus, are you letting a tab load before loading another? Could that lead to a resource problem - i.e. memory? I was using groups and loading in pairs some of the time, but I have all the memory that 32 bit Windows can address.

Sorry that I cannot produce same error. I have no certain answer for you.

Thank you for responding, JamesD.

Now that you mention it, a couple of times twin+ was eating about 85-90% of RAM and the only way out was to was to shut down the computer and do a cold start.

This problem only seems to occur when I click on news links in emails to save for reading later off-Line and yes, I probably click on some links faster than previous tabs can open. I never had this problem with previous versions of KM.

As for why twin+ often goes Off_line, I haven't a clue.confused smiley

Charlie

~~If it ain't broke, why screw it up?~~


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: adXok
Date: November 30, 2012 02:50AM

Hi, rodocop

Glad to see someone is developing my favorite web-browser. I do not understand programming so I cannot say what are the differences between Twin+ and standard release but anyway.

I just want to tell that it works. Off to the wish-list page.

P.S. What I miss in Twin+ is the Search Button. I have this button in my K-meleon 1.7a2 and it is a big time-saver!!!

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: November 30, 2012 02:31PM

Hi, adXok!
Thank you for feedback!

Search button is present in Twin+ - it's located next to NewTab button.
But maybe you mean Search Bar? Then you can easily install it from there
Just right-click the link and select 'KM extension' - it would install Search Bar and restart KM in order to new feature be working.


And sorry - I'm not developer, only 'builder'...


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: December 01, 2012 02:54AM

Thanks, everyone for your help. For some reason the entire system and applications became so unstable, apparently from trying to use 1.6 that the machine was totally of no use when connected to the Internet that I had to remove Twin+ and even then the files with extension htm, http etc. hat to me manually reassigned from Folder Options. If I recall correctly, I experienced much the same problem with an earlier version of 1.6. Since apparently no one else is experiencing these problems with 1.6. I guess, for some reason the problems lay with my particular system. In short, I had to drop back to 1.5.4. But thank you, every one for all your help.

Charlie

~~If it ain't broke, why screw it up?~~


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: December 01, 2012 01:02PM

What is your system config?
Are you working in 98 or Millenium?


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: December 02, 2012 01:32AM

Quote
rodocop
What is your system config?
Are you working in 98 or Millenium?

The system on which I use KM is a 7 year old low-end Emachines T3624 with OEM Windows XP Home SP 2 updated to SP 3 and 1MB of RAM with All critical updates and many optional updates.

Charlie

~~If it ain't broke, why screw it up?~~


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: December 02, 2012 02:22AM

caktus,
very unusual problem.

Try this in Windows (not in KM):
Start->Run ->input command:
netsh winsock reset
& run it.

Then restart your PC. Try to use Twin and tell us about results.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 12/02/2012 02:22AM by rodocop.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: JamesD
Date: December 02, 2012 02:24AM

Charlie,

That configuration is usually good for any version of KM. I am assuming that you meant 1 gig of RAM and not 1 MB of RAM. My laptop has XP pro updated to SP3, 1 gig of RAM and the bios is dated January of 2003 making it almost 10 years old.

Have you run software to check your machine for viruses and rootkits?

Rodocop,

Are there any runtime files that Charlie needs to check for correct version? I am assuming that if one was just missing KM would not even start?

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: December 02, 2012 03:10AM

JamesD,
it would start but cannot be 8 pages correct - and then crash.

These are symptoms of network config problems in OS.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: December 02, 2012 03:41AM

@ JamesD

Yes, I intended to type 1GB. My BIOS is a bit newer, Intel Corp. SR84510A.46T.0014.P06.0410050243 10/05/2004 but I understand that dates verses versions some times turn out kind of bass-ackwards.grinning smiley


@ Rodocop,

I have also experienced these same types of problems with all versions of FF that I have tried. Do you have any idea what kind of network config problems might be causing it?

Charlie

~~If it ain't broke, why screw it up?~~


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: Michael
Date: December 02, 2012 09:09AM

Hi,

First of all, thank you for all your efforts on Twin,

I'd like to try it out, but am a bit unsure how to set it up. Do I need to extract it to a specific place on my PC, or could I just extract it to my desktop?

How do I then transfer over my settings and add-ons from my older version (KM 5.4)?

Running Win XP Home SP3

My apologies if these are stupid questions. Thank you for your help.

Michael

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: December 02, 2012 02:23PM

Quote
caktus
@ Rodocop,
I have also experienced these same types of problems with all versions of FF that I have tried. Do you have any idea what kind of network config problems might be causing it?

What about surfing with other browsers? Is it unproblematic? Have you triedmy solution with netsh winsock reset?

What is your connection type - direct or proxied?

Sorry for so much of questions - but it's difficult to diagnose problems at remote.

Other option I can propose is to connect our PCs by Remote-access software (I have some) in order to me being able to look at your system. I understand that not every user would agree to let someone else inside his PC, but if you trust me, I guarantee not to harm your privacy and configuration - just look into trying to understand your problems and help (one of my 'professional hobbies' is computer troubleshooting). You decide.
If agree - just write a mail to me (address in profile) and I'll send you needed software or download it by yourself.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: December 02, 2012 02:40PM

Quote
Michael
Hi,

First of all, thank you for all your efforts on Twin,

I'd like to try it out, but am a bit unsure how to set it up. Do I need to extract it to a specific place on my PC, or could I just extract it to my desktop?

How do I then transfer over my settings and add-ons from my older version (KM 5.4)?

Running Win XP Home SP3

My apologies if these are stupid questions. Thank you for your help.

Michael

Hi, Michael!
Not so stupid questions!

First of all, before trying to update KM backup your existing installation and Profile somewhere!

Further, KM Twin is fully portable - just unpack it in some preferred place but not in your 1.5.4 folder.

• The best way to migrate to Twin with all your settings saved is - I think so - K-Meleon Syncronizer extension. Add it to your 1.5.4 installation and use for settings transfer.

I haven't tried this ever but I believe this is the tool you need.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 12/02/2012 02:41PM by rodocop.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: duffy98
Date: December 02, 2012 05:36PM

Michael ... rodocop explained it all very well, I'm going to add what I do ... for anyone really new to various versions of K-Meleon. I unpack a KM version and place it in the C / Programs folder. I then label that folder with the KM version ... at present, I have three versions of K-Meleon on my computer ... in the Programs folder labeled as such:

K-Meleon v1.5.4
K-Meleon v1.6.0.2.4 ... (from JamesD)
K-Meleon Twin ... (rodocop)

... then I create a shortcut from each folder to the Desktop (labeled the same as each folder) and then I have three versions of K-Meleon ready to use, since some versions work better on some web sites. I have added or updated a few newer User Agents, mainly IE8. Just an idea for having more than one K-Meleon version available to use. They will not conflict with each other.
...



Edited 2 time(s). Last edit at 12/02/2012 05:54PM by duffy98.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: December 03, 2012 10:47PM

Quote
rodocop
Quote
caktus
@ Rodocop,
I have also experienced these same types of problems with all versions of FF that I have tried. Do you have any idea what kind of network config problems might be causing it?

What about surfing with other browsers? Is it unproblematic? Have you triedmy solution with netsh winsock reset?

What is your connection type - direct or proxied?

Sorry for so much of questions - but it's difficult to diagnose problems at remote.

Other option I can propose is to connect our PCs by Remote-access software (I have some) in order to me being able to look at your system. I understand that not every user would agree to let someone else inside his PC, but if you trust me, I guarantee not to harm your privacy and configuration - just look into trying to understand your problems and help (one of my 'professional hobbies' is computer troubleshooting). You decide.
If agree - just write a mail to me (address in profile) and I'll send you needed software or download it by yourself.

I use a discount dialup connection with no proxy. I have a v92 56k modem. For years I had been getting a 44kbs connection but lately I have been getting a 24-26kbs connection. The phone line seems fine; I am thinking the telecom switching station may now further away or perhaps phone traffic in my area has increased as the area has been building up. I live in the sticks but progress and development seem to know no bounds.sad smiley I usually visit web sites that have very few "bells and whistles" and I take great advantage of Adblock+ so using km 1.5.4 is very good for surfing and the low connection speed seems to mostly effect program/malware definitions downloads. BTW, one of the things I particularly liked about 1.6 is the AB+ filters kill images, etc. on the fly.drool smiley

Surfing other web sites seems good with km 1.5.4. I also use IE 8, which works real good, for IE that is. IE 8 is usually slow loading the first page of a web site but successive pages usually load rather quickly. I have Opera 12.02, as a backup witch is veeeery sloooow.

I will look into netsh winsock reset. Ports 137, 138 and 139 are disabled, do you think that may be a problem?

I have java 1.4.2. I just downloaded and am getting ready to install 7.0.90.5, I am wondering if that will make much difference.

Charlie

~~If it ain't broke, why screw it up?~~


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: December 03, 2012 11:41PM

The only sense to update Java is about security issues - modern malware (drive-by downloads) frequently use holes in old plugins like Flash, Acrobat or Java to get into your PC.

So update it - this is good step forward. But I cannot say is this related with your problems.

Maybe they are in the field of dialup networking - I don't know. That's why I ask about browsing in other navigators. Its interesting how they handle 8 and more tabs.

One more direction to dig into is network performance settings of KM.
Have you tried to switch on Twin-Tune settings from Twin's Tools menu.

If not - try this. It optimizes some network connection settings in order to help KM browse faster.

Another way: install Fasterfox extension and try to choose preset closest to your system and connection config.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: December 04, 2012 12:03AM

@ rodocop

I had twin-tune selected. I will reinstall twin+ and try with Fasterfox.

EDIT
I seem to recall km having a tool of some kind to permit multiple versions of km on the same computer but I can't seem to find it. Do you know where I can fine it?

Charlie

~~If it ain't broke, why screw it up?~~




Edited 1 time(s). Last edit at 12/04/2012 12:31AM by caktus.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: rodocop
Date: December 04, 2012 03:06AM

no tool needed.
Just place different builds in their own folders and create shortcuts with parameter -new


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: caktus
Date: December 04, 2012 09:00PM

Quote
rodocop
no tool needed.
Just place different builds in their own folders and create shortcuts with parameter -new

Thank you, robocop. I did that and re-registered the netsh winsock reset as well. I'll play it from here and see how it goes.

EDIT: BTW, I ran the AppMgmtParameters.reg and it returned that it had been "successfully registered." But when I attempt to start the App Management service it returned "could not be started, etc. Error 2: The system cannot find the specified file." This problem had been occurring previously but as of yet all I manage to find about it was confusing information. I forget what program originally alerted me to the problem.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 1 time(s). Last edit at 12/04/2012 09:18PM by caktus.

Re: CommMeleon2??? Oh, No! K-Meleon Twin+ is here!!!
Posted by: Michael
Date: December 12, 2012 07:20PM

Hi guys, thanks a lot for taking the time to reply to my post.

Okay, I set today aside to have a go at getting it all running (hence my late reply). Unfortunately, I don't seem to be able to even get past first base. I simply can't extract the 7zp archive. I've tried with 7 zip and two other archive softwares and it says there's an error with it.

Could some kind soul make me a self extracting version of the archive?

K-Meleon forum is powered by Phorum.