General :  K-Meleon Forum
General discussion about K-Meleon. 
1.6 goes offline at every startup
Posted by: caktus
Date: August 12, 2012 11:01AM

I'm using 1.6.0 BETA 2. At every startup or restart, km starts out working "off-line" and I half to toggle the off-line feature in order to work online. This is not a new problem. This problem has persisted since I installed 1.6.0 BETA 2. I've been trying to figure out how to fix it, but it turns out I need help with it. Can someone please help me fix this problem.

Thank you,

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: JamesD
Date: August 12, 2012 06:49PM

It sounds like the pref kmeleon.general.offline is getting set to TRUE. When you start next time, go to edit - configuration and put the word 'offline' in the filter. If the kmeleon.general.offline is true then the next question is "was that state user set". If it is user set it should be in bold type. Highlight that line and right click for a popup menu and select toggle to set the state to false. Close configuration and restart KM.

If KM comes back up offline, then are you sure you have write authority to your profile? The only other possibility is some macro which is running at startup setting the value to true.

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: caktus
Date: August 12, 2012 11:44PM

Quote
JamesD
It sounds like the pref kmeleon.general.offline is getting set to TRUE. When you start next time, go to edit - configuration and put the word 'offline' in the filter. If the kmeleon.general.offline is true then the next question is "was that state user set". If it is user set it should be in bold type. Highlight that line and right click for a popup menu and select toggle to set the state to false. Close configuration and restart KM.

If KM comes back up offline, then are you sure you have write authority to your profile? The only other possibility is some macro which is running at startup setting the value to true.

about:config > kmeleon.general.offline IS set to false. I toggled it to True", "then back to "False",but when I restarted the machine km would only Work Off-line mode until toggled. kmeleon.general.offline is not in bold type.

I am not sure I understand "write authority to your Profile."

The only pages that open after restart and without toggling "Work off/Online" are my cashed Home Page (resource:///readme.html) and about:config.

Regardless the kmeleon.general.offline setting,
opening Saved, Previous Sessions, Undo Last Closed and saved History pages renders "Address not found. etc." However, the correct URL"s appear in the Address Bar. I think these are new problems because I think I was successfully using these features
until last Thursday.

The only changes I have made to settings was
removing some Buttons in "Toolbars.Cfg" when I first installed 1.6.0 BETA 2 about a month ago. And the only Macros, Extension, Plugins, etc. I have installed are specially indicated for 1.6.0 and in their default form.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: JamesD
Date: August 13, 2012 12:32AM

@ Charlie

That sound you hear is me scratching my head. The problem is since we are not getting updates a lot of the talented people are no longer visiting the forum. This has not happened to me, so I have no history of how to fix it.

From what you said in your first post, I gather that the check mark appears by the Work Offline item in the menu when you first start KM. KM then works online once you click that menu item just once. Is that correct?

Do you have enough hard drive space to load another version of KM? If you do, then you might try my beta 2.4 release. You can find it here: https://dl.dropbox.com/u/1522294/K-Meleon1.6.0_Beta2dot4_en-US.7z

Just create a folder somewhere that you have write authority and extract the files to that folder. If you could create the folder then you have write authority. The default here is to put the profile with the program. Just double click on k-meleon.exe.

JamesD

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: caktus
Date: August 13, 2012 09:31PM

Quote
JamesD
From what you said in your first post, I gather that the check mark appears by the Work Offline item in the menu when you first start KM. KM then works online once you click that menu item just once. Is that correct?

Sorry JamesD, I seem to have a problem with cleairy; Nothing new.confused smiley

When I first open 1.6.0 BETA 2, it immediately works "Off-line, but File > Work Off-line is NOT checked. And I halve to check it, then uncheck it in order to work online.

BTW, 1.6.0 BETA 2 also does not maintain default status very long and as a result the Internet shortcuts have defaulted to IE file association and cannot be returned to KM association.

I will try your K-Meleon1.6.0_Beta2dot4_en-US.7z an see how that works out.

Thank you for all your help.smiling smiley

UPDATE: I installed your KM 1.6B2dot4 And All seems to be going as expected. In fact, KM 1.6B2dot4 seems to be even more responsive than 1.6.0 BETA 2. I'll start making customizations one at a time and see if all continues to work as expected.

Thanks again.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 2 time(s). Last edit at 08/15/2012 12:46AM by caktus.

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: caktus
Date: August 15, 2012 01:27AM

@ JamesD

It turns out that even KM 1.6B2dot4 is also defaulting to "Work Off-line" mode, except very seldom and with no apparent rhyme or reason. I am beginning to wonder if my computer may be the problem. Over the past few weeks I have re-downloaded/re-installed 1.5.4, 1.6+.0 BETA 2 and now KM 1.6B2dot4 each time making sure that no remnants of previous versions remain. I have also Scanned for viruses/spyware/etc. with both updated AVAST! and Trend Micro's Houscall. All MS critical and Windows updates are installed. I have also run SFC /scannow several times and XP Homes' "Check Now" with "Automatically fix system errors" and "Scan for and attempt recovery of bad sectors" features selected as well as general disk cleanup. Also, I have twice performed a non-destructive system restoration and then a complete system restoration.

For the life of me I have no idea what could be causing the problem. I have found a couple of previous forum posts where others have also experienced the same problem as far back as 2010 apparently with no solution. If anyone has experienced or discovered a solution to this kind of problem I hope they will post about it in this thread.

I am beginning to believe perhaps a new HDD may be in order in spite of all the maintenance I have been performing. Meanwhile, I will keep trying to find what may be causing the problem.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: JohnHell
Date: August 15, 2012 06:38PM

JamesD, confirm this.

Set offline mode > Close/Exit K-meleon > Reopen K-meleon > check that File menu has "Work Offline" checked > go to about:config and check for kmeleon.general.offline if set to true > browse any page (that is not cached, of course)

If you can browse internet, you have the same behavior as me.

This means, that K-meleon is not getting the offline value at start.

Now, if you uncheck "Work offline" (I do via accel shorcut) you'll still be online, so the pref is not mistaken in this sense (understand true as false and viceversa) just it doesn't get the initial value. In our case the value is ever taken online, and in caktus case, offline.

Where does k-meleon store or gets this value from apart from your profile? The defaults folder maybe?



Edited 1 time(s). Last edit at 08/15/2012 06:40PM by JohnHell.

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: JamesD
Date: August 15, 2012 10:59PM

@ JohnHell

You are right. KM does not get the pref value at start-up. I set the check-mark for Work Offline and closed KM. I then looked at the prefs.js file and saw the value was set to true. When I re-started KM I could see the check-mark but I also was able to go to a site that I had not visited in more than a year.

I don't know if KM is getting another value for offline or where it might get the value. I will have a look at the defaults.

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: caktus
Date: August 16, 2012 12:08AM

When I first returned to my computer this morming after it having been on all night I was able to surf the Internet with no problems. After successfully using the Internet for a while I suddenly began getting "Working Off-'line" notices until after I toggled "Work Off-line" on and then back off. It still appears that with KM 1.6B2dot4 this problem is happening only occasionally and with no rhyme or reason as though there is a memory leak occurring.

As John Hell suggested, I set km to "Work Off-line" Exited KM including Loader.exe. When I reopened KM it was still set to "Work Off-line" and in about:config kmeleon.general.offline is set to "True".
With KM still in "Work Off-line" mode I was able to load an uncached web page.

I looked in prefs.js and see no mention of kmeleon.general.offline.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: JamesD
Date: August 16, 2012 01:11AM

The pref 'kmeleon.general.offline' defaults to false. That is in K-Meleon\defaults\pref\kmeleon.js. It will only appear in prefs.js if you have it set to true.

There is definitely a bug here, but we have no support now. It appears that the menu system FILE - WORK OFFLINE is correctly reading the pref, but I have no idea how KM's program is set to detect offline/online.

Edit:

Found something which may be of use here. See this item: http://www.ampercent.com/disable-firefox-browser-offline-mode/7639/



Edited 1 time(s). Last edit at 08/16/2012 01:16AM by JamesD.

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: JohnHell
Date: August 16, 2012 01:14AM

Quote
caktus
I looked in prefs.js and see no mention of kmeleon.general.offline.

When a pref has its default value, it is removed from prefs.js in the profile folder. Only appears in about:config if it is inside a file of the "defaults\pref" folder.

In kmeleon.js appears the kmeleon.general.offline and it is set false. In yours, should be to false.

Anyway, have you already tried to force the value via user.js?

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: km2
Date: August 16, 2012 02:37PM

@ caktus

check this, maybe

"browser.cache.offline.enable",true
"offline.autoDetect";true

try to delete localstore.rdf, xul.mfl files, from profile.

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: caktus
Date: August 17, 2012 02:10AM

Quote
km2
@ caktus

check this, maybe

"browser.cache.offline.enable",true
"offline.autoDetect";true

try to delete localstore.rdf, xul.mfl files, from profile.

Thank you, km2.

I'll give these a try and see how it goes.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: km2
Date: August 17, 2012 02:43AM

too much...

"offline.startup_state";0

0 = use network.online (default)
1 = prompt user

"network.online";true

true = Mozilla is online (default)
false = Mozilla is offline

Also,

"browser.offline";true

"network.manage-offline-status";False

False: Prevents automatically setting offline mode

Options: ReplyQuote
Re: 1.6 goes offline at every startup
Posted by: km2
Date: August 17, 2012 02:18PM

Edit:

"browser.offline";false

not sure, but offline.autoDetect is obsolete for 1.6...

Anyway you can try at list..

Options: ReplyQuote


K-Meleon forum is powered by Phorum.