General :  K-Meleon Forum
General discussion about K-Meleon. 
how to extend website connection timeout?
Posted by: Luckyday
Date: March 25, 2012 05:03AM

sometimes I use proxy to connect to sites, this proxy is sometimes slow, and many times when I load a page after 20 seconds it gives up, and says "The operation timed out when attempting to contact".

how or where do I extend the amount of time before it gives up trying to connect to a site? currently it's way too fast..

any help is much appreciated, thanks

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: Kleon
Date: March 26, 2012 12:49AM

Try this:

In about:config go to network.http.connect.timeout default

Your setting may be 30, so you can change it to 60 or 120, maybe even 600.

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: guenter
Date: March 26, 2012 02:47AM

Quote
Kleon
Try this:

In about:config go to network.http.connect.timeout default

Your setting may be 30, so you can change it to 60 or 120, maybe even 600.

I also recall that we tried to alter it like You remember.

But Kleon sorry to say that this prefernce was phased out by Mozilla.

http://kb.mozillazine.org/Network.http.connect.timeout

Quote
Mozill.org
Currently, the timeout is determined by the system-level connection establishment timeout

@ Luckyday,

I have no idea how to change that "system-level connection establishment timeout".

I do not even understand what it is in my language. sad smiley

You are English maybe You know.

Greetings from Germany



Edited 2 time(s). Last edit at 03/26/2012 02:52AM by guenter.

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: Kleon
Date: March 26, 2012 04:15AM

Quote
guenter

Currently, the timeout is determined by the system-level connection establishment timeout

I have no idea how to change that "system-level connection establishment timeout".

Mozilla (on which engine K-Meleon is based) may not have solved the timeout issue yet, but if you're using Windows you can increase the number of connect retries.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpMaxConnectRetransmissions

XP and 2000 default to 2 retries, NT defaults to 3. The initial timeout is 3 seconds and doubles for each retry.

For further info see:

http://support.microsoft.com/default.aspx?scid=kb;en-us;314053

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: JohnHell
Date: March 26, 2012 04:28AM

I think that the browser waits to see what happens with the connection.

As I use my own DNS server I think I could give a bit of light to that, guenter, as I've seen several times happening.

The example explained is, as said, about DNS resolving, some other variables could affect to the timeout.

When you request a page, K-meleon calls the tcp stack, the tcp stack routes to the DNS server, the server starts to resolve the domain to an IP, then, the result goes back to K-meleon. If found, K-meleon loads the page, if the dns server can't resolve, K-meleon, immediately, displays an error.

But, wait, there is a paradox. In the DNS server I can configure the minimum timeout for domain resolving, or, in other words I can expand the timeout limit. Here you can see the system-level timout working.

But, wait, we haven't finished. I'm talking under Windows 2000. In OSs like XP, where you have a configurable DNS client service, does it behave the same way? how is that service configured? does it have a windows registry setting as, maybe, the whole connection timeout?

I haven't searched, but probably, the solution could be in the registry.
[Kleon just answered while I was composing this message smiling smiley]


Anyway, going on topic again, we have to know first if the proxy is just slow, or if it really can't resolve and find the page through the proxy. Why I say this? because I haven't had such timeout problems with proxies. Usually, when a proxy displays an error (free proxies out there, at least) is because it really can't handle the request at any level and, usually, it displays an standard pre-configured error, not a K-meleon error.

What error does k-meleon show? Can you provide a screen capture, maybe?



Edited 1 time(s). Last edit at 03/26/2012 04:29AM by JohnHell.

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: Luckyday
Date: March 26, 2012 05:23AM

I do not think it is windows config issue, beacuse other browser like chrome and opera, using SAME proxy do not have this problem.

But, with these browsers, you can set timeout for connection... why is there no option on mozilla/kmelon to change this setting?

and the message I get, is quoted in first post, copy/paste.

I like this browser, but it is very annoying to keep having pages give up before the connection is made.. so if anybody can help it is most appreciated.

thanks

ps. I can't even post in this forum using k-melon.. it keeps saying "we have deceted the message as spam, if you have javascript disabled blaabla..." but i dont have it disabled.. anyway, i post this with other browser.

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: Luckyday
Date: March 26, 2012 05:28AM

well here it is fully, note it says the browser has stopped waiting for reply, not windows...


.

Network Timeout



The operation timed out when attempting to contact (website url).



The requested site did not respond to a connection request and the browser has stopped waiting for a reply.

* Could the server be experiencing high demand or a temporary outage? Try again later.
* Are you unable to browse other sites? Check the computer's network connection.
* Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.
* Still having trouble? Consult your network administrator or Internet provider for assistance.

.

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: guenter
Date: March 26, 2012 06:40AM

Quote
Luckyday
I do not think it is windows config issue, beacuse other browser like chrome and opera, using SAME proxy do not have this problem.

So why do You complain? Use Opera or Chrome - if they perform the job better.

BTW. Opera & Chrome currently have faster JavaScript engines than K-Meleon.
Which should not matter. No other differences. Have You tried wit Firefox?



Edited 1 time(s). Last edit at 03/26/2012 06:40AM by guenter.

Options: ReplyQuote
Re: how to extend website connection timeout?
Posted by: JohnHell (unlogged)
Date: March 26, 2012 02:55PM

Ok, that is the internal error by K-meleon. I just requested a capture because some proxies display similar messages smiling smiley

If Opera and Chrome behave as expected, then, as K-meleon is based in Mozilla GRE and they implemented it (or removed) like this, we can't do anything else :/

Options: ReplyQuote
Re: website connection timeout
Posted by: km2
Date: March 26, 2012 06:25PM

network.http.keep-alive;true /by default
network.http.proxy.keep-alive;true /by default
network.http.keep-alive.timeout /300 by default
network.proxy.failover_timeout /1800 by default

Options: ReplyQuote


K-Meleon forum is powered by Phorum.