"Browser Out Of Date"
Posted by: Matt Bohart
Date: March 21, 2012 08:52AM

Hi!

When I go to Windows Live, the site tells me that "my browser is out of date/they no longer support this browser/please upgrade to the following," etc., etc., etc.

Facebook does not not show up correctly; neither does You Tube. Obviously, although I do not remember, there are other sites as well that would also have similar problems.

May I ask how to fix this please?

Otherwise, I adore this browswer--but by no means am I a "developer."

Thank you!

Best,
Matt Bohart
Web Show Creator-and-Artist
Writer


Re: "Browser Out Of Date"
Posted by: duffy98
Date: March 21, 2012 09:54AM

Matt ... I have been using this User Agent and so far have had good luck with it. I don't see the "out of date message" so far at YouTube and such. I don't do Facebook so I don't know about that site. I tested K-Meleon at a User ID page and it says I am using IE8 on Windows 7:

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0)

I am using this with Windows 98SE. Maybe others will have a better solution for you.

User Agent ID:

http://user-agent-string.info/parse

Browser logo IE 8.0 ->Detail
run on logo Windows 7 ->OS detail

... another Browser User Agent ID site:

http://www.mg55.net/browser

Browser Identification

This is the identification string sent by the browser to the server:

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1)

From this string the following informations were extracted:

browser_name_regex: §^mozilla/4\.0 \(compatible; msie 8\.0; .*windows nt 6\.1.*\).*$§
browser_name_pattern: Mozilla/4.0 (compatible; MSIE 8.0; *Windows NT 6.1*)*
parent: IE 8.0
version: 7.0
majorver: 7
minorver: 0
platform: Win7
browser: IE
win32: YES
frames: YES
iframes: YES
tables: YES
cookies: YES
backgroundsounds: YES
javascript: YES
vbscript: YES


...

Re: "Browser Out Of Date"
Posted by: rodocop
Date: March 21, 2012 09:20PM

Answer depends on what KM version you are using.

If 1.5.x - then just upgrade to 1.6beta or 1.7alpha, else try to spoof sites with useragent string as described.

And search through forum - you situation occurs very frequently, so there are numerous threads devoted to the same problems.

_____________________________________
Using K-Meleon-1.6db+NS by dugbug / KM-16-S2014
1.6beta2.6 by JamesD
_____________________________________
Recommending K-Meleon Twin+`||`Discuss it!!!
_____________________________________
New KM74 for test and feedback! Get It!

Re: "Browser Out Of Date"
Posted by: guenter
Date: March 22, 2012 02:39AM

This has been a topic for quite a while. http://kmeleon.sourceforge.net/forum/read.php?2,120061


Some pages use a faulty browser switch but no new JavaScript or HTML features.
For these it is sufficient to spoof a newer Firefox UserAgentString.

Some pages really use newer JavaScript and HTML 5 features.
For these pages You have to use K-Meleon 1.6.beta and sometimes even 1.7.alpha.
& depending what the page's browser switch wants You need to use Firefox 3.5 or Firefox 3.6 as spoofed UserAgentString.

For some pages disrupted posted fixes for K-Meleon 1.5.4.
http://kmeleon.sourceforge.net/forum/read.php?1,115782

Background: K-Meleon uses the same JavaScript & HTML engines as Firefox.
K-Meleon 1.5.4 the same as Firefox 2.0
K-Meleon 1.6.beta the same as Firefox 3.5
K-Meleon 1.7.alpha the same as Firefos 3.6

K-Meleon 1.6 beta2 is a stable version that is at about the same level as a release candidate.

K-Meleon 1.7 alpha is a stable version that has glitches but none that much affect daily use.



Edited 1 time(s). Last edit at 03/22/2012 02:41AM by guenter.

K-Meleon forum is powered by Phorum.