General :  K-Meleon Forum
General discussion about K-Meleon. 
How proxies work now? (1.6b2.4)
Posted by: JohnHell
Date: December 12, 2011 04:48AM

I found that is behaving in some strange way. Let's see.

When you enable to use a proxy, the pref "network.proxy.type" is set to 1; then, Kmeleon should be using (and indeed uses) the proxy configured on "network.proxy.http" and "network.proxy.http_port" (or .ftp/.ftp_port, and for ssl, and... you know).

That is the normal behavior and works. But looks like when you configure a proxy in the preference window, the proxy is then set to whatever says in proxy.kmm and, so, in a preference like "kmeleon.plugins.macros.proxy1.proxy.http".

But, for any reason, K-meleon is not taking the IPs/ports set on this prefs, but the default one, this is "network.proxy.http" and "network.proxy.http_port". It is not taking the user-configuration proxy selected in the preference window.

Is it only my problem?. Does it happen to you too?

Options: ReplyQuote
Re: How proxies work now? (1.6b2.4)
Posted by: JamesD
Date: December 12, 2011 08:14AM

I don't do proxies so I never see this behavior. Do you know at which version the behavior of the prefs changed?

Options: ReplyQuote
 
Posted by: adodupan
Date: December 12, 2011 10:19AM

 



Edited 1 time(s). Last edit at 03/01/2016 02:11AM by adodupan.

Options: ReplyQuote
Re: How proxies work now? (1.6b2.4)
Posted by: km2
Date: December 12, 2011 03:26PM

Try this method, maybe.. Just, for things clear out.

function FindProxyForURL(url, host)
{
// variable strings to return
var proxy_yes = "PROXY 194.36.10.154:3128";
var proxy_no = "DIRECT";
if (shExpMatch(url, "127.0.0.1")) { return proxy_yes; }
if (shExpMatch(url, "*www.*")) { return proxy_yes; }
if (shExpMatch(url, "*.*")) { return proxy_yes; }
if (shExpMatch(url, "https://*";;)) { return proxy_yes; }
if (shExpMatch(url, "ftp://*";;)) { return proxy_yes; }
if (shExpMatch(url, "gopher*")) { return proxy_yes; }
return proxy_yes;
}

save privacy.pac in root c:\
in privacy mode profile preferences, proxy> new configuration>
name configuration: privacymode
use the following url: file:///c|/privacy.pac
then select new privacy proxy from tools>proxy

http://kmeleon.sourceforge.net/forum/read.php?9,83391

Options: ReplyQuote
Re: How proxies work now? (1.6b2.4)
Posted by: JohnHell
Date: December 13, 2011 12:47AM

Ok, I see..., I see I didn't see the apply button.

It's not enough to set for use the proxy profile, but also go to the selected proxy profile tab and click to apply... ehem... awesome.

Even the indescribable answer by adodupan, helped to find out what happened. Until then, I didn't notice that "apply" button :/

To whoever made this, I would like to suggest to apply a proxy profile by just selecting it in the dropdown menu of user predefined proxy profiles. I didn't found it in the proxy.kmm... yet. Maybe is in some jar file in chrome folder.


Anyway, just answering to JamesD, maybe this comes from 1.5.x as it is when the preference window changed. I didn't use enough the versions between 1.1.6 and your 1.6b2.4 to find out where started to happen.

As a side note: sometimes I need proxies to test my own http/ftp/whatever servers from "outside".

Options: ReplyQuote
 
Posted by: adodupan
Date: December 13, 2011 09:51AM

 



Edited 1 time(s). Last edit at 03/01/2016 02:12AM by adodupan.

Options: ReplyQuote
Re: How proxies work now? (1.6b2.4)
Posted by: JohnHell
Date: December 13, 2011 09:35PM

Interesting, thanks.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.