General :  K-Meleon Forum
General discussion about K-Meleon. 
New unofficial version : KM-16-F3624
Posted by: Fred
Date: November 11, 2011 12:28PM

I have uploaded a new unofficial version KM-16-F3624 ,
based on the updated Firefox 3.6.24 , Gecko 1.9.2.24 , date 20111103 .
It is possible, but not sure that Mozilla will release further updates
for Firefox 3.6, as many business customers will want to continue using
the older Firefox versions.
Note : This version needs the 80's runtimes. Download MSvce8dist.exe from
http://jujuland.pagesperso-orange.fr and install it.
As kplugins from K-Meleon 1.5 are being used, you will also need
the files msvcp71.dll and msvcr71.dll in your system or in your K-Meleon folder.
If you need these files, look for them in the internet.
The profile will be created inside the K-Meleon folder.
If in Linux you want it inside the ".wine" folder, because of
user rights problems, rename the file profile.ini to
profile.ini-renamed before the first start.

Download from here :

http://kmext.sourceforge.net/fred/KM-16-F3624.zip

Regards to all

Fred

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: kingsparrow
Date: November 11, 2011 11:16PM

thanks Fred, I'm using it now. So far so good..................

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: ...
Date: November 14, 2011 11:54PM

Is this a KM-1.6-Beta2 based, or is it KM-1.7-Alpha2 based?

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: Fred
Date: November 15, 2011 12:44AM

The exe is from KM 1.7, the kplugins from KM 1.5 ,
because the kplugins of the newer versions do not
work with Gecko 1.9.2.24 from Firefox 3.6.24 .

Fred

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: ndebord
Date: November 15, 2011 03:52AM

Quote
Fred
The exe is from KM 1.7, the kplugins from KM 1.5 ,
because the kplugins of the newer versions do not
work with Gecko 1.9.2.24 from Firefox 3.6.24 .

Fred

Fred,

Do you know what works and does not work with this version? I ask because I would like to move to Gecko 1.9.2 from FF 3.6.xxx instead of 1.9.1 from FF 3.5.xx that is used in the KM 1.6b2 version.

Tks.

N

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: Fred
Date: November 15, 2011 08:43AM

I have not tested everything, because I have a personal
browser setting, but most things should work.
Image zoom in and out does not work, but could be
done with a new additional zoom macro.
I would propose to use a new folder containing this
variation, and the Profiles should then be created
inside this folder, without touching the general
K-Meleon profile that you already have.
You could check then yourself, if you miss any functions.
Remember, that you need all the MS dlls mentioned above
in the K-Meleon folder or in your system, namely the
80s runtimes from Jujulands site and also the 70s
runtimes, which you may already have.

Fred

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: rodocop
Date: November 15, 2011 07:54PM

All versions, containing KM 1.7 exe, miss:
- compatible AdBlock
- compatible NoScript
- working typeahead
- ability to change some settings in Preferences

It's not the full list, but my own experience. Listed are meaningful deficiencies for me and average user, I think.
But only one is really annoying and - simulyaneously - inner (not connected with extensions) bug: no typeahead.

So, my question to Fred is:
is it possible to make F36xx-build with KM 1.6 executable?

Anyway, Fred, you make big and really needed work, so I want to say "Thank you very very very much!"
KM is my main browser for years and last time I use KM-S2014 as default. It has all what I need in work, and what I partly miss in 1.7-based builds.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: ndebord
Date: November 15, 2011 08:56PM

Quote
rodocop
All versions, containing KM 1.7 exe, miss:
- compatible AdBlock
- compatible NoScript
- working typeahead
- ability to change some settings in Preferences

rodocop,

Adblock is the sticking point for me... have seen the preferences issue, as for typeahead, aka autocomplete, I can do without it. Never liked NoScript.

My concern is Gecko.... K-Meleon needs to get to Gecko 1.9.2 IMO, sooner rather than later. Moving to Gecko 2? Who knows.

N

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: rodocop
Date: November 15, 2011 09:56PM

Just one point:
typeahead aka find-as-you-type not autocomplete.
And as for me, I need it on a few sites only, but these are my everyday and important sites (forum) which is much more comfortably explored with typeahead on.

So, thus a small, not-everyday, utility becomes irreplaceable :-)

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: ndebord
Date: November 15, 2011 10:18PM

Quote
rodocop
Just one point:
typeahead aka find-as-you-type not autocomplete.
And as for me, I need it on a few sites only, but these are my everyday and important sites (forum) which is much more comfortably explored with typeahead on.

So, thus a small, not-everyday, utility becomes irreplaceable :-)

rodocop,

Gotcha. Either way, I don't need it, but we who use KM, like our oh-so configurable browser just our personal way!

<g>

N

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: rodocop
Date: November 15, 2011 10:18PM

I've remembered one more thing KM 1.7 is missing:
- while it remembers login data (user name+password) and allows to turn this feature on/off - there isn't ability (no button in Preferences) to view saved data and no query pops up asking whether remember this site private data or not.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: Fred
Date: November 16, 2011 01:38AM

@ rodocop

Gecko 1.9.2.x does not work with KM 1.6 exe.
The kplugins from KM 1.5 work, together with the added 70s runtimes.
This is a difference from KM 1.7 alpha, where kplugins
create problems.

@ ndebord

To replace Adblock, enable CSS adblocking in Preferences/Content Filters.
This will eliminate most adverts.

Enable also Flashblock there, because many adverts are Flash nowadays.

Enabling Javascript only when needed, helps avoiding unnecessary
page errors. This can also replace Noscript to a certain degree.
Javascript can be toggled on and off by pressing F7.

Fred

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: ndebord
Date: November 16, 2011 02:49AM

Quote
Fred
@ rodocop

Gecko 1.9.2.x does not work with KM 1.6 exe.
The kplugins from KM 1.5 work, together with the added 70s runtimes.
This is a difference from KM 1.7 alpha, where kplugins
create problems.

@ ndebord

To replace Adblock, enable CSS adblocking in Preferences/Content Filters.
This will eliminate most adverts.

Enable also Flashblock there, because many adverts are Flash nowadays.

Enabling Javascript only when needed, helps avoiding unnecessary
page errors. This can also replace Noscript to a certain degree.
Javascript can be toggled on and off by pressing F7.

Fred
Fred,

Thanks, have done all you suggested. One way to do passwords is to make sure the default profile folder is the same between your version and beta2 and in this fashion, I copied the password file over and all works well. I use Prefbar to toggle javascript in both versions and as I never much liked NoScript, that is no loss to me. Flashblock is enabled now. So far, so good. <g>

Tks.

N

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: ...
Date: November 17, 2011 02:12AM

@Fred

Thanks for the answers.
To make it less confusing, please consider naming the file: "KM-17A-F3624."

Options: ReplyQuote
Re: New unofficial version : KM-16-F3624
Posted by: rodocop
Date: November 17, 2011 01:28PM

the same proposition: KM 17-F36xx will be much closer to the reality :-)

Options: ReplyQuote
Adblock Plus for K-Meleon 1.7 alpha2
Posted by: ini
Date: December 09, 2011 01:55AM

Quote
rodocop
All versions, containing KM 1.7 exe, miss:
- compatible AdBlock

ABP test build 138a.172 is working with 1.7 alpha2, however not fully functional.

Options: ReplyQuote
Re: Adblock Plus for K-Meleon 1.7 alpha2
Posted by: rodocop
Date: December 09, 2011 04:59PM

no button, no blockable items list but seems it works!

Thank you!


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Options: ReplyQuote


K-Meleon forum is powered by Phorum.