General :  K-Meleon Forum
General discussion about K-Meleon. 
javascript is on - but it isn't
Posted by: mhf
Date: October 24, 2011 05:08PM

So, with all settings set to ON, PolicyManager removed, ADP switched off etc. etc. I still can't use many sites because I get the dreaded "Javascript off in your browser" message. I've tried different Useragents in fact I've tried everything I can think of but to no avail - any ideas ?


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.24pre) Gecko/20100228 K-Meleon/1.5.4

Options: ReplyQuote
Re: javascript is on - but it isn't
Posted by: km2
Date: October 25, 2011 07:27AM

You don't need to delete policyManager, just check "Global Policy" / Edit / javaScript - Enable.

And check Advanced tab setting,
by default only "Allow to access these properties..." unchecked.
(Accessing to clipboard - Block.)

Not sure, but even if you delete PM, it can leave settings. So you can cleane-up pm completely with preferential extension.

Options: ReplyQuote
Re: javascript is on - but it isn't
Posted by: mhf
Date: October 25, 2011 05:38PM

Thanks km2 - but it's not much clearer for me :
JS is enabled in the global preferences (first thing I checked) and I can't find any references to PM in the Preferential window.

Could you expand please ? Thanks.

Options: ReplyQuote
Re: javascript is on - but it isn't
Posted by: km2
Date: October 25, 2011 06:21PM

In PolicyManager

- Delete all policy's except "Global Policy", of cource.

In the Preferential try search "policy", "capability" or open pefs.js (in your profile), trough the notepad and search "capability.policy".

Also check Tools/Privacy "Block JavaScript" must be unchecked.

Options: ReplyQuote
Re: javascript is on - but it isn't
Posted by: km2
Date: October 26, 2011 09:09AM

Try switch on ADP and uncheck all subscriptions/custom rules..

Maybe more experienced guys/girls leave some reply on this.

Options: ReplyQuote
Re: javascript is on - but it isn't
Posted by: JamesD
Date: October 26, 2011 07:50PM

@ mhf

If you have removed Policy Manager, some of the prefs that it set up may remain. All the prefs for Policy Manager begin with the words "capability.policy". Unless you are using another system which uses these prefs, then you should close KM, and edit the prefs.js file in your profile. Remove all the "capability.policy.[various]" prefs. Save the file and restart KM.

:::--------------------------
JamesD

Options: ReplyQuote
Re: javascript is on - but it isn't
Posted by: mhf
Date: October 26, 2011 09:57PM

OK - it's clearer now, thanks km2 and james.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.