General :  K-Meleon Forum
General discussion about K-Meleon. 
New unofficial version : KM-16-F3623
Posted by: Fred
Date: September 28, 2011 10:58PM

I have uploaded a new unofficial version KM-16-F3623 ,
based on the updated Firefox 3.6.23 , Gecko 1.9.2.23 , date 20110920 .
It is possible, but not sure that Mozilla will release further updates
for Firefox 3.6, as many business customers will want to continue using
the older Firefox versions.
Note : This version needs the 80's runtimes. Download MSvce8dist.exe from
http://jujuland.pagesperso-orange.fr and install it.
As kplugins from K-Meleon 1.5 are being used, you will also need
the files msvcp71.dll and msvcr71.dll in your system or in your K-Meleon folder.
If you need these files, look for them in the internet.
The profile will be created inside the K-Meleon folder.
If in Linux you want it inside the ".wine" folder, because of
user rights problems, rename the file profile.ini to
profile.ini-renamed before the first start.

Download from here :

http://kmext.sourceforge.net/fred/KM-16-F3623.zip

Regards to all

Fred

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: kingsparrow
Date: September 29, 2011 07:09PM

thanks for this new toy Fred. Enjoying and using it now, seems to be stable enough...........................

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: margarita
Date: September 29, 2011 10:10PM

Thak you Fred.
o.O

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: ndebord
Date: September 30, 2011 09:58PM

Quote
Fred
I have uploaded a new unofficial version KM-16-F3623 ,
based on the updated Firefox 3.6.23 , Gecko 1.9.2.23 , date 20110920 .
It is possible, but not sure that Mozilla will release further updates
for Firefox 3.6, as many business customers will want to continue using
the older Firefox versions.
Note : This version needs the 80's runtimes. Download MSvce8dist.exe from
http://jujuland.pagesperso-orange.fr and install it.
As kplugins from K-Meleon 1.5 are being used, you will also need
the files msvcp71.dll and msvcr71.dll in your system or in your K-Meleon folder.
If you need these files, look for them in the internet.
The profile will be created inside the K-Meleon folder.
If in Linux you want it inside the ".wine" folder, because of
user rights problems, rename the file profile.ini to
profile.ini-renamed before the first start.

Download from here :

http://kmext.sourceforge.net/fred/KM-16-F3623.zip

Regards to all

Fred

Fred,

A question I've been mulling over for some time, as I've used your builds in windows (not linux) and see how much KM 1.7a is struggling with the Kplugins from Km 1.6... I see you using KM 1.5.4 kplugins. Do you think that they could also be used with a KM 1.7 release browser?

Tks for listening.

N

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: Fred
Date: September 30, 2011 10:14PM

It would probably work, but the main problem is,
that Firefox 3.6.x, on which K-Meleon would have
to be based, is reaching the EOL end of life
sooner or later.
The existing k-meleon.exe's do unfortunately
not work with Firefox 7 and upcoming Firefox
updates.
This would need a new k-meleon.exe etc to be
developped, and I do not know how far such a
project is at the moment.
My KM 17 variation with the old kplugins can
be updated still, but only as long as Mozilla
will support FF 3.6.x .
For earlier versions, the support was available
for up to a year after the release of the
new Firefox version, but this is very uncertain
now, after the announcements of some of the
Mozilla developers.

Fred

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: km2
Date: October 01, 2011 03:04AM

about:config

Can't create new value or modify etc..

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: Fred
Date: October 01, 2011 07:48PM

Modifying an existing value or setting true to false
can still be done by double-clicking on the line, but
adding a new line seems not to be possible.
I don't know the reason for that.

Fred

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: ndebord
Date: October 01, 2011 08:42PM

Quote
Fred
It would probably work, but the main problem is,
that Firefox 3.6.x, on which K-Meleon would have
to be based, is reaching the EOL end of life
sooner or later.
The existing k-meleon.exe's do unfortunately
not work with Firefox 7 and upcoming Firefox
updates.
This would need a new k-meleon.exe etc to be
developped, and I do not know how far such a
project is at the moment.
My KM 17 variation with the old kplugins can
be updated still, but only as long as Mozilla
will support FF 3.6.x .
For earlier versions, the support was available
for up to a year after the release of the
new Firefox version, but this is very uncertain
now, after the announcements of some of the
Mozilla developers.

Fred

Fred,

As I understand it, one of the problems with KM 1.7 is the kplugins from KM 1.6 don't work (some of them that is) and so your use of KM 1.5.4 is why I posted this message... small ray of light in the tunnel.

Yup, know about the problems with Gecko 2.0. As for Gecko 1.9.2 (Firefox 3.6.xxx), because of complaints from Enterprise users and because Debian is still using 3.6 in its official variation of Firefox (Iceweasel), support will probably continue for some time... not a long period of time, but some time. Mozilla Corp. backed off of Asa's extreme pronouncements and quietly changed their policy.

Don't know what to say about building a new executable, as I have never been a coder. We need a C++ developer to reappear for K-Meleon, whether it be Gecko as the engine or do like others have done, move to WebKit. I do not like the idea of saying goodbye to KKO's macro scripting improvements.

FWIW, I use PSI 2 to tell me if my software is bad and it says that KM 1.6 is OK (for now that is).

It just makes me think that a KM 1.7beta is a possibility as you have demonstrated here.

N



Edited 1 time(s). Last edit at 10/01/2011 08:44PM by ndebord.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: km2
Date: October 01, 2011 10:58PM

Creating a new value still possible, but with preferential ext.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: Slimshady444
Date: October 03, 2011 08:04AM

seems the same as 1.7.a2

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: 4td8s
Date: October 05, 2011 01:11AM

Quote
ndebord

Yup, know about the problems with Gecko 2.0. As for Gecko 1.9.2 (Firefox 3.6.xxx), because of complaints from Enterprise users and because Debian is still using 3.6 in its official variation of Firefox (Iceweasel), support will probably continue for some time... not a long period of time, but some time. Mozilla Corp. backed off of Asa's extreme pronouncements and quietly changed their policy.

yup ndebord, support for FF 3.6 is still being continued by mozilla.
an FF 3.6.24 version is being planned for release on November 8; same release date as FF 8.0.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: K
Date: October 06, 2011 08:12PM

basic authentication does not work.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: ndebord
Date: October 06, 2011 08:59PM

Quote
K
basic authentication does not work.

K,

Could you provide a URL so we can see it too?

Tks.

N

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: JamesD
Date: October 07, 2011 07:11PM
Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: ndebord
Date: October 07, 2011 08:12PM


JamesD,

Have you heard anything about Mozilla's idea to move to silent upgrade where you don't have a choice (like Chrome), it just does it all in the background. Similar, the idea of never telling you the version number of your current browser?

Tks.

N

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: K
Date: October 07, 2011 08:15PM

I don't have a concrete example on the Internet.
Following is packet capture by Wireshark,
HTTP response header when K-Meleon KM-16-F3623 access to admin console of a router.

HTTP/1.0 401 Unauthorized
Server: IP_SHARER WEB 1.0
WWW-Authenticate: Basic realm="CG-BAR FX2"
Content-type: text/html

Almost browser (including K-Meleon 1.5.4) shows a dialog to input authentication information after receiving 401, then retry accessing with authentication information.
But KM-16-F3623 just display 401 message.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: JamesD
Date: October 08, 2011 03:49AM

Quote
ndebord
Have you heard anything about Mozilla's idea to move to silent upgrade where you don't have a choice (like Chrome), it just does it all in the background. Similar, the idea of never telling you the version number of your current browser?

Have not seen anything on this yet.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: ndebord
Date: October 08, 2011 06:33AM

Quote
JamesD
Quote
ndebord
Have you heard anything about Mozilla's idea to move to silent upgrade where you don't have a choice (like Chrome), it just does it all in the background. Similar, the idea of never telling you the version number of your current browser?

Have not seen anything on this yet.

JamesD,

I read something somewhere, but can't recall what. I'll look for it now.

P.S. This is what I found, not up-to-date I'm afraid.

https://wiki.mozilla.org/Silent_Update

N



Edited 1 time(s). Last edit at 10/08/2011 10:36AM by ndebord.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: gordon451
Date: October 08, 2011 12:15PM

Quote
Mozilla Silent Update page
...we want to ensure everyone is on the latest version of Firefox

Of course all FireFox will work on older OSs surprised smiley ROFL LMAO

My mum always told me "If you can't say anything nice, don't say anything." ^-zip-^

Gordon.

____________________
Gigabyte H61M-USB3-B3 r2.0, I5-2400 3.10GHz, 4GB RAM; W7HPx64 SP1, Lotus SmartSuite 9.8, K-Meleon74, Opera 12.17, IE9, Eudora 6.2, Foxit Reader 5.3.1.0606, PaintShop Pro 6.02, Avast! 10.0.2206

____________________
Early to bed and early to rise makes a bloke crook, broke and stupid.

Options: ReplyQuote
Re: New unofficial version : KM-16-F3623
Posted by: 4td8s
Date: November 11, 2011 09:41AM

fred, can you make an unofficial KM-16-F3624 release since FF 3.6.24 came out late Tuesday afternoon? thanks.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.