General :  K-Meleon Forum
General discussion about K-Meleon. 
Find bar - searches as you type
Posted by: Jerbearrrrrr
Date: June 10, 2011 11:47PM

Hi all,

is there a way to disable the equivalent of "find as you type" in the find bar (the ctrl+f thing)?

If I start typing in the find bar, it will immediately start seraching before I press enter (sometimes losing your place on the page).

Is there any way to make it wait until enter is pressed before executing the search?

thanks

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: panzer
Date: June 11, 2011 01:47AM

Preferences-Finding Websites-URL bar-uncheck find fitting pages ... and autocomplete as you type. I think this should do it.



Edited 1 time(s). Last edit at 06/11/2011 01:51AM by panzer.

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: siria
Date: June 11, 2011 03:46AM

Hmm, looks like that's not an "equivalent" of "Find as you type" but simply the same thing: it stops if you disable FAYT in "Edit>Page Search" menu. Personally I like it smiling smiley

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: Jerbearrrrrr
Date: June 13, 2011 06:59PM

panzer - wrong feature, I'm talking about ctrl+f, not anything url-related.

siria - box is already unchecked, no difference to the feature in question whether or not it's ticked.

Version is K-Meleon 1.5.4. Not sure how to check build numbers or anything.

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: siria
Date: June 13, 2011 10:51PM

Hmm... which "box"...?
Are you sure that's in MENU Edit>Page Search?

If that really doesn't work, open "about:config" and check if
"accessibility.typeaheadfind" is set to false.
Or if you type "typeahead" into the filter line, there appear a whole bunch of more options, perhaps you can find some solution there.

EDIT: Oops... That works only in KM1.6, but you're right, in my KM154 it ignores that setting! Perhaps there are some more settings needed, or perhaps it's a gecko bug, no idea...



Edited 2 time(s). Last edit at 06/13/2011 10:57PM by siria.

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: Jerbearrrrrr
Date: June 14, 2011 04:23PM

I've already set everything with typeahead to false lol.

As for the "box", sorry, I wasn't thinking. The box is metaphorically unticked. And yes, it was in edit=>page search.

How do I upgrad to KM1.6? Can I just overwrite the executable?

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: Jerbearrrrrr
Date: June 14, 2011 04:44PM

Just saw all the dlls. Overwriting the executable was never gonna work lol.

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: Jerbearrrrrr
Date: June 14, 2011 04:54PM

Just downloaded KM1.6, Edit=>PageSearch=>FAYT doesn't seem to alter behaviour one way or another.

Options: ReplyQuote
Re: Find bar - searches as you type
Posted by: sourcheese
Date: January 09, 2012 01:04AM

Hello ..i got a bar in the right couner of my page and it will not let me type..every time i put in a letter it scrolls down the page finding that letter and i really need it to go its been bugging me for a while and is there like a easy way to get it away...ps im not good with computers so i probley don't know what most of the things that have been cometed means :/sad smiley

Options: ReplyQuote


K-Meleon forum is powered by Phorum.