General :  K-Meleon Forum
General discussion about K-Meleon. 
KM16Beta2+ Missing toolbar & buttons
Posted by: machinesmith
Date: April 29, 2011 03:56AM

Hi all

I've spent about 2 hrs now and no matter WHAT version I've tried I keep getting the same result: No Back, Forward, Go etc buttons (IIRC that was called the Main Toolbar, well that bar is entirely missing). Manual Domain completion no longer works (e.g. pressing Ctrl+Enter to get the www. and .com prefix/suffix) and the privacy features (Javascript on/off, FlashBlock etc) are gone, I'm sure I'll run into others but right now those are big ones.

This is a fresh install of Windows (XP SP2) and KM1.6+ was the first thing to be installed (after drivers) I have no clue what's causing this.

I've tried installing 1.6beta2 initially, then went to KM1.7a2, then tried out a solution that was given back in 2007 on the forum (same missing buttons/toolbar problem, except for KM1.5 - the solution back then was to go to about:config and set kmeleon.toolband&Main Bar.visibility to True) and finally tried going back to KM1.6a4. NONE of these worked.

KM-1.5.4, however, has everything working great. As much as I love the 1.5 series - I'd like to progress a little ahead (KM1.6+ web rendering has spoilt me!)


Anyhelp at all would be appreciated

--
sys specs for KM reporting: PIII-1GHZ, 1GB RAM, WinXPsp2

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: siria
Date: April 29, 2011 04:15AM

Quote from the download page, below "latest dev. version":
Quote

If you have problems to run some 1.6.0 Beta version is possible you need install:
VS2005 Redistributable
http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647

Have you tried that already...?

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: machinesmith
Date: April 29, 2011 04:21AM

Yep, I have, installed that (VC2005 redistributable) and when it didn't work, I installed VC2008 redistributable, then SP1 for vc2008 redis. No go unfortunately

Edit: I've fixed it! I *still* have no clue how or why it got fixed, but all I did was Download a build made by Fred (KM-16-S2013 to be exact) I extracted the file to desktop and then ran it (no other instances of KM were running at the time)

Fred's build had everything showing up fine, after closing his version I went back to the offending copy of KM1.6 I had installed and...I had everything working again! Toolbars, buttons, hotkeys , the works!

Thank you Fred! For making builds of KM that I'll never use unless I'm frustrated! (and for making builds that magically fix the official ones!)



Edited 1 time(s). Last edit at 04/29/2011 04:27AM by machinesmith.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: siria
Date: April 29, 2011 04:52AM

Crazy... grinning smiley But glad it works now!!
Could it be that there's some prob with creating a new profile the first time or something??? And Freds version created one in your user account, and at next start KM1.6beta found it? Just a wild guess.



Edited 1 time(s). Last edit at 04/29/2011 04:52AM by siria.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: ndebord
Date: April 29, 2011 06:23AM

Quote
machinesmith
Hi all

I've spent about 2 hrs now and no matter WHAT version I've tried I keep getting the same result: No Back, Forward, Go etc buttons (IIRC that was called the Main Toolbar, well that bar is entirely missing). Manual Domain completion no longer works (e.g. pressing Ctrl+Enter to get the www. and .com prefix/suffix) and the privacy features (Javascript on/off, FlashBlock etc) are gone, I'm sure I'll run into others but right now those are big ones.

This is a fresh install of Windows (XP SP2) and KM1.6+ was the first thing to be installed (after drivers) I have no clue what's causing this.

I've tried installing 1.6beta2 initially, then went to KM1.7a2, then tried out a solution that was given back in 2007 on the forum (same missing buttons/toolbar problem, except for KM1.5 - the solution back then was to go to about:config and set kmeleon.toolband&Main Bar.visibility to True) and finally tried going back to KM1.6a4. NONE of these worked.

KM-1.5.4, however, has everything working great. As much as I love the 1.5 series - I'd like to progress a little ahead (KM1.6+ web rendering has spoilt me!)


Anyhelp at all would be appreciated

--
sys specs for KM reporting: PIII-1GHZ, 1GB RAM, WinXPsp2

I too had the exact same problems right after a fresh install of XP PRO SP3 on my laptop. I didn't find your solution, but I did install the VC2005 stuff and something else, can't recall exactly what and after a reboot, voila!, everything was as it should be. Can't say what redistributable files are needed, but there is definitely something there that was missing and could be fixed by installing something, but exactly what I don't know. This was a single user install with profile.ini in the program folder. I don't let things write to the registry very often if I can help it.


FRED????

XP PRO SP3
K-Meleon 1.6beta 2 (Guenter's hack)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19pre) Gecko K-Meleon/1.6.0

N



Edited 3 time(s). Last edit at 04/29/2011 06:31AM by ndebord.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: frank
Date: April 29, 2011 09:15PM

ndebord

where is guenter's hack available form (for KM 16-B2) ?

frank

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: guenter
Date: April 29, 2011 10:55PM

guenter does not hack but sometimes builds updates for the GRE of 1.6.beta2.
Cave: guenter only supplies files without any warranties. & Users must know how to manually update the GRE themselves.

p.s. Read desga2's how too for the older GRE of 1.5.x if You do not know how.
It is done the same way - only other K-Meleon & GRE versions.


I will probably re-build the most recent SeaMonkey or Firefox code this weekend.
But my site is down. sad smiley



Edited 1 time(s). Last edit at 04/30/2011 01:14AM by guenter.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: ndebord
Date: April 30, 2011 07:48AM

Quote
guenter
guenter does not hack but sometimes builds updates for the GRE of 1.6.beta2.
Cave: guenter only supplies files without any warranties. & Users must know how to manually update the GRE themselves.

p.s. Read desga2's how too for the older GRE of 1.5.x if You do not know how.
It is done the same way - only other K-Meleon & GRE versions.


I will probably re-build the most recent SeaMonkey or Firefox code this weekend.
But my site is down. sad smiley

Guenter,

Guenter doesn't hack, but is Guenter a hack? <g,d&r>>

<VBG>

A rebuild on the latest Seamonkey would be very much appreciated here!

N



Edited 1 time(s). Last edit at 04/30/2011 07:48AM by ndebord.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: guenter
Date: April 30, 2011 09:01PM

Quote
ndebord

Guenter doesn't hack, but is Guenter a hack?


A rebuild on the latest Seamonkey would be very much appreciated here!

Whatever that means? (I assume cludge?)

You can also use Firefox sources, it does not matter after recent code changes



Edited 1 time(s). Last edit at 04/30/2011 09:03PM by guenter.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: ndebord
Date: May 01, 2011 12:38AM

Guenter,

Kludge is American spelling, as for hack, either as in hacker or as in "hack writer" <g,d&r> A witticism or as they would say where I come from: corn-feed humor.

Good to know that you are no longer dependent solely upon SeaMonkey sources!

N



Edited 2 time(s). Last edit at 05/01/2011 12:41AM by ndebord.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: guenter
Date: May 01, 2011 04:04AM

Quote
ndebord


Good to know that you are no longer dependent solely upon SeaMonkey sources!

Not You or me but K-Meleon.org.

p.s. For as long as it lasts = 1.9.1x currently.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: ndebord
Date: May 01, 2011 07:45AM

Quote
guenter
Quote
ndebord


Good to know that you are no longer dependent solely upon SeaMonkey sources!

Not You or me but K-Meleon.org.

p.s. For as long as it lasts = 1.9.1x currently.

Guenter,

I stand corrected... but still, good to know!

N

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: Craig
Date: December 24, 2011 05:39AM

I had the same problem with 1.6.0
I then installed 1.5.4 and I now have the buttons back, however I can't
open preferences. When I try I get this message..."XML parsing error undefined entity. location:chrome//kmpref/content/pref.xul line #4, column 1: Dialog xmlns www.mozill.org/keymaster/gatekeeper/there.is.only.xul"
What can I do to access preferences?

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: JamesD
Date: December 24, 2011 11:46AM

I am not sure which 1.6 version you are trying. I have a 1.6.0 beta 2.4 at this location. http://dl.dropbox.com/u/1522294/K-Meleon1.6.0_Beta2dot4_en-US.7z

You might give it a try to see if that fixes your problem. Make a new folder and use 7zip to extract the files to that folder.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: JujuLand
Date: December 24, 2011 02:42PM

Probably a profile problem.

Try to create a new profile to see if it's better.

I think that sharing the same profile between 2 different versions of K-Meleon is not a good idea.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 1 time(s). Last edit at 12/24/2011 02:42PM by JujuLand.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: JohnHell
Date: December 24, 2011 07:17PM

The problem is the C++ 2005 SP1 dlls.

I dealt this week with this problem too in a... let's say "at work computer". In the downloads page you have the correct download. Don't search with Google as you probably end in C++ 2005 *pre SP1* installable.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: JujuLand
Date: December 24, 2011 07:23PM

Well, I forget it.

You can download a tiny version here:

http://jujuland.pagesperso-orange.fr/

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: Craig
Date: December 24, 2011 10:37PM

Quote
JamesD
I am not sure which 1.6 version you are trying. I have a 1.6.0 beta 2.4 at this location. http://dl.dropbox.com/u/1522294/K-Meleon1.6.0_Beta2dot4_en-US.7z

You might give it a try to see if that fixes your problem. Make a new folder and use 7zip to extract the files to that folder.

That did not work, still have the same problem.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: Craig
Date: December 24, 2011 10:43PM

Quote
JohnHell
The problem is the C++ 2005 SP1 dlls.

I dealt this week with this problem too in a... let's say "at work computer". In the downloads page you have the correct download. Don't search with Google as you probably end in C++ 2005 *pre SP1* installable.

I downloaded directly from the download page.
I went to the jujuland site, but nothing would download.
How do I fix the dlls?

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: JujuLand
Date: December 24, 2011 11:44PM

Sorry, I had problem with an update, and the pages were broken.

That's now ok

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: Craig
Date: December 25, 2011 07:48PM

Ok nothing has worked so far.
Any other suggestions?

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: rodocop
Date: December 26, 2011 07:37AM

check you have this 3 files in windows/system32:
Windows\system32\mfc71.dll
Windows\system32\msvcp71.dll
Windows\system32\msvcr71.dll

Second option, you can try to put them in KM-folder


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: Craig
Date: December 26, 2011 07:13PM

All three of those dlls are missing from my machine.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: rodocop
Date: December 26, 2011 08:08PM

So this maybe the reason!
Download them here:
http://www.2shared.com/file/3zYsec9G/ms_files71.html

and place into windows/system32


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 2 time(s). Last edit at 12/27/2011 02:40AM by rodocop.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: guenter
Date: December 27, 2011 01:34AM

Quote
rodocop
check you have this 3 files in windows/system32:
Windows\system32\mfc71.dll
Windows\system32\msvcp71.dll
Windows\system32\msvcr71.dll

Second option, you can try to put them in KM-folder

Not so fast.

These files belong to K-Meleon 1-0-1.5.4.
These K-Meleons are compiled with VC 7.1.

The topic is KM16Beta2+ Missing toolbar & buttons
Current K-Meleon 1.6 variants are compiled with VC8.
It needs the VC 8 redistributable package or the minimalistic hand out by jujuland linked by JamesD already.

The toolbar, favorities, bookmarks, hotlist, bmpmenu dlls/kplugins & K-Meleon.exe need support for a certain older code in comctl32.dll if You want the to create proper bars.

Additionally for alpha transparency on all Windows XP or newer (Not Win98 or Win2000) make sure that Microsoft.Windows.Common-Controls has version="6.0.0.0".

See the last 2 posts in this related thread. http://kmeleon.sourceforge.net/forum/read.php?3,115632,116686#msg-116686

But I have no ideas if that does not help.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: rodocop
Date: December 27, 2011 02:39AM

but presence of these files really affects some aspects of the performance of 1.6-1.7 builds I'm using.

P.S. I've slightly corrected my previous message though...


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 12/27/2011 02:41AM by rodocop.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: guenter
Date: December 27, 2011 04:58AM

Quote
rodocop
but presence of these files really affects some aspects of the performance of 1.6-1.7 builds I'm using.

P.S. I've slightly corrected my previous message though...

Ok.

Fred's 1.6-1.7 compilations sometimes use VC 7.1 generated Kplugins with VC 8 compiled exe.
So it effects some builds functions but not official ones.

It does not effect KM16Beta2+. Generally it only effects the versions that have the dlls that You have enumerated linked into them or their kplugins.

You can use programs such as filealyzer to find out/check which program/dll needs which dll.


p.s. The problem is that there is no real way we can help users that have partially outdated systems or have systems with missing or broken dll.



Edited 2 time(s). Last edit at 12/27/2011 05:37AM by guenter.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: JohnHell
Date: December 27, 2011 05:52AM

Guenter, to leave it clear, is this one:
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=5638

The same distributables you posted, but SP1. If they are not SP1, don't work, as I said in my previous post.

Options: ReplyQuote
Re: KM16Beta2+ Missing toolbar & buttons
Posted by: guenter
Date: December 27, 2011 11:50AM

Quote
JohnHell
Guenter, to leave it clear, is this one:
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=5638

The same distributables you posted, but SP1. If they are not SP1, don't work, as I said in my previous post.

Thx for correcting me.


Sorry that I did not read Your message properly enough. sad smiley

Options: ReplyQuote


K-Meleon forum is powered by Phorum.