General :  K-Meleon Forum
General discussion about K-Meleon. 
preference language
Posted by: bamboum
Date: March 30, 2011 08:08PM

Where I can change the language when kmeleon is reading the script of a web page. I suppose that it is configured to find english langage first.
For example on this page: www.polytech-clermontferrand.fr/ if I used IE or avant that's work. But with Kmeleon I got page not found. The webmaster said that I must force my navigator to read first in french the pages. On his navigator I see that one can put with a preference order the different languages.
Thanks for your answer.

Options: ReplyQuote
Re: preference language
Posted by: caktus
Date: March 30, 2011 09:12PM

bamboum,

I am not sure if this is what you are looking for but it might help.

I think this only translates the current page. Click on Tools > Translation > From English. Then, again click on Tools > Translation > To > French.

To permanently use French language, go to http://kmeleon.sourceforge.net/download.php and down load the French version of KM.

I hope this is helpful.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: preference language
Posted by: JamesD
Date: March 30, 2011 11:22PM

I think the pref intl.accept_languages might have something to do with which language is read first.

Edit: Put "intl.accept_languages" in search of forum and go back 1 year to find more information.



Edited 1 time(s). Last edit at 03/30/2011 11:25PM by JamesD.

Options: ReplyQuote
Re: preference language
Posted by: guenter
Date: March 30, 2011 11:49PM

Quote
JamesD
I think the pref intl.accept_languages might have something to do with which language is read first.

Absolut. Go Configuration -> Configuartion du Navigateur -> Insert to the filter

intl.accept_languages that will lead to the right item. I got: de, en, fr, es

You must choose/edit fr, de, en or whatever. But French (fr) is first choice/place.

BTW. The new 1.6 version will have a GUI to set that.



Edited 1 time(s). Last edit at 03/30/2011 11:50PM by guenter.

Options: ReplyQuote
Re: preference language
Posted by: siria
Date: March 30, 2011 11:52PM

Quote
JamesD
I think the pref intl.accept_languages might have something to do with which language is read first.

Yep, that's what websites use to choose a language to display.

In KM 1.6 (currently beta) desga recently added this setting in the pref sheets:
Edit > Preferences (F2) > Page Display / Languages

In KM 1.5 it can only be set manually, unless I'm mistaken:
- Edit > Configuration > Browser Configuration (=about:config)
(Ignore the warning, this language setting isn't overly dangerous grinning smiley)
- Type "language" in the filter line
- Right-click on "intl.accept_languages" to type your preferred languages.
There can be many, for example mine is set to "de,en-us,en,fr"

PS:
If you filter for "locale" there are yet more language settings, for different purposes. Am not quite sure what each one is here for...
In general, if you want to play with settings without being absolutely sure what they do exactly, better first make a backup copy of the file prefs.js in your profile folder, so you can restore it anytime.
Highly recommended anyway to keep a copy of the profile folder as backup cool smiley

------
@guenter: LOL, this time you were 3 min faster!! grinning smiley grinning smiley



Edited 2 time(s). Last edit at 03/31/2011 12:03AM by siria.

Options: ReplyQuote
Re: preference language
Posted by: bamboum
Date: April 01, 2011 11:37PM

Thanks a lot. I was in the config and write fr also (because that was missing) at the first place: fr,en-us, en
Now it is working!

Options: ReplyQuote


K-Meleon forum is powered by Phorum.