General :  K-Meleon Forum
General discussion about K-Meleon. 
KVRAUDIO site - K-Meleon not good
Posted by: hopi
Date: March 21, 2011 11:42PM

on the forums for the kvraudio.com site, K-Meleon does something weird when user tries to type an entry to the forum and\or type to send a pm to another user...

you would have to try it to see how maddening it is... but basically hitting the space bar jumps you out of the message entry fields and goes to something else..

it is ONLY K-Meleon that does this... no other browser has this problem

I wish it could be fixed as I prefer to use K-Meleon always but this makes it impossible on this site.

Options: ReplyQuote
Re: KVRAUDIO site - K-Meleon not good
Posted by: guenter
Date: March 21, 2011 11:56PM

Change browser string via menu: Tools -> User Agent To Firefox.

If that does not help with K-Meleon 1.5.4 update to K-Meleon 1.6.beta2 en-US and use the same method.

Tech Info: The error origins from a script (browser switch) used by that site. It is supposed to send a browser specific page to K-Meleon. Because it does not recognize that K-Meleon uses the Gecko HTML rendering Engine just like Firefox it sends the wrong page version. Probably the IE version. K-Meleon does not know the JavaScript dialect of the IE version because that is not standards compliant Java/ECMA-Script. If You open the error console You see details what went wrong.

Setting the UserAgentString to Firefox makes that K-Meleon sends the page wrong info so that the page sends the right return message in the dialect K-Meleon can understand. smiling smiley

I personally changed my user string permanently to: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.25pre) Gecko/20100308 K-Meleon/1.5.4 not Firefox/2.0.0.25pre - most stupid browser switches read that as Firefox because the string is present. grinning smiley

Some pages do not support Gecko engine Version 1.8.x (K-Meleon 1.5.4) anymore it might be needed to update to Gecko engine version 1.9.x (K-meleon 1.6.bet2).

This is not a K-Meleon but a site specific bug. So this thread will be moved. Please confirm ASAP so that I an can move this thread to General Forum. Thx.



Edited 1 time(s). Last edit at 03/22/2011 12:06AM by guenter.

Options: ReplyQuote
Re: KVRAUDIO site - K-Meleon not good
Posted by: 4td8s
Date: March 25, 2011 11:13PM

is there any way to change the K-meleon user agent string to IE?

I know the kvraudio.com site works perfectly with Internet Explorer.
I've used their forum site in the past a few times and works best with IE.

Options: ReplyQuote
Re: KVRAUDIO site - K-Meleon not good
Posted by: snuz2
Date: March 26, 2011 03:21PM

yes you can change it to IE. That will give you the same page you see now, designed for IE rather than Mozilla, so it won't help you. Just surf as FF like everybody else....sad smiley

Options: ReplyQuote


K-Meleon forum is powered by Phorum.