General :  K-Meleon Forum
General discussion about K-Meleon. 
The 1st time, it goes well. the 2nd time, it goes
Posted by: SUZUKI Youji
Date: October 25, 2001 03:37AM

I happend to hear about K-Meleon.
I was interested in it's small size and light weight, then tried it.

I installed K-Meleon 0.5 on Japanese-Win98 + IE5 + MFC42.dll(ver6.??).

The 1st time(auto started just after install), K-Meleon goes well.
Preference looks no problem,

Then close it, and restart K-Meleon, "Could not find menu.cfg" dialog
appeared. after it , "Coul not find accel.cfg", some new plugins found,
and "No Menu" dialog appeared. Finally K-Meleon windows appeared, but
it doesn't have the menu bar.

K-Meleon is installed at "C:\Program Files\K-Meleon\*".
Preference is at "C:\WINDOWS\Application Data\KMeleon\Profiles-1\hw9q9x0y.slt\*",
as in the 1st time preference.

What can I do to start K-Meleon well ?

And one more question. How should I pronounce "K-Meleon" ?

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: Suppafly
Date: October 25, 2001 11:59AM

try uninstalling it and reinstalling it..

also.. pronounce it like the small lizard.. cameleon

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: SUZUKI Youji
Date: October 26, 2001 03:37AM

Yes, I have uninstall-reinstalled again and again.
But "No Menu" has appeared again and again.
(Sorry, I forgot to write before.)

I tried on another machine(Win98SE), it went the same.

What can I do more ?

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: Yannick
Date: October 26, 2001 04:20PM

maybe if you try to pronounce its name correctly it will stop annoying you :o)

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: Fulvio Perini
Date: October 26, 2001 11:45PM

Just a guess,since a number of problem surfaced in Netscape6.1,and they were corrected by deleting the Chrome folder in your Data folder,not in the main program.
If K-meleon works like Mozilla,and it should,the chrome file will be rebuilt.But since you are talking about menu.cfg and accel.cfg,it seems that you lack something.Do you have those two file in your .slt folder?The files can be opened using Notepad(right click Open with Notepad).Sorry,I do not see anything obvious in my menu.
I do not think that pronouncing incorrectly would such a drastic effect.
Anybody else with Japanese Win98?

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: SUZUKI Youji
Date: October 27, 2001 05:30AM

Yes, I found "menu.cfg" and "accel.cfg" in "*.slt" folder, and opened by notepad.

I check in "*.slt\chrome" folder, there is only one file "user-locales.rdf".
Then I tried copying chrome files from install-dir to *.slt/chrome", but the same
result.

By the way, in the directory "c:\WINDOWS\Applicaion Data\KMeleon",
there is a "Profiles" empty directory (perefence is in "Profiles-1"),
and a file "registry.dat".
Do them effect this probrem?

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: Fulvio Perini
Date: October 27, 2001 12:08PM

I cannot see why having an empty folder would hurt.I have only one Profile,and I did not bother changing from default.
As for the Chrome folder,I have the same file as you do,but I was recommended to delete it at the Netscape Message Board,when there were strange installation problems.I have problems with the Location bar.There was none,and all icons were to the left,and unusuable.I deleted the Chrome folder,and everything was ok,and the problem did not reoccur.I may not help you,but it is very quick to do or undo. As for the .cfg files,I do not understand what should be there.And,finallyy,yes,I do have a registry.dat file,and it should be there. My suggestion is that you uninstall K-Meleon from the Add/REmove one more time,but Delete the K-Meleon folder in Application Data.Everything has to go.Then reinstall.

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: SUZUKI Youji
Date: October 28, 2001 04:20AM

I tried it, but result the same.

Uninstalling with "all profiles delete",
and checked with explorer that "c:\WINDOWS\Application Data\KMeleon"
isn't exist.
And checking registry, deleted "K-Meleon" entry.

Then install.
When K-Meleon is autostarted, Profiles directories are:
c:\WINDOWS\Application Data\KMeleon\Profiles\ (empty)
\Profiles-1\28sht87m.slt*
(preference files here)
\registry.dat
In K-Meleon's preference setting:
Setting Dir: C:\WINDOWS\Application Data\KMeleon\Profiles-1\28sht87m.slt\
Plugins Dir: C:\PROGRAM FILES\K-MELEON\kplugins\

In setting dir, there are "menu.cfg" and "accel.cfg".
There files can be opened by notepad.

K-Meleon shows blank screen, URL field is also blank.

Then exit, and start via desktop icon.
First, "Manage Profiles" window appear, select default, and press "OK",
then "Could not find menus.cfg" appeared, and so on.

After this, Everytime K-Meleon stated and "Could not find menus.cfg" appears immediately.

These are all events I faced.
Is there any more check point?

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: Andrew
Date: October 29, 2001 12:39PM

Try this:

Users running Windows95 and/or versions of Internet Explorer older than 5.0 need to download and install the Common Control Library from Microsoft:
http://www.microsoft.com/msdownload/ieplatform/ie/comctrlx86.asp

Andrew

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: SUZUKI Youji
Date: October 30, 2001 03:35AM

I downloaded "50comupd.exe" and ran it,
but dialog said,
"Your computer already has the latest version of Windows common controls."
and no action.

Then re-install K-Meleon, but result the same.

(I think comctl32.dll is related to Windows(or parts) drawing.
Does it have something to do with "Profiles" ? )

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: Brian
Date: October 30, 2001 07:44AM

A control is something like a button or a text box or a menu or anything else you see on the screen. Common controls are controls that all windows programs share. K-Meleon uses something called a "rebar control" that is only available in the newest version of the comctl library.

I think the problem has something to do with the japanese windows. I have never tested it on anything other than english, so I really have no idea what kind of strangeness can happen.

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: SUZUKI Youji
Date: October 31, 2001 03:37AM

Now I want to compile & trace K-Meleon,
but I doan't have VC++. (Src files looks VC++ code, isn't it?)

I only have gcc, but it can't compile MFC-program,
Then, how can I get compiler which can compile K-Meleon?

Please don't say "Buy VC++", it's expensive.(over 20000 Yen, about $200)
Next, Borland's Delphi personal edition? C++Builder free compiler ?

Is there any free or low-cost compiler which can compile MFC-program?

Options: ReplyQuote
Re: The 1st time, it goes well. the 2nd time, it g
Posted by: Brian
Date: October 31, 2001 04:40AM

We all use Visual C++, it may work with Borland, but I have no idea. You can get Visual C++ 6 on ebay for real cheap. I got my copy brand new, unopened, professional edition for $100 off ebay.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.