General :  K-Meleon Forum
General discussion about K-Meleon. 
AdBlock Question ...
Posted by: duffy98
Date: March 07, 2011 11:36PM

Never used AdBlock before till last week ... I put the version on for KM 1.5.4 and the new version on for KM 1.6 Beta 2. I have noticed that when I open the KM browser now ... KM seems to take longer to open. This is not a complaint, just an observation. Am I right on this ... is there a connection and have others noticed this also? ... thanks

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: luk3Z
Date: March 08, 2011 02:19PM

Quote
duffy98
Never used AdBlock before till last week ... I put the version on for KM 1.5.4 and the new version on for KM 1.6 Beta 2. I have noticed that when I open the KM browser now ... KM seems to take longer to open. This is not a complaint, just an observation. Am I right on this ... is there a connection and have others noticed this also? ... thanks

I also noticed this. 1.6b2 is little slower when you start it about 0.5~1 sec I think. You can speed up your KM - read this: http://kmeleon.sourceforge.net/forum/read.php?1,114722
BTW
I today move my KM dir to 2 GB (FAT16) partition with pagefile.
KM running faster and it is easier and faster to defragment this partition when I have disk cache setting on >300MB.

Edit:
I don't use KM Loader, but it can speed up your KM:
http://kmeleon.sourceforge.net/wiki/TutorialLoader



Edited 4 time(s). Last edit at 03/08/2011 08:14PM by luk3Z.

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: caktus
Date: March 09, 2011 12:22AM

Quote
duffy98
Never used AdBlock before till last week ... I put the version on for KM 1.5.4 and the new version on for KM 1.6 Beta 2. I have noticed that when I open the KM browser now ... KM seems to take longer to open. This is not a complaint, just an observation. Am I right on this ... is there a connection and have others noticed this also? ... thanks

Hi, duffy98. I too tried using the AB+ version(?) for 1.6 and it is apparently the cause of some problems with loading 1.6b2, even with the Loader.exe. The AB+ version(?) for 1.6 also seems to some times cause 1.6b2 to draw about 99% of CPU resources requiring a restart of the computer. I think I have read in this forum about some one else having this same problem. I have gone back to using 1.5.4 until 1.6 is in final release.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: AdBlock Question ...
Posted by: duffy98
Date: March 09, 2011 10:00AM

Thanks caktus for the info. I removed AdBlock Plus on KM 1.5.4 earlier today and it seems to have the speed back. I am also going to remove it from KM 1.6 B2 ... I like to switch between both KM browsers every so often. Yes, KM 1.6 will be better down the road with the final version. I hope 1.6 will have a "final" version ... I know there is talk of just going to v1.7. I don't know where v1.6 stands these days. It works OK for me ... it has flaws.

luk3Z ... also thanks for the info ... I read the links, not sure if I will remove all those items. I may just experiment one of these days, I have a backup of everything.



Edited 1 time(s). Last edit at 03/09/2011 10:08AM by duffy98.

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: ndebord
Date: March 09, 2011 10:31AM

Charlie,

I don't see that level of CPU usage, but I am using KM 1.6beta1, not 2. I have the latest Adblock Plus installed and I see like 2 to 33 percent, not 99????

N



Edited 1 time(s). Last edit at 03/09/2011 10:31AM by ndebord.

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: snuz2
Date: March 09, 2011 04:51PM

I stopped using abp because of the long load time. It seems to be related to parsing its very complete black list. I bet if you make a black list of just the few most annoying sites, it will be faster. You never notice this on FF, bcuz it takes forever to load anyway....

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: luk3Z
Date: March 09, 2011 09:58PM

Quote
snuz2
I stopped using abp because of the long load time. It seems to be related to parsing its very complete black list. I bet if you make a black list of just the few most annoying sites, it will be faster. You never notice this on FF, bcuz it takes forever to load anyway....

I don't know why you use black list subscription.
I make my black list myself based on the web sites I was - so I know what is bocked and I don't need to block everything else (my list is short and fast).
I don't want to bock all internet websites/ads. This is my list:
http://tinypaste.com/fdcdc

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: km2
Date: March 09, 2011 11:36PM

EasyList may cause some delay at start.

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: snuz2
Date: March 10, 2011 11:34AM

so you are claiming that even with the short list, you get a noticeable delay on startup?

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: ndebord
Date: March 10, 2011 12:14PM

Quote
snuz2
I stopped using abp because of the long load time. It seems to be related to parsing its very complete black list. I bet if you make a black list of just the few most annoying sites, it will be faster. You never notice this on FF, bcuz it takes forever to load anyway....

snuz2,

What do you call a long load time?

N

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: Paul
Date: March 10, 2011 12:44PM

Quote
luk3Z
Quote
snuz2
I stopped using abp because of the long load time. It seems to be related to parsing its very complete black list. I bet if you make a black list of just the few most annoying sites, it will be faster. You never notice this on FF, bcuz it takes forever to load anyway....

I don't know why you use black list subscription.
I make my black list myself based on the web sites I was - so I know what is bocked and I don't need to block everything else (my list is short and fast).
I don't want to bock all internet websites/ads. This is my list:
http://tinypaste.com/fdcdc



Very good list....just what I was looking for!



Options: ReplyQuote
Re: AdBlock Question ...
Posted by: duffy98
Date: March 10, 2011 11:17PM

luk3Z ... I put AdBlock Plus back on KM 1.5.4 today and I am going to use your list and see how that works. Might just be what I need. ... thanks

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: km2
Date: March 10, 2011 11:55PM

Quote
snuz2
so you are claiming that even with the short list, you get a noticeable delay on startup?

That depend on installed subscriptions. Just don't use old subscriptions.

http://adblockplus.org/en/getting_started

And delay on startup, not always mean delay when surf.

Delete mozctl.dll (1.5.4) and K-M will start little faster.

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: ndebord
Date: March 23, 2011 11:20AM

Just want to be clear about which version of AdBlockPlus (ABP) should be used with KM 1.6.

I hear from some that adblockpluskmeleon-1.3.5b.157 is a memory or cpu hog. I know from personal experience that adblockplus adblockplus-kmeleon-1.2.2-en-US-unofficial-0.5 seems to work OK (missing the icon(s).

Anybody care to comment on what is the stable ABP for KM 1.6???

N

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: Matt
Date: March 24, 2011 12:01AM

I haven't noticed memory leaks using 1.3.5 dev builds but try for yourself comparing both versions. BTW ABP 1.3.5 RC is out.

Options: ReplyQuote
Re: AdBlock Question ...
Posted by: ndebord
Date: March 24, 2011 12:11AM

Quote
Matt
I haven't noticed memory leaks using 1.3.5 dev builds but try for yourself comparing both versions. BTW ABP 1.3.5 RC is out.

Matt,

I saw that only some of the posters were reporting problems. My temporary solution was to go back to the stable old release in the short term.

N

Options: ReplyQuote


K-Meleon forum is powered by Phorum.