KM 1.6 and AdBlock
Posted by: ndebord
Date: November 18, 2010 08:25AM

Waldmir has said that that AdBlockPlus 1.3.1 won't work with K-Meleon. Any chance that AdBlock 1.0.2 that worked with KM 1.5.4 can be made to work with KM 1.6beta?

N

Re: KM 1.6 and AdBlock
Posted by: guenter
Date: November 18, 2010 08:59AM

Quote
ndebord
1.) Waldmir has said that that AdBlockPlus 1.3.1 won't work with K-Meleon.

2.) Any chance that AdBlock 1.0.2 that worked with KM 1.5.4 can be made to work with KM 1.6beta?

1.) W. Palant is right - I tried. Not out of the box and not with easy changes like I (a user) can do.

2.) Maybe - but IMHO with as much trouble as dega2 has had to fix with PrefsPanel and the rest of the chrome.

IMHO there are more chances and less work to fix 1.3.1 in a fashion that works.



Edited 1 time(s). Last edit at 11/18/2010 09:01AM by guenter.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: November 18, 2010 12:26PM

Quote
guenter
Quote
ndebord
1.) Waldmir has said that that AdBlockPlus 1.3.1 won't work with K-Meleon.

2.) Any chance that AdBlock 1.0.2 that worked with KM 1.5.4 can be made to work with KM 1.6beta?

1.) W. Palant is right - I tried. Not out of the box and not with easy changes like I (a user) can do.

2.) Maybe - but IMHO with as much trouble as dega2 has had to fix with PrefsPanel and the rest of the chrome.

IMHO there are more chances and less work to fix 1.3.1 in a fashion that works.

Guenter,

Guess I'll have to go to Waldmir's blog and post a beg. <weak grin>

N

Re: KM 1.6 and AdBlock
Posted by: guenter
Date: November 18, 2010 07:57PM

Quote
ndebord


Guess I'll have to go to Waldmir's blog and post a beg. <weak grin>

Has been done.


Quote
use_r

Quote
just_me
Hope, You did not forget K-Meleon, Wladimir smiling smiley. Since yesterday first beta is available http://kmeleon.sourceforge.net/wiki/kmeleon16 or http://kmeleon.sourceforge.net/download.php

Quote
Wladimir Palant
Right, and Mozilla will probably drop Gecko 1.9.1 support in a month (with Adblock Plus following shortly)...


https://adblockplus.org/forum/viewtopic.php?f=1&t=5712&sid=3d1166d0f4cfe63eb11fd3d12d8584b1

sad smiley sad smiley

We may get it for 1.7? confused smiley

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: November 20, 2010 08:58AM

Quote
guenter
Quote
ndebord


Guess I'll have to go to Waldmir's blog and post a beg. <weak grin>

Has been done.


Quote
use_r

Quote
just_me
Hope, You did not forget K-Meleon, Wladimir smiling smiley. Since yesterday first beta is available http://kmeleon.sourceforge.net/wiki/kmeleon16 or http://kmeleon.sourceforge.net/download.php

Quote
Wladimir Palant
Right, and Mozilla will probably drop Gecko 1.9.1 support in a month (with Adblock Plus following shortly)...


https://adblockplus.org/forum/viewtopic.php?f=1&t=5712&sid=3d1166d0f4cfe63eb11fd3d12d8584b1

sad smiley sad smiley

We may get it for 1.7? confused smiley

Guenter,

Aside: Anybody got the source code for the old, old Adblock 0.5??? Before Waldmir took over the project? Perhaps that might work better?

N

Re: KM 1.6 and AdBlock
Posted by: guenter
Date: November 20, 2010 05:16PM

? Chrome code has changed lately. A number of XUL extensions create new problem or do not work. I doubt that older versions work any better.

Besides. The working together of GRE, exe and kplugins is not yet very good.
Lets wait and see.



Edited 1 time(s). Last edit at 11/20/2010 05:17PM by guenter.

Re: KM 1.6 and AdBlock
Posted by: jk--
Date: November 20, 2010 07:10PM

I had a similar thought about the old adblock, I did find this link:
http://adblock.ethereal.net/Adblock_v.5/adblock-05-dev.xpi

I know I have the "Adblock 0.5 d3 nightly 43" somewhere too.
Trying to find it.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: November 20, 2010 08:24PM

Quote
jk--
I had a similar thought about the old adblock, I did find this link:
http://adblock.ethereal.net/Adblock_v.5/adblock-05-dev.xpi

I know I have the "Adblock 0.5 d3 nightly 43" somewhere too.
Trying to find it.

jk,

Good for you... I tried to find that link and failed. The nightly is the last Adblock before it switched over to AdblockPlus.

N



Edited 1 time(s). Last edit at 11/20/2010 08:24PM by ndebord.

Re: KM 1.6 and AdBlock
Posted by: jk--
Date: November 21, 2010 05:35AM

Hmm, the link is working for me, maybe you need to go to the webpage to download if you aren't spoofing the HTTP Referrer.

http://adblock.ethereal.net/Adblock_v.5

I chedked it out and the version is: 0.5.3.042

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: November 21, 2010 12:21PM

Quote
jk--
Hmm, the link is working for me, maybe you need to go to the webpage to download if you aren't spoofing the HTTP Referrer.

http://adblock.ethereal.net/Adblock_v.5

I chedked it out and the version is: 0.5.3.042

Yes, it works... I had dropped carrier (wifi hotspot) and didn't realize. <weak grin>

N

Re: KM 1.6 and AdBlock
Posted by: Alex.Tarantul
Date: December 01, 2010 03:29PM

Colleagues! Now Vladimir Palant has answered my questions concerning compatibility AdBlock Plus and K-Meleon 1.6beta.
(I am and Vladmir - Russian-speaking, therefore to me am simple to state him an essence of our problems.) smiling smiley

Who is ready to help Vladimir with work end on creation of the efficient version adblok for a K-Meleon?

Quote

Basic incompatibility is not present, updatings are necessary rather small (I have already brought them). A problem in basic that Adblock Plus for K-Meleon from version 1.0.2 did not develop in the absence of the compatible versions Gecko. For these one and a half year Adblock Plus has undergone very much essential changes, and emulation of a window of a browser which is used in K-Meleon, it is necessary to adapt. This work I in May-June of the beginnings, base changes are brought also the contextual menu works. Other parts the user interface are not functional yet, there it is necessary more works. And at me time it is not strong much, and does not impress work prospect "in a table" (by then when K-Meleon 1.6 realised, its version of Gecko will not be supported any more)

Source codes for support K-Meleon here:
https://hg.adblockplus.org/adblockplus/file/tip/kmeleon

There while there are some files with expansion js is an old code emulation of a window of a browser, it is not used any more. A new code in the module AppIntegrationKMeleon.jsm.

My blog about K-Meleon
http://kmeleon-ru.blogspot.com/



Edited 3 time(s). Last edit at 12/01/2010 03:32PM by Alex.Tarantul.

Re: KM 1.6 and AdBlock
Posted by: guenter
Date: December 01, 2010 10:57PM

Quote
Alex.Tarantul

1.) Who is ready to help Vladimir with work end on creation of the efficient version adblok for a K-Meleon?

Quote

2.) (by then when K-Meleon 1.6 realised, its version of Gecko will not be supported any more)

3.) Source codes for support K-Meleon here:
https://hg.adblockplus.org/adblockplus/file/tip/kmeleon

@Alex.Tarantul, thank You for Your effort for K-Meleon.

1.) The people that have skills, interest and time are currently working on K-Meleon core. W. Palant will need a skilled helper, who I currently do not see (unavailable).

2.) W. Palant is right. It does not make sense to invest his limited time for adapting Adblock for 1.6 unless the code adaption can be reused for K-Meleon 1.7.

I am just another user. sad smiley

But IMHO it would be best for K-Meleon to jump over GRE 1.9.1 = K-Meleon 1.6 soon. Even without spending the time for finished debugs for release. desga2 made the chrome usable -> that chrome works AFAIK on 1.9.2 also. Dorian's 1.7a shows that a K-Meleon compiles with that GRE version.

3.) Thx for the source link.

С уважением, guenter



Edited 1 time(s). Last edit at 12/01/2010 11:07PM by guenter.

Re: KM 1.6 and AdBlock
Posted by: enter
Date: December 01, 2010 11:49PM

So now the serious question is - develop 1.6 further and release it with most probably already outdated Gecko at that time OR bring K-Meleon 1.7 out of alpha stage soon?

Re: KM 1.6 and AdBlock
Posted by: guenter
Date: December 02, 2010 03:50AM

Up to the devs. They should know how they want it & which is the better solution.

And whether it makes more sense to spend the extra time needed for the release or go on without when 1.6 is a stable beta. All depends how much time and interest the dev have.



Edited 1 time(s). Last edit at 12/02/2010 04:00AM by guenter.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: December 02, 2010 01:52PM

Quote
guenter
Up to the devs. They should know how they want it & which is the better solution.

And whether it makes more sense to spend the extra time needed for the release or go on without when 1.6 is a stable beta. All depends how much time and interest the dev have.

Guenter,

Correct me if I'm wrong, but Linux still wants/needs 3.5.xxx FF and there are new releases for that engine (Gecko 1.9.1, same as KM 1.6). I believe that Firefox 3.5.16 is scheduled for December 9.

N



Edited 1 time(s). Last edit at 12/02/2010 01:53PM by ndebord.

Re: KM 1.6 and AdBlock
Posted by: guenter
Date: December 02, 2010 10:20PM

Quote
ndebord
Correct me if I'm wrong, but Linux still wants/needs 3.5.xxx FF and there are new releases for that engine (Gecko 1.9.1, same as KM 1.6). I believe that Firefox 3.5.16 is scheduled for December 9.

No idea. I take Your word for it.

I know that You can build and download a portable Firefox 3.5.16pre.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.16) Gecko/20101122 Firefox/3.5.16 tbf

But I am sure You also were also able to to build like:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.24pre) Gecko/20090921 BonEcho/2.0.0.22pre and newer until the branch's repository partly broke.

The reason that BonEcho was maintained longer was also that Linux distros had pledged commercial support until a date.

But The Firefox' release page states that it is only supported until August 2010.

Quote
Firefox 3.5 Release page
Firefox 3.5.x will be maintained with security and stability updates until August 2010. All users are strongly encouraged to upgrade to Firefox 3.6.

Source: http://www.mozilla.com/en-US/firefox/all-older.html



Edited 1 time(s). Last edit at 12/02/2010 10:25PM by guenter.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: December 02, 2010 11:48PM

Guenter,

Although they say they only support FF 3.5 until August of 2010, they have continued with releases, as I have FF 3.5.15 right now on one of my computers. I read about the December 9th release date on the WikiPedia FF 3.5 webpage.

N

Re: KM 1.6 and AdBlock
Posted by: guenter
Date: December 03, 2010 01:19AM

I already said, I take Your word for it. smiling smiley

BTW. I have the mentioned Firefoxes - else I would not have had their UAstrings.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: December 03, 2010 08:46AM

Quote
guenter
I already said, I take Your word for it. smiling smiley

BTW. I have the mentioned Firefoxes - else I would not have had their UAstrings.

Guenter,

Funny! I just go to Mozillazine and steal the UA strings from the posts there! <VBG>

N

Re: KM 1.6 and AdBlock
Posted by: 4td8s
Date: December 03, 2010 11:12AM

Quote
ndebord
Guenter,

Although they say they only support FF 3.5 until August of 2010, they have continued with releases, as I have FF 3.5.15 right now on one of my computers. I read about the December 9th release date on the WikiPedia FF 3.5 webpage.

that info on the old Firefox releases page is outdated and no longer accurate about the August 2010 "end of support" date. the folks at Mozilla haven't bothered of changing that date on that page.

And on this Firefox Planning Meeting notes page:
https://wiki.mozilla.org/Firefox/Planning/2010-12-01
There is a mention of an upcoming Firefox 3.5.17 release. A draft schedule on that one is planned for next week.

And I have yet to see Wladimir prepare a KM version of adblock+ that would work specifically for KM 1.6 beta & later. Doesn't seem like a high priority right now.



Edited 1 time(s). Last edit at 12/03/2010 11:13AM by 4td8s.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: December 03, 2010 12:27PM

Quote
guenter
Up to the devs. They should know how they want it & which is the better solution.

And whether it makes more sense to spend the extra time needed for the release or go on without when 1.6 is a stable beta. All depends how much time and interest the dev have.

Guenter,

Do you think that the work on KM 1.6 can be ported over to KM 1.7?

Similarly, if it is better to work on KM 1.7 and Gecko 1.9.2, then to my mind and for my uses the current KM 1.6 beta is good enough for everyday use (my apologies to those who use W98se) in XP PRO SP3. So efforts might better be spent working on the alpha.

P.S. After reflection, considering the amount of time needed to get KM 1.6.xx out, my uneducated opinion would be to continue some work on it to get a gold version out that can be the main browser for the near future, but put most of the work into getting a KM 1.7xxx version out whenever possible (if possible).

FF 4.xxx is a whole different ballgame as near as I can tell.

N



Edited 1 time(s). Last edit at 12/03/2010 10:28PM by ndebord.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: December 03, 2010 10:34PM

Quote
4td8s


that info on the old Firefox releases page is outdated and no longer accurate about the August 2010 "end of support" date. the folks at Mozilla haven't bothered of changing that date on that page.

And on this Firefox Planning Meeting notes page:
https://wiki.mozilla.org/Firefox/Planning/2010-12-01
There is a mention of an upcoming Firefox 3.5.17 release. A draft schedule on that one is planned for next week.

And I have yet to see Wladimir prepare a KM version of adblock+ that would work specifically for KM 1.6 beta & later. Doesn't seem like a high priority right now.

4td8s,

Thanks for the update... didn't know Mozilla wasn't keeping up with posting on releases. If chrome from KM 1.6 works with KM 1.7, then perhaps that is the direction to go. Wladimir has given the hint that IF KM goes to 1.7 and Gecko 1.9.2, that he would be more willing to port a version of Adblock 1.3 for that version.

N



Edited 1 time(s). Last edit at 12/03/2010 10:34PM by ndebord.

Re: KM 1.6 and AdBlock
Posted by: 4td8s
Date: December 25, 2010 10:04AM

Quote
ndebord
4td8s,

Thanks for the update... didn't know Mozilla wasn't keeping up with posting on releases. If chrome from KM 1.6 works with KM 1.7, then perhaps that is the direction to go. Wladimir has given the hint that IF KM goes to 1.7 and Gecko 1.9.2, that he would be more willing to port a version of Adblock 1.3 for that version.

ndebord, if you check the MozillaWiki Releases page recently, Firefox 3.5.17 would be tentatively scheduled for release on Feb. 8, 2011. Looks like the Mozilla folks haven't EOL'ed FF 3.5.x yet.

In a stunning twist of fate, Wladimir has recently decided to make an Adblock Plus for Google Chrome. Read the following blogs on this:
http://adblockplus.org/blog/status-update-2010-12-23
http://adblockplus.org/blog/adblock-plus-for-google-chrome-to-be-released-soon

so far, nothing new on a new ABP for K-meleon yet.
and yeah, I like to see KM 1.7 go the gecko 1.9.2 route. anyways Mozilla will be supporting Firefox 3.5x & 3.6x for a while since the final release of Firefox 4 hasn't been fully decided yet. more new betas of FF4 are coming in early 2011, which postpones the final release of FF4.



Edited 1 time(s). Last edit at 12/25/2010 10:08AM by 4td8s.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: December 25, 2010 12:19PM

Quote
4td8s
Quote
ndebord
4td8s,

Thanks for the update... didn't know Mozilla wasn't keeping up with posting on releases. If chrome from KM 1.6 works with KM 1.7, then perhaps that is the direction to go. Wladimir has given the hint that IF KM goes to 1.7 and Gecko 1.9.2, that he would be more willing to port a version of Adblock 1.3 for that version.

ndebord, if you check the MozillaWiki Releases page recently, Firefox 3.5.17 would be tentatively scheduled for release on Feb. 8, 2011. Looks like the Mozilla folks haven't EOL'ed FF 3.5.x yet.

In a stunning twist of fate, Wladimir has recently decided to make an Adblock Plus for Google Chrome. Read the following blogs on this:
http://adblockplus.org/blog/status-update-2010-12-23
http://adblockplus.org/blog/adblock-plus-for-google-chrome-to-be-released-soon

so far, nothing new on a new ABP for K-meleon yet.
and yeah, I like to see KM 1.7 go the gecko 1.9.2 route. anyways Mozilla will be supporting Firefox 3.5x & 3.6x for a while since the final release of Firefox 4 hasn't been fully decided yet. more new betas of FF4 are coming in early 2011, which postpones the final release of FF4.

4td8s,

Well, he is a biz, so... I'm not holding out hope.

I run the first 1.6 beta as my everyday browser now with few problems. Spellchecker only half works, but kludges make it acceptable and history I can do without until such time as it is fixed.

BUT my second browser is KM 1.7alpha. Crashes when it exits, but it runs nonetheless.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.5pre) Gecko K-Meleon/1.7.0

XP PRO SP3

N



Edited 1 time(s). Last edit at 12/25/2010 12:22PM by ndebord.

Re: KM 1.6 and AdBlock
Posted by: quoted
Date: December 25, 2010 03:53PM

Last time Wladimir Palant mentioned K-Meleon in ABP changelog on 30th November.

Re: KM 1.6 and AdBlock
Posted by: 4td8s
Date: January 14, 2011 12:26AM

Quote
quoted
Last time Wladimir Palant mentioned K-Meleon in ABP changelog on 30th November.

but his progress on the new ABP for KM is currently running at a snail's pace.
I wouldn't be surprised if I see few or no more KM updates in future changelogs for the dev builds of ABP.



Edited 1 time(s). Last edit at 01/14/2011 12:26AM by 4td8s.

Re: KM 1.6 and AdBlock
Posted by: eilath
Date: January 14, 2011 01:57AM

4td8s u read this?

Quote
Alex.Tarantul
Colleagues! Now Vladimir Palant has answered my questions concerning compatibility AdBlock Plus and K-Meleon 1.6beta.
(I am and Vladmir - Russian-speaking, therefore to me am simple to state him an essence of our problems.) smiling smiley

Who is ready to help Vladimir with work end on creation of the efficient version adblok for a K-Meleon?

R u willing 2 help? Yes? Then do so & help Wladimir & our small community. No, then go away, no1's forcing u 2 use K-Meleon. U can use Adblock Plus with a bunch of software.

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: January 14, 2011 07:10AM

Quote
eilath
4td8s u read this?

Quote
Alex.Tarantul
Colleagues! Now Vladimir Palant has answered my questions concerning compatibility AdBlock Plus and K-Meleon 1.6beta.
(I am and Vladmir - Russian-speaking, therefore to me am simple to state him an essence of our problems.) smiling smiley

Who is ready to help Vladimir with work end on creation of the efficient version adblok for a K-Meleon?

R u willing 2 help? Yes? Then do so & help Wladimir & our small community. No, then go away, no1's forcing u 2 use K-Meleon. U can use Adblock Plus with a bunch of software.

eilath,

Whoa! Where did that come from?

4td8s is merely expressing his concern about Waldmir and KM. It is a fact that Waldmir is not inclined to write anything for Gecko 1.9.1 (FF 3.5) , aka KM 1.6. Whenever KM gets to Gecko 1.9.2 (FF 3.6), aka KM 1.7, it will be on the same page as Waldmir's next to latest AdBlock and then I would think we could try to hold Waldmir's feet to the fire and ask him to do the right thing. If not, we'll have to find another solution.

N



Edited 1 time(s). Last edit at 01/14/2011 09:01AM by ndebord.

Re: KM 1.6 and AdBlock
Posted by: sickley
Date: January 14, 2011 03:03PM

I too am just concerned about the lack of abp in 1.6 and 1.7
I would use 1.6 and 1.7 as my regular browser, but there are a few sites I visit regularly that are practically unbrowseable without abp. Thus I am stuck using 1.5 for now. I'd rather not move to a different browser because quite frankly k-meleon is better than every other one I've tried, but eventually I'm going to need to move to a version with updated gecko (before certain sites decide I can no longer use them with "outdated browser"), and I refuse to browse without abp.

I know it's not the community or the developers' fault (or even abp developer's fault), but this is an appropriate place to make our voices heard no? smiling smiley

Re: KM 1.6 and AdBlock
Posted by: ndebord
Date: January 16, 2011 01:31AM

Quote
sickley
I too am just concerned about the lack of abp in 1.6 and 1.7
I would use 1.6 and 1.7 as my regular browser, but there are a few sites I visit regularly that are practically unbrowseable without abp. Thus I am stuck using 1.5 for now. I'd rather not move to a different browser because quite frankly k-meleon is better than every other one I've tried, but eventually I'm going to need to move to a version with updated gecko (before certain sites decide I can no longer use them with "outdated browser"), and I refuse to browse without abp.

I know it's not the community or the developers' fault (or even abp developer's fault), but this is an appropriate place to make our voices heard no? smiling smiley

sickley,

The only other alternative I know of is the built-in addblock.css with the fanboy listings... I guess you could manually edit Fred's list there to add in info.

N

K-Meleon forum is powered by Phorum.