General :  K-Meleon Forum
General discussion about K-Meleon. 
Backspace key keeps taking me back! How do I fix it?
Posted by: athenian200
Date: October 20, 2010 09:56PM

I'm having issues with the backspace key in K-meleon. I've just started using it, and the mapping of the Backspace key to the Back button makes it unusable for writing forum posts. Every time I hit backspace, it sends me back a page.

In Google's search box, I can use backspace to delete text without being sent back a page. On most forums, I can't do so while writing a post.


Is there anything I can do to unlink the "Back" function from the "Backspace" key? It makes absolutely no sense for a key as commonly used as backspace to be used like a function key without any modifiers, so I can hardly believe it was implemented on purpose. I would understand ALT-Backspace or CTRL-Backspace... but just backspace by itself? That was a horrible idea.

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: JamesD
Date: October 21, 2010 12:34AM

You can change the accelerator key definition yourself. Here is how to do it.

Go to EDIT - CONFIGURATION - ACCELERATORS and make the following entry.

VK_BACK = null

Save the file and that should allow backspace to work as you requested.

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: guenter
Date: October 21, 2010 01:53AM

Quote
athenian200
Is there anything I can do to unlink the "Back" function from the "Backspace" key?

It makes absolutely no sense for a key as commonly used as backspace to be used like a function key without any modifiers, so I can hardly believe it was implemented on purpose. I would understand ALT-Backspace or CTRL-Backspace... but just backspace by itself? That was a horrible idea.

Every single accelerator key can be changed/edited in the file with the method named by JamesD.

You are absolutely right, it makes no sense that those forum programmers used the backspace key for anything but for what was long time industry standard function for backspace: namely = OnePageBack (AFAIK it been in use for that ever since Mosaic and original Netscapesmiling smiley ).



Edited 1 time(s). Last edit at 10/21/2010 02:04AM by guenter.

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: siria
Date: October 21, 2010 02:15AM

Not quite sure, but wasn't that a bug, probably with KM1.6 on some websites? I dimly remember having read about it here some time ago...
From how I understand it, the backspace key only flips back one page as long as the cursor is NOT inside an input field, and that's exactly how it's always been working for me, in all my forums and other input pages, and still does. Hmm... really can't remember for sure, but there was *something* with this issue discussed here, and guess someone knew the reasons and partial fixes...


Okay, did now a little forum search for backspace, let me summarize it:

Someone had backspace probs on FLASH pages:
Suggestion by guenter:
VK_BACK = VK_BACK or
VK_BACK =
Browser restart needed of course

Suggestion by James above:
Go to EDIT - CONFIGURATION - ACCELERATORS and make the following entry.
VK_BACK = null

Do those 3 solutions have the same effect? smiling smiley

Another suggestion by jmillar a bit ago:
Use cursor arrows and the delete key instead

and by desga:
you can use Ctrl+Backspace or Shift+Backspace or Alt+Backspace to avoid the default ID_NAV_BACK accelerator for the Backspace key.

(Crazy, that was only a few weeks ago and I had already forgotten that shift-trick!!)



Edited 2 time(s). Last edit at 10/21/2010 02:50AM by siria.

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: JamesD
Date: October 21, 2010 03:45AM

@ siria

You are right about different actions for backspace depending on if the user has the cursor in a text entry field. I just went back into the acel.cfg file and commented out my previous suggestion. When I use backspace while typing this reply the result is to backspace and delete previous keystrokes. When I move the cursor outside the text area the result is to go to the previous page. This is on KM 1.6.0a4. I have not yet tested on older versions.

@ athenian200

You mentioned forum pages was where you had the problem. Can you let us know which version of KM you are using please? I infer from your post that you are trying to backspace and remove previous keystrokes within a text entry field. Please let us know if that is correct.



Edited 1 time(s). Last edit at 10/21/2010 03:50AM by JamesD.

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: desga2
Date: October 23, 2010 11:08PM

This is a Gecko 1.8.1.x problem in old KM 1.5.4. New versions 1.6.x with Gecko 1.9.1.x haven't this problem.

For KM 1.5.4 I recommended change it in \KM\defaults\settings\accel.cfg in line 77 replace:
VK_BACK   = ID_NAV_BACK

by Shift+Backspace:
#VK_BACK   = ID_NAV_BACK
SHIFT VK_BACK   = ID_NAV_BACK

Why I use Shift key?
Because there are default Gecko shortcut keys for:
Ctrl+Backspace => Delete a word.
Alt+Backspace => Undo.

K-Meleon in Spanish



Edited 2 time(s). Last edit at 10/23/2010 11:10PM by desga2.

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: siria
Date: October 24, 2010 05:11AM

Thanks for clearing this up, desga. Short and precise explanation smiling smiley

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: athenian200
Date: October 27, 2010 08:44PM

Quote
JamesD

@ athenian200

You mentioned forum pages was where you had the problem. Can you let us know which version of KM you are using please? I infer from your post that you are trying to backspace and remove previous keystrokes within a text entry field. Please let us know if that is correct.

Yes, that is correct.

However, I already managed to fix the problem by modifying accel.cfg. That's probably the best solution for me, because I really dislike the default functionality of the Backspace key... I enter information into text fields a lot, and it's WAY too easy to accidentally go back a page while trying to edit a post.

My KM version reports itself as 1.7.0. I got that because I thought it was the latest version.

Options: ReplyQuote
Re: Backspace key keeps taking me back! How do I fix it?
Posted by: siria
Date: November 21, 2010 10:27PM

Perhaps it should be mentioned yet, if the backspace key throws you back, you can usually click "Forward" to return to your half-finished post.
At least that's how it works in my forums, but am not sure about facebook and those other sites with that bug. Am not a member there and cannot test, my forums are of the normal kind ;-)

PS: The latest development version currently is KM1.6 beta1. Still some bugs of course, being the first beta version, but otherwise usable.

Wouldn't try yet that older 1.7alpha from last May, it was just meant experimental, posted with a warning that it was tested for only for 5 minutes!

Quote
Dorian (announcing the now outdated KM1.6a4)
New build. It fixes the high cpu usage of previous 1.6 build.

http://sourceforge.net/projects/kmeleon/files/k-meleon-dev/

There is also a ... 1.7 version, with gecko 1.9.2
No typeahead for this one, since it changed. It uses js now, and I don't know how to make it works. I warn you, I only tested it for 5 mins or so.


Options: ReplyQuote


K-Meleon forum is powered by Phorum.