General :  K-Meleon Forum
General discussion about K-Meleon. 
KM keeps crashing.
Posted by: caktus
Date: August 05, 2010 12:41AM

A dozen or more times a day KM 1.5.4 crashes. It has crashed most often when clicking on "Preview" or "Submit" here in the KM forum. When it crashes, I some times get a Crash Report dialog in which case I usually sent the report but some times the crash report stops responding before I can send. The most recent crash was when I clicked on
"Submit" while attempting to create a second post at http://kmeleon.sourceforge.net/forum/read.php?1,109259 to report that the word "s u g g e s t" (w/o the spaces) is being flagged as a word "banned from use."

Yesterday I had just reinstalled 1.5.4 partly for this very reason. Perhaps the problem carries over to this new installation because I used the same profile. Before I delete/remove all things KM and start with a clean installation of KM, does anyone have any
s u g g e s t i o n s how I might first fix the problem before bothering with a new clean install of 1.5.4?. I had reported some other problems at http://kmeleon.sourceforge.net/forum/read.php?1,108658 that so far seem to be fixed.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: KM keeps crashing.
Posted by: siria
Date: August 05, 2010 01:38AM

Then I'd sug-gest to just test with an independant portable KM first, before deleting anything...
Whow you're right, sug-gest is banned - crazy! Although, upon further testing, it is only the "ugg" part in it...
Even crazier!! grinning smiley Hmm, I sure hope that can be fixed again...

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: JujuLand
Date: August 05, 2010 02:59AM

just create a new profile and test it. It's probably a broken profile which is the reason of theses crashes.

After you will just have to keep some files (bookmarks, s file, ...)

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 1 time(s). Last edit at 08/05/2010 02:59AM by JujuLand.

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: caktus
Date: August 06, 2010 01:56AM

I copied the contents of the old Profile folder to the new folder. It has caused spellcheck to stop offering optional corrections for misspelled words, but otherwise, so far, so good.

Thanks.

Edit: I wish I could remember how I got Spell Check to work in the previous KM installation. I even installed it to the new install of KM with KEM and get "installed successfully from KEM, deleted the .dat's from Componants and restarted KM, first left click on the misspelled word then right click and click on Spell Checker but still no dice.

Anyone have any ideas how I might get Spell Check to work?

Thank you.

Charlie

~~If it ain't broke, why screw it up?~~




Edited 1 time(s). Last edit at 08/06/2010 03:14AM by caktus.

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: JujuLand
Date: August 06, 2010 03:06AM

When you keep files in an old profile, you must not copy all the files and obviously not prefs.js, as it's often this file which is broken? but you can in some case keep some prefs.

Generally, here are the files to be kept:

bookmarks.html
cookies.txt
gestures.xml (if you have modified some gesture)
xxxxxx.s (these are the passwords and a few other infos.)
Iconcache.dat (if it's not bad, as sometimes)
search.xml (if modified since profile creation)

To keep sfile, you must go to a site which requires a password, and after modify the pref to use the sfile you have kept, or rename the sfile with the name found in prefs.

For spellcheck, you just perhaps have to keep the concerned prefs in old prefs.js, or just set again parameters.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Options: ReplyQuote
Re: KM keeps crashing.
Posted by: 4td8s
Date: August 08, 2010 09:53PM

what version of Windows are you using, caktus?
and what plugins and/or KM addons/extensions do you have installed?

I no longer use KM 1.5.4 under Vista as I've gotten crashes with that version after closing the browser window. Just about all my crashing problems have gone away when using KM 1.6a4 under Vista.

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: caktus
Date: August 10, 2010 12:46PM

Finally got Spell Check working after reinstalling it with KEM. I am finding that KEM is a handy extension. Thank you to who ever created this little gem.smiling smiley

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: KM keeps crashing.
Posted by: caktus
Date: August 13, 2010 11:12PM

This info will not post as it apparently contains a word that is erroneously banned. and it is a very long post so I have saved it as a Word.doc at the following URL:
http://www.mediafire.com/?uz74psypikggcvo

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: KM keeps crashing.
Posted by: R4ND0M
Date: August 13, 2010 11:46PM

Quote
caktus
This info will not post as it apparently contains a word that is erroneously banned. and it is a very long post so I have saved it as a **Word.doc** at the following URL:
http://www.mediafire.com/?uz74psypikggcvo

http://en.wikipedia.org/wiki/Pastebin

?

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: SoerenB
Date: August 14, 2010 01:02AM

Hi, Charlie,

have you tried with the Magnifier extension uninstalled?

(Manually:
Exit KM AND the loader
Rename the magnifier.kmm and wservices.kmm in the macros folder to, say, --.kmx
"a_lens.exe" in the tools folder & "magnifier.ini" in the kmextensions folder (if that one exists) may stay untouched.
Delete compreg.dat and xpti.dat from the components folder. Start KM)

(If you need a magnifier badly, you're most likely to own a real glass loupe - maybe that will do for testing?)

If crashing stops, either the macro is buggy or it was badly installed.

That Toluna site causes a heap of css errors here, too, but it does display ok (machine A).

Maybe it would be a good idea to replace that as your homepage until you have sorted out things ...

Cheers
SoerenB

No more own machines, because of addiction.
Don't know when I'll be back to normal ...

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: desga2
Date: August 14, 2010 01:48AM

@ caktus:
Download Magnifier again, your magnifier.kmm file is corrupted or incomplete.

This errors in Magnifier were detected and fixed one year ago.

But I think this extension have a bad method to run.
Extension must be work with one kmm file only, because K-Meleon loads macros in alphabetical order and function in others macro files can be needed to loaded before than others. This can be a big cause of your problems.
As this Extension for example;
Magnifier have two macro files; magnifier.kmm and wservices.kmm
But wservices.kmm need to load first because this create the "Web Services" submenu in "Tools" menu.
Else menu option to Magnifier can't be created because the submenu is not found.
Alphabetical order in macro folder is;
...
magnifier.kmm
...
wservices.kmm
....

magnifier.kmm macro file is loaded before than wservices.kmm.

I propose change Extension method to integrate code wservices.kmm in magnifier.kmm and not include wservices.kmm in Extension.

This is the code fixed for: C:\Documents and Settings\Owner\Desktop\New KM\macros\magnifier.kmm

# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)

# ---------------- magnifier menu ------------------------------------------------
#
# Dependencies	: main.kmm (Go)
# Resources	: -
# Preferences	: -
#
# --------------------------------------------------------------------------------

$_tool_path=getfolder(RootFolder)."\\Tools";

magnifier{
exec($_tool_path."\\a_lens.exe");
}

magnifier_BuildMenu{
setmenu("WebServices",popup,"Web Services");
setmenu("Web Services",macro,"Magnifier Plus",magnifier);
}

$OnInit=$OnInit."magnifier_BuildMenu;";

# --------------------------------------------------------------------------------
$macroModules=$macroModules."magnifier;";


About http://us.toluna.com/scripts/Pages/Home.js error, this is a JS error in a website that you are browsing or not?.
I don't think you have some macro to load this page, if you aren't browsing for this site it's possible you have some adware/spyware in your system.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 08/14/2010 01:52AM by desga2.

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: SoerenB
Date: August 14, 2010 02:02AM

Quote
myself
macro is buGgy

I'm sure now. Give me until monday night to come up with an own version - with loupe settings more flexible, too.

edit: desga2 was faster ...

This does NOT mean it surely IS the reason for your crashes, but it could well be ...

Cheers
SoerenB

No more own machines, because of addiction.
Don't know when I'll be back to normal ...



Edited 1 time(s). Last edit at 08/14/2010 02:06AM by SoerenB.

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: caktus
Date: August 15, 2010 10:53AM

Thank you, Guy's. I am out of town and away from my machine right now, but when I return home next week I will try your sug-gestions and see if I can work things out.

Thank you. Ya'll have a great day.smiling smiley

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: KM keeps crashing.
Posted by: disrupted
Date: August 17, 2010 03:51AM

desga, i don't believe having a second speciality macro can be a cause of any problems.. even when kmeleon alphabetically builds them. the menu macros are all parsed with the init event meaning that all the menus will be built and drawn before the window is launched as opposed to startup.

you can test the magnifier with a new profile where no extensions/macrps have even been installed(no special macros have been defined before)..the magnfier submenu will be built normally inside the second macro. this is the same idea as the default sendto macro.. even if you write a macro that is alphabetically-precedent to sendto.kmm but uses its menu it will still display in send to menu properly regardless of what letter its name starts with

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: siria
Date: August 17, 2010 04:36AM

Oh, webservices again? Just today there was another thread, and sickley discovered there are 2 versions of this menu out there, one that creates "Web Services" and the other creating "Extra Services", but both using the same buildmenu-command, therefore overwriting the other one...
http://kmeleon.sourceforge.net/forum/read.php?9,109633

Creating that menu again in the magnifier menu may work fine for this one, but wouldn't it duplicate the menu, if wservices.kmm works too? At least that's my experience with my own macro struggles ;-)



Edited 1 time(s). Last edit at 08/17/2010 04:39AM by siria.

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: caktus
Date: August 18, 2010 03:33AM

SorenB and desga2

Toluna is a trusted social networking site I have been using for about a year with no problems. But I have set it to my Home Page as sug-gested. BTW, what difference can be made by setting it as my Home Page make?confused smiley

On Sunday evening I made the changes you Guy's sug-gested and all seemed fine until today (Tuesday afternoon) when 1.5.4 again began crashing. While I cleared the Error console, there are no errors listed, but the console indicates many new css warnings. Most of the css warnings apply to Toluna, but Toluna seems to be working fine.When I attempted to entirely uninstall the magnifier.kmm, the files no longer exists. Also, all of the global macros "All Files" icons have changed to Note Pad icons. Also, all of the User-Defined macros "All Files" icons have changed to Window Installer icons and when I attempt to save them as "All Files" I get a message that the file "already exists" and asking if I want to "replace it." When I click "Yes" the file icon remains a Windows Installer or Note Pad icon. Also, when I attempt to install, repair or uninstall the file, I get a message that "This installation package could not be opened. Verify that the package already
exists....." When I copy and paste the data into new text documents and attempt to save as "All Files" again I get the message the "The file already exists and when I click "Yes" again it is saved with a Windows Installer or Note Pad icon, this problem also occurs when I have previously deleted the old copy of the macro. The macros otherwise, seem to be working properly.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: KM keeps crashing.
Posted by: SoerenB
Date: August 18, 2010 04:27PM

Hi, caktus,
I'm sorry it's still crashing.

Quote

BTW, what difference can be made by setting it as my Home Page make?
console indicates many new css warnings. Most of the css warnings apply to Toluna,

Well, trying a diagnose could be made easier by, e.g., freeing the console from unnecessary clutter, and excluding suspects. So it should not just have been "don't have it as your homepage for a while", but: "don't visit that site for a while."

Quote

...to uninstall the magnifier.kmm, the files no longer exists

Very strange.

The notepad icon thing: my .kmm's show that too - because I told Windows once to always open them in notepad, probably - but that must not necessarily be the reason in your case; considering that installer icon issue, it probably isn't (or not the only one).

Charlie, for helping us helping you, please do us some favors:

(Windows UI texts are my translations from my german XP, may differ slightly from what you really see - ).

1) go to Explorer -> Extras menu - Folder Options -> "View" tab (second tab).
2) Search for the tickBox: "Hide extensions of known file types" (or so .., its the 6th box here.
3) Untick that, click "Apply", click "OK".
4) Maybe it's a good idea to log off and on again now,from/to your Windos user account.

5) go to your "Program Files\K-Meleon\macros" folder.
6) go to -> View, tick "Details", adjust the column widths so as to show as much meaningful info as you can in a screenshot (-I hope your font size is not too small...)
7) make a screenshot

8) repeat steps 6 & 7 for the folder you reach FROM K-Meleon, via edit -> Configuration -> Profile Folder -> the macros folder in there.

Post those screenshots, please. Maybe someone gets a clue from that ...

Cheers
SoerenB

No more own machines, because of addiction.
Don't know when I'll be back to normal ...



Edited 1 time(s). Last edit at 08/18/2010 04:28PM by SoerenB.

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: SoerenB
Date: August 18, 2010 04:42PM

... or, forget that rather lengthy post of mine, do as siria wrote above: get an independent portable fresh install with a fresh profile, don't customize / optimize / add many things at a time, before testing for , say, two days?
Keep a copies of the whole folder before making new changes. That way, you may detect the culprit one day.
Tell us what you changed between your last "stable" backup and the first crashing version.

Cheers
SoerenB

No more own machines, because of addiction.
Don't know when I'll be back to normal ...

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: caktus
Date: August 19, 2010 08:25AM

Quote
SoerenB
... or, forget that rather lengthy post of mine, do as siria wrote above: get an independent portable fresh install with a fresh profile, don't customize / optimize / add many things at a time, before testing for , say, two days?
Keep a copies of the whole folder before making new changes. That way, you may detect the culprit one day.
Tell us what you changed between your last "stable" backup and the first crashing version.

Thank you. I will give this a try and see where it leads. It will probably turn out to be something so simplesurprised smiley that I could kick my self in the head.grinning smiley

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: KM keeps crashing.
Posted by: SoerenB
Date: August 19, 2010 02:16PM

Hi, caktus,

..good!

Wouldn't be a bad idea to follow my steps 1 to 4 from above, though.
Never miss a wrong file extension any more ...
Plus, you'll be able to see faked extensions when receiving bad mail attachments via Outlook Express.
Not a very common problem nowadays, I know ...

Cheers
SoerenB

No more own machines, because of addiction.
Don't know when I'll be back to normal ...

Options: ReplyQuote
Re: KM keeps crashing.
Posted by: caktus
Date: September 02, 2010 01:32PM

Quote
SoerenB
Hi, caktus,

..good!

Wouldn't be a bad idea to follow my steps 1 to 4 from above, though.
Never miss a wrong file extension any more ...
Plus, you'll be able to see faked extensions when receiving bad mail attachments via Outlook Express.
Not a very common problem nowadays, I know ...

Sorry it took me so long to respond back. So many things have been going on lately. I always have "Hide extensions of known file types" unticked as it keeps me from getting confused. Well, sometimes. I learned that the macro files have the Notepad icon because they were created with an empty "New Text Document.txt" file that I use for convenience. When I "Save as "All Files" the new macro file replaces the "New Text Document.txt" however, the empty
"New Text Document.txt" file remains in the macro folder.

I started over from scratch again and after installing the macros I usually use, all was fine. I have been installing my desired extensions (not the magnifier, of course) one at a time, and so far so good.

But extensions installed with KEM do not work for some reason. KEM seems to download the extensions, reports "Success" and restarts the browser (1.5.4) but the extensions installed with KEM do not work, although the extension files appear installed in the correct directories. Even manually deleting the compreg.dat and xpti.dat and restarting the browser does not help. Also, the KEM's "Installed extensions:" drop-down menu does not show the new extensions.

I am, however, able to successfully, manually install extensions using .7z tool and selecting > "Extract here." Then after manually deleting compreg.dat and xpti.dat and restarting the browser, the new extensions work as they should. Also, the KEM "Installed extension:" drop-down menu shows the manually installed extensions.

Being able to use the KEM would be a great convenience but I can live with out it.

Edit: The crashing problem seems to have been caused by a Youtube Fix .css edit. After removing the .css edit a few hours ago, the crashing problem seems be solved.

Edit: A day after removing the Youtube Fix .css edit and still installing more extensions, KM is working flawlessly.smiling smiley

Charlie

~~If it ain't broke, why screw it up?~~




Edited 4 time(s). Last edit at 09/03/2010 09:56PM by caktus.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.