General :  K-Meleon Forum
General discussion about K-Meleon. 
Why Won't Walgreens Ad Let Me Browse In HTML?
Posted by: markxxx
Date: August 01, 2010 07:19PM

This is an oddity I can't figure out.

I go to www.walgreens.com and I go to look at their weekly ad.

It gives you the option of viewing the ad in FLASH (broadband) or HTML.

I used to choose HTML (I hate flash) and all was OK smiling smiley

For the last three weeks I noticed no matter how many times I click on HTML I can't get it to work. It always defaults back to broadband (Flash).

I can view it in IE8 in HTML.

Just out of curiosity I can go to IE8 and choose HTML then copy the URL and paste the URL back into K-Meleon and it lets me view the ad in HTML in K-Meleon.

So I don't think it's a K-Meleon problem, but I was just wondering what was up. It's not a huge deal but I thought someone who knew something about such things could give me some insight on it

Thanks

BTW here's the URL for the HTML version

http://
walgreens.shoplocal.com/walgreens/Default.aspx?action=browsepagelarge&storeid=2428966&promotioncode=Walgreens-100801&pagenumber=1


Here's the URL for the flash version


http://
walgreens.shoplocal.com/walgreens/Default.aspx?action=browsepageflash&storeid=2428966&promotioncode=Walgreens-100801&pagenumber=1

Options: ReplyQuote
Re: Why Won't Walgreens Ad Let Me Browse In HTML?
Posted by: guenter
Date: August 01, 2010 08:57PM

The behaviour is probably from a faulty browser switch (sniffer that redirects).
When You are past it e.g. after You pasted the URL into K-Meleon all can work ok.

Default procedure if You suspect a page to have such a faulty switch:

Try with Tools/User Agent set to firefox. If that is the solution install
K-Meleon extension AgentSwitcher and add Walgreens to the list of stupid sites that must be cheated by sending a false User Agent string.

Options: ReplyQuote
Re: Why Won't Walgreens Ad Let Me Browse In HTML?
Posted by: markxxx
Date: August 04, 2010 01:20PM

Thanks I tried what you said

I cleared out my cache, I cleared my cookies, then I set the User agent to Firefox. Still no luck.

As I said, it's not a big deal but I thought I'd post it in case it was a bug. Sounds like it's bad scripting or something

Options: ReplyQuote
Re: Why Won't Walgreens Ad Let Me Browse In HTML?
Posted by: JamesD
Date: August 04, 2010 06:26PM

@ markxxx

Which version of KM are you using. I had no trouble see either version in KM 1.6.0a4. The site may use something of HTML5. If you use 1.5.4 that HTML5 part might not be supported.

Edit:
I tried my 1.5.4 and could see the page OK. It is not a HTML5 problem.



Edited 1 time(s). Last edit at 08/04/2010 08:42PM by JamesD.

Options: ReplyQuote
Re: Why Won't Walgreens Ad Let Me Browse In HTML?
Posted by: ndebord
Date: August 04, 2010 08:18PM

I'm using KM 1.5.4 and shop at Walgreens too.

http://walgreens.shoplocal.com/walgreens/Default.aspx?action=browsepagelarge&storeid=2429627&promotioncode=Walgreens-100801&pagenumber=1

Above is the weekly shoppers ad. I'm reading it with zero problems in HTML.

I use 8 megs of RAM for memory and an 8 meg ramdisk for disk cache.

I used the default agent switcher setting and it did not change the bad list to include Walgreens for FF user agent.

XP PRO, SP3, Pentium M (THinkpad T40)

N



Edited 1 time(s). Last edit at 08/04/2010 08:19PM by ndebord.

Options: ReplyQuote
Re: Why Won't Walgreens Ad Let Me Browse In HTML?
Posted by: desga2
Date: August 05, 2010 03:16AM

http://
walgreens.shoplocal.com/walgreens/Default.aspx?action=browsepagelarge&storeid=2428966&promotioncode=Walgreens-100801&pagenumber=1

http://
walgreens.shoplocal.com/walgreens/Default.aspx?action=browsepageflash&storeid=2428966&promotioncode=Walgreens-100801&pagenumber=1

Seems this variable "action" in URL could be stored in some cookie.
Check you are accepting all cookies in Preferences (F2).

K-Meleon in Spanish

Options: ReplyQuote


K-Meleon forum is powered by Phorum.