General :  K-Meleon Forum
General discussion about K-Meleon. 
KM 1.7.0a crashes everytime after closing browser window
Posted by: 4td8s
Date: June 09, 2010 03:00AM

After trying out K-Meleon 1.7.0a on my Win2000, XP and Vista computers, it keeps on crashing everytime I close the KM 1.7.0a browser window.

anyone else who have tested KM 1.7 alpha experience this problem on their computers?

looks like it's not stable enough to recommend for daily use.

Options: ReplyQuote
Re: KM 1.7.0a crashes everytime after closing browser window
Posted by: siria
Date: June 09, 2010 03:11AM

grinning smiley
Quote
Dorian
There is also a ... 1.7 version, with gecko 1.9.2
No typeahead for this one, since it changed. It uses js now, and I don't know how to make it works. I warn you, I only tested it for 5 mins or so.
Certainly doesnt sound like it was even remotely meant for real use yet grinning smiley

Options: ReplyQuote
Re: KM 1.7.0a crashes everytime after closing browser window
Posted by: CJ
Date: June 09, 2010 01:59PM

Quote
4td8s
anyone else who have tested KM 1.7 alpha experience this problem on their computers?

Yes, does it every time on Win7 (32bit).
"K-Meleon has stopped working. Press OK to close the program".

The message comes up as soon as the window disappears. I've gone to 1.6.0a4 instead and, apart from some gaps in the preferences settings, it's working beautifully.

Options: ReplyQuote
Re: KM 1.7.0a crashes everytime after closing browser window
Posted by: 4td8s
Date: June 14, 2010 10:52PM

Quote
siria

Certainly doesnt sound like it was even remotely meant for real use yet grinning smiley

yea. only a minor setback. guess I'll wait for a more stable alpha release of KM 1.7, perhaps when KM 1.6 reaches beta or RC smiling smiley

time to ditch the current KM 1.7a and switch back to KM 1.6a4

Options: ReplyQuote
Re: KM 1.7.0a crashes everytime after closing browser window
Posted by: SoerenB
Date: August 31, 2010 02:15PM

Hi, all,

I tried updating the 1.7.a0 with the relevant files from 1.6.a4 cp4 from here - with success.

(Well, I did that in 3 steps, weeks & days in between, no documentation - so better not ask ME for a HowTo)

On quick first inspection, I didn't find a "Preferences" section not displaying or working ok.

There's only that "Crash on Exit" thing mentioned above (which does NO real harm here), and one little glitch (see below), otherwise this could go as a very good alpha2.

The glitch I see here: the order of some buttons' and some extensions' menus is a bit muddled (?).
This may well be due to an error or some over-customizing of mine.
It's quite obvious in the useragentswitcher's menu.
IF some could reproduce it, that would point to a change, or fault, in 1.7's menu handling?

EDIT: found another hint indicating a general menu problem: the context menu in about:config shows the "SelectedText" menu.

Is this of any help for detecting the crashes' cause?

- But do take your own precious time, devs. No need to hurry - I just liked playing aroung (again).

Cheers
SoerenB

is: I'm back, on wine in some (!) linuxes - speaking of addiction ...

was: No more own machines, because of addiction.
Don't know when I'll be back to normal ...



Edited 1 time(s). Last edit at 08/31/2010 02:47PM by SoerenB.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.