HOW-TO proxy support - read
Posted by: Argyle
Date: August 24, 2000 12:10AM

Quit your bitching. K-Meleon supports proxies...

Go to C:\Program Files\K-Meleon\defaults\pref

See that file named all.js ? Open it with you text editor of choice.

Find the lines that say:

pref("network.proxy.autoconfig_url", "");
pref("network.proxy.type", 0);
pref("network.proxy.ftp", "");
pref("network.proxy.ftp_port", 0);
pref("network.proxy.gopher", "");
pref("network.proxy.gopher_port", 0);
pref("network.proxy.news", "");
pref("network.proxy.news_port", 0);
pref("network.proxy.http", "");
pref("network.proxy.http_port", 0);
pref("network.proxy.wais", "");
pref("network.proxy.wais_port", 0);
pref("network.proxy.ssl", "");
pref("network.proxy.ssl_port", 0);
pref("network.proxy.socks", "");
pref("network.proxy.socks_port", 0);
pref("network.proxy.no_proxies_on", "");

Yes, that's where the configuration exists.

I did the simple thing and opened the .js file from Netscape 6 and did a cut and paste. I deleted the corresponding proxy lines from the all.js file.

Restart k-meleon and your in business.

My config lines look like:

user_pref("network.proxy.autoconfig_url", "tdc-intranet.wds.largemegacorp.com/auto.cfg");
user_pref("network.proxy.http", "web-proxy.wds.largemegacorp.com");
user_pref("network.proxy.http_port", 8080);
user_pref("network.proxy.type", 1);

Yours will differ. Do not use my config for your browser. You need to know your own proxy settings, I'm just showing you where to put them.

Understand? k thx

RE: HOW-TO proxy support - read
Posted by: Gord
Date: August 24, 2000 01:46AM

Wow...
worked like a charm.

RE: HOW-TO proxy support - read
Date: August 24, 2000 08:47AM

I couldn't understand and set "network.proxy.autoconfig_url".
Could you tellme what is and how to decide this?

RE: HOW-TO proxy support - read
Posted by: stinkf
Date: August 24, 2000 09:28PM

And it works! Thanks a lot. I tried to do the same, but left out the "user_" part. I think this browser will be the one I am going to use from now on.

RE: HOW-TO proxy support - read
Posted by: Nguyen
Date: August 25, 2000 12:39AM

Cool

RE: HOW-TO proxy support - read
Posted by: Argyle
Date: August 26, 2000 05:36AM

If you don't have an autoconfig URL, just enter a valid proxy server address into the lines:

pref("network.proxy.http", "");
pref("network.proxy.http_port", 0);





RE: HOW-TO proxy support - read
Date: August 26, 2000 08:58AM

Thanks, Argyle!
I'll try again. (after my PC returns from repairing...)

K-Meleon forum is powered by Phorum.