: K-Meleon Forum
K-Meleon development related discussions.
[quote=siria] Basically I support that guideline strongly too, it makes a lot of sense and is important to avoid bugs. So if a macro is meant for direct use in menus or buttons, I usually make sure to have its name starting with the kmm-name too. But there's a limit, I just feel that it can get "too much", regarding readability of a code. At some point it starts getting too confusing and all the (just example) privileges are dancing before my eyes like snowflakes... ;-) Just my personal opinion of course :) And don't care much about other peoples macros, if I don't need to edit them - to each their own! Just for my own ones have decided for a compromise: to use abbreviations for 'private' helper macros and global variables, that should keep them unique enough. E.g. _OnEv_ instead of _OnEventCheck_ each time. Only for secondary macros, not the ones in the menus and buttons, and mostly not for OnEvent-variables (used in $OnLoad etc.), those get the full name. But especially for non-global variables (like loop-counting) it's really not needed, and IMO the code gets a lot easier to understand if those are nice and short ($_page or $_nr etc.). But perhaps I'm just losing overview faster than you :-)[/quote]
K-Meleon forum is powered by